summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVadim A. Misbakh-Soloviov <mva@mva.name>2014-11-04 07:47:51 +0600
committerVadim A. Misbakh-Soloviov <mva@mva.name>2014-11-04 07:47:51 +0600
commit5bb8fb86e5eb68ad736d3e7af2fbce26385135d8 (patch)
tree49e2c73cf577222ca3b0df291d45d1f2fc245ac4 /dev-lua/lua-getopt/lua-getopt-9999.ebuild
parent[app-editors/neovim] Fixed (+aded msgpack dependency). TODO: LuaJIT FFI bindi... (diff)
downloadlua-5bb8fb86e5eb68ad736d3e7af2fbce26385135d8.tar.gz
lua-5bb8fb86e5eb68ad736d3e7af2fbce26385135d8.tar.bz2
lua-5bb8fb86e5eb68ad736d3e7af2fbce26385135d8.zip
[dev-lua/*] Fix luajit compat (+added some deps)
Signed-off-by: Vadim A. Misbakh-Soloviov <mva@mva.name>
Diffstat (limited to 'dev-lua/lua-getopt/lua-getopt-9999.ebuild')
-rw-r--r--dev-lua/lua-getopt/lua-getopt-9999.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-lua/lua-getopt/lua-getopt-9999.ebuild b/dev-lua/lua-getopt/lua-getopt-9999.ebuild
new file mode 100644
index 0000000..bf4dc54
--- /dev/null
+++ b/dev-lua/lua-getopt/lua-getopt-9999.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: This ebuild is from Lua overlay; Bumped by mva; $
+
+EAPI="5"
+
+inherit toolchain-funcs git-r3
+
+DESCRIPTION="Lua getopt module (simplified)"
+HOMEPAGE="https://github.com/jjensen/lua-getopt"
+EGIT_REPO_URI="https://github.com/jjensen/lua-getopt"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS=""
+IUSE="luajit"
+
+RDEPEND="
+ !luajit? ( dev-lang/lua )
+ luajit? ( dev-lang/luajit:2 )
+"
+DEPEND="
+ ${RDEPEND}
+ dev-util/pkgconfig
+"
+
+
+src_install() {
+ local lua=lua;
+ use luajit && lua=luajit;
+ insinto "$($(tc-getPKG_CONFIG) --variable INSTALL_LMOD ${lua})"
+ doins src/getopt.lua
+}