aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJory Pratt <anarchy@gentoo.org>2020-02-15 21:05:42 -0600
committerJory Pratt <anarchy@gentoo.org>2020-02-15 21:08:22 -0600
commit6c3a5ad5c8ab9377eaefb286aa45d6b19cb20501 (patch)
tree4a70b4b4c95f7f0ab2e39975f9b5596ce23d5d3c
parentwww-client/firefox: Fix lto/pgo build (diff)
downloadmozilla-6c3a5ad5c8ab9377eaefb286aa45d6b19cb20501.tar.gz
mozilla-6c3a5ad5c8ab9377eaefb286aa45d6b19cb20501.tar.bz2
mozilla-6c3a5ad5c8ab9377eaefb286aa45d6b19cb20501.zip
www-client/firefox: Fix llvm9 build failure
Closes: https://bugs.gentoo.org/704924 Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Jory Pratt <anarchy@gentoo.org>
-rw-r--r--www-client/firefox/files/firefox-73.0_fix_llvm9.patch19
-rw-r--r--www-client/firefox/firefox-73.0.ebuild1
2 files changed, 20 insertions, 0 deletions
diff --git a/www-client/firefox/files/firefox-73.0_fix_llvm9.patch b/www-client/firefox/files/firefox-73.0_fix_llvm9.patch
new file mode 100644
index 00000000..e12417e6
--- /dev/null
+++ b/www-client/firefox/files/firefox-73.0_fix_llvm9.patch
@@ -0,0 +1,19 @@
+diff --git a/config/gcc-stl-wrapper.template.h b/config/gcc-stl-wrapper.template.h
+--- a/config/gcc-stl-wrapper.template.h
++++ b/config/gcc-stl-wrapper.template.h
+@@ -32,6 +32,14 @@
+ # define moz_dont_include_mozalloc_for_cstdlib
+ #endif
+
++#ifndef moz_dont_include_mozalloc_for_type_traits
++# define moz_dont_include_mozalloc_for_type_traits
++#endif
++
++#ifndef moz_dont_include_mozalloc_for_limits
++# define moz_dont_include_mozalloc_for_limits
++#endif
++
+ // Include mozalloc after the STL header and all other headers it includes
+ // have been preprocessed.
+ #if !defined(MOZ_INCLUDE_MOZALLOC_H) && \
+
diff --git a/www-client/firefox/firefox-73.0.ebuild b/www-client/firefox/firefox-73.0.ebuild
index c4fb0b23..6e104cb5 100644
--- a/www-client/firefox/firefox-73.0.ebuild
+++ b/www-client/firefox/firefox-73.0.ebuild
@@ -258,6 +258,7 @@ src_prepare() {
eapply "${WORKDIR}/firefox"
eapply "${FILESDIR}/${PN}-73.0_fix_lto_pgo_builds.patch"
+ eapply "${FILESDIR}/${PN}-73.0_fix_llvm9.patch"
# Allow user to apply any additional patches without modifing ebuild
eapply_user