aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--arp.c22
-rw-r--r--ifconfig.c4
-rw-r--r--ipmaddr.c4
-rw-r--r--iptunnel.c47
-rw-r--r--netstat.c14
-rw-r--r--po/Makefile2
-rw-r--r--po/net-tools.pot192
-rw-r--r--slattach.c6
8 files changed, 240 insertions, 51 deletions
diff --git a/arp.c b/arp.c
index 5c9f461..8699d47 100644
--- a/arp.c
+++ b/arp.c
@@ -8,7 +8,7 @@
* NET-3 Networking Distribution for the LINUX operating
* system.
*
- * Version: $Id: arp.c,v 1.11 1999/01/05 20:52:54 philip Exp $
+ * Version: $Id: arp.c,v 1.12 1999/03/24 09:49:43 philip Exp $
*
* Maintainer: Bernd 'eckes' Eckenfels, <net-tools@lina.inka.de>
*
@@ -235,11 +235,11 @@ static int arp_getdevhw(char *ifname, struct sockaddr *sa, struct hwtype *hw)
strcpy(ifr.ifr_name, ifname);
if (ioctl(sockfd, SIOCGIFHWADDR, &ifr) < 0) {
- fprintf(stderr, "arp: cant get HW-Address for `%s': %s.\n", ifname, strerror(errno));
+ fprintf(stderr, _("arp: cant get HW-Address for `%s': %s.\n"), ifname, strerror(errno));
return (-1);
}
if (hw && (ifr.ifr_hwaddr.sa_family != hw->type)) {
- fprintf(stderr, "arp: protocol type missmatch.\n");
+ fprintf(stderr, _("arp: protocol type mismatch.\n"));
return (-1);
}
memcpy((char *) sa, (char *) &(ifr.ifr_hwaddr), sizeof(struct sockaddr));
@@ -248,7 +248,7 @@ static int arp_getdevhw(char *ifname, struct sockaddr *sa, struct hwtype *hw)
if (!(xhw = get_hwntype(ifr.ifr_hwaddr.sa_family)) || (xhw->sprint == 0)) {
xhw = get_hwntype(-1);
}
- fprintf(stderr, "arp: device `%s' has HW address %s `%s'.\n", ifname, xhw->name, xhw->sprint(&ifr.ifr_hwaddr));
+ fprintf(stderr, _("arp: device `%s' has HW address %s `%s'.\n"), ifname, xhw->name, xhw->sprint(&ifr.ifr_hwaddr));
}
return (0);
}
@@ -455,7 +455,7 @@ static void arp_disp_2(char *name, int type, int arp_flags, char *hwa, char *mas
if (arp_flags & ATF_PUBL)
printf("%-8.8s%-20.20s", "*", "*");
else
- printf("%-8.8s%-20.20s", "", "(incomplete)");
+ printf("%-8.8s%-20.20s", "", _("(incomplete)"));
} else {
printf("%-8.8s%-20.20s", xhw->name, hwa);
}
@@ -472,19 +472,19 @@ static void arp_disp(char *name, char *ip, int type, int arp_flags, char *hwa, c
if (xhw == NULL)
xhw = get_hwtype(DFLT_HW);
- printf("%s (%s) at ", name, ip);
+ printf(_("%s (%s) at "), name, ip);
if (!(arp_flags & ATF_COM)) {
if (arp_flags & ATF_PUBL)
printf("* ");
else
- printf("<incomplete> ");
+ printf(_("<incomplete> "));
} else {
printf("%s [%s] ", hwa, xhw->name);
}
if (arp_flags & ATF_NETMASK)
- printf("netmask %s ", mask);
+ printf(_("netmask %s "), mask);
if (arp_flags & ATF_PERM)
printf("PERM ");
@@ -501,7 +501,7 @@ static void arp_disp(char *name, char *ip, int type, int arp_flags, char *hwa, c
if (arp_flags & ATF_USETRAILERS)
printf("TRAIL ");
- printf("on %s\n", dev);
+ printf(_("on %s\n"), dev);
}
@@ -584,7 +584,7 @@ static int arp_show(char *name)
if (!showed) {
if (host[0] && !opt_a)
- printf("%s (%s) -- no entry\n", name, host);
+ printf(_("%s (%s) -- no entry\n"), name, host);
else if (hw_set || host[0] || device[0]) {
printf(_("arp: in %d entries no match found.\n"), entries);
}
@@ -690,7 +690,7 @@ int main(int argc, char **argv)
break;
case 'N':
opt_N = FLAG_SYM;
- fprintf(stderr, "arp: -N not yet supported.\n");
+ fprintf(stderr, _("arp: -N not yet supported.\n"));
break;
case 'v':
opt_v = 1;
diff --git a/ifconfig.c b/ifconfig.c
index 669d3be..e351869 100644
--- a/ifconfig.c
+++ b/ifconfig.c
@@ -3,7 +3,7 @@
* that either displays or sets the characteristics of
* one or more of the system's networking interfaces.
*
- * Version: $Id: ifconfig.c,v 1.28 1999/03/03 19:40:28 philip Exp $
+ * Version: $Id: ifconfig.c,v 1.29 1999/03/24 09:49:45 philip Exp $
*
* Author: Fred N. van Kempen, <waltje@uwalt.nl.mugnet.org>
* and others. Copyright 1993 MicroWalt Corporation
@@ -109,7 +109,7 @@ static const char *if_port_text[][4] =
#include "sockets.h"
#include "util.h"
-char *Release = RELEASE, *Version = "ifconfig 1.38 (1999-01-05)";
+char *Release = RELEASE, *Version = "ifconfig 1.39 (1999-03-18)";
int opt_a = 0; /* show all interfaces */
int opt_i = 0; /* show the statistics */
diff --git a/ipmaddr.c b/ipmaddr.c
index 2b99254..7bc72fe 100644
--- a/ipmaddr.c
+++ b/ipmaddr.c
@@ -253,7 +253,7 @@ static void print_maddr(FILE *fp, struct ma_info *list)
fprintf(fp, "inet6 ");
break;
default:
- fprintf(fp, "family %d ", list->addr.family);
+ fprintf(fp, _("family %d "), list->addr.family);
break;
}
if (format_host(list->addr.family, list->addr.data, abuf, sizeof(abuf)))
@@ -262,7 +262,7 @@ static void print_maddr(FILE *fp, struct ma_info *list)
fprintf(fp, "?");
}
if (list->users != 1)
- fprintf(fp, " users %d", list->users);
+ fprintf(fp, _(" users %d"), list->users);
if (list->features)
fprintf(fp, " %s", list->features);
fprintf(fp, "\n");
diff --git a/iptunnel.c b/iptunnel.c
index aa90882..03e53fc 100644
--- a/iptunnel.c
+++ b/iptunnel.c
@@ -58,16 +58,15 @@ static void usage(void) __attribute__((noreturn));
static void usage(void)
{
- fprintf(stderr, "Usage: iptunnel { add | change | del | show } [ NAME ]\n");
- fprintf(stderr, " [ mode { ipip | gre | sit } ] [ remote ADDR ] [ local ADDR ]\n");
- fprintf(stderr, " [ [i|o]seq ] [ [i|o]key KEY ] [ [i|o]csum ]\n");
- fprintf(stderr, " [ ttl TTL ] [ tos TOS ] [ nopmtudisc ] [ dev PHYS_DEV ]\n");
- fprintf(stderr, "\n");
- fprintf(stderr, "Where: NAME := STRING\n");
- fprintf(stderr, " ADDR := { IP_ADDRESS | any }\n");
- fprintf(stderr, " TOS := { NUMBER | inherit }\n");
- fprintf(stderr, " TTL := { 1..255 | inherit }\n");
- fprintf(stderr, " KEY := { DOTTED_QUAD | NUMBER }\n");
+ fprintf(stderr, _("Usage: iptunnel { add | change | del | show } [ NAME ]\n"));
+ fprintf(stderr, _(" [ mode { ipip | gre | sit } ] [ remote ADDR ] [ local ADDR ]\n"));
+ fprintf(stderr, _(" [ [i|o]seq ] [ [i|o]key KEY ] [ [i|o]csum ]\n"));
+ fprintf(stderr, _(" [ ttl TTL ] [ tos TOS ] [ nopmtudisc ] [ dev PHYS_DEV ]\n\n"));
+ fprintf(stderr, _("Where: NAME := STRING\n"));
+ fprintf(stderr, _(" ADDR := { IP_ADDRESS | any }\n"));
+ fprintf(stderr, _(" TOS := { NUMBER | inherit }\n"));
+ fprintf(stderr, _(" TTL := { 1..255 | inherit }\n"));
+ fprintf(stderr, _(" KEY := { DOTTED_QUAD | NUMBER }\n"));
exit(-1);
}
@@ -305,7 +304,7 @@ static int parse_args(int argc, char **argv, struct ip_tunnel_parm *p)
if (p->iph.protocol == IPPROTO_IPIP || p->iph.protocol == IPPROTO_IPV6) {
if ((p->i_flags & GRE_KEY) || (p->o_flags & GRE_KEY)) {
- fprintf(stderr, "Keys are not allowed with ipip and sit.\n");
+ fprintf(stderr, _("Keys are not allowed with ipip and sit.\n"));
return -1;
}
}
@@ -325,7 +324,7 @@ static int parse_args(int argc, char **argv, struct ip_tunnel_parm *p)
p->o_flags |= GRE_KEY;
}
if (IN_MULTICAST(ntohl(p->iph.daddr)) && !p->iph.saddr) {
- fprintf(stderr, "Broadcast tunnel requires a source address.\n");
+ fprintf(stderr, _("Broadcast tunnel requires a source address.\n"));
return -1;
}
return 0;
@@ -340,7 +339,7 @@ static int do_add(int cmd, int argc, char **argv)
return -1;
if (p.iph.ttl && p.iph.frag_off == 0) {
- fprintf(stderr, "ttl != 0 and noptmudisc are incompatible\n");
+ fprintf(stderr, _("ttl != 0 and noptmudisc are incompatible\n"));
return -1;
}
@@ -352,7 +351,7 @@ static int do_add(int cmd, int argc, char **argv)
case IPPROTO_IPV6:
return do_add_ioctl(cmd, "sit0", &p);
default:
- fprintf(stderr, "cannot determine tunnel mode (ipip, gre or sit)\n");
+ fprintf(stderr, _("cannot determine tunnel mode (ipip, gre or sit)\n"));
return -1;
}
return -1;
@@ -390,11 +389,11 @@ void print_tunnel(struct ip_tunnel_parm *p)
inet_ntop(AF_INET, &p->i_key, s3, sizeof(s3));
inet_ntop(AF_INET, &p->o_key, s4, sizeof(s4));
- printf("%s: %s/ip remote %s local %s ",
+ printf(_("%s: %s/ip remote %s local %s "),
p->name,
p->iph.protocol == IPPROTO_IPIP ? "ip" :
(p->iph.protocol == IPPROTO_GRE ? "gre" :
- (p->iph.protocol == IPPROTO_IPV6 ? "ipv6" : "unknown")),
+ (p->iph.protocol == IPPROTO_IPV6 ? "ipv6" : _("unknown"))),
p->iph.daddr ? s1 : "any", p->iph.saddr ? s2 : "any");
if (p->link) {
char *n = do_ioctl_get_ifname(p->link);
@@ -426,13 +425,13 @@ void print_tunnel(struct ip_tunnel_parm *p)
printf("\n");
if (p->i_flags&GRE_SEQ)
- printf(" Drop packets out of sequence.\n");
+ printf(_(" Drop packets out of sequence.\n"));
if (p->i_flags&GRE_CSUM)
- printf(" Checksum in received packet is required.\n");
+ printf(_(" Checksum in received packet is required.\n"));
if (p->o_flags&GRE_SEQ)
- printf(" Sequence packets on output.\n");
+ printf(_(" Sequence packets on output.\n"));
if (p->o_flags&GRE_CSUM)
- printf(" Checksum output packets.\n");
+ printf(_(" Checksum output packets.\n"));
}
static int do_tunnels_list(struct ip_tunnel_parm *p)
@@ -460,7 +459,7 @@ static int do_tunnels_list(struct ip_tunnel_parm *p)
buf[sizeof(buf) - 1] = 0;
if ((ptr = strchr(buf, ':')) == NULL ||
(*ptr++ = 0, sscanf(buf, "%s", name) != 1)) {
- fprintf(stderr, "Wrong format of /proc/net/dev. Sorry.\n");
+ fprintf(stderr, _("Wrong format of /proc/net/dev. Sorry.\n"));
return -1;
}
if (sscanf(ptr, "%ld%ld%ld%ld%ld%ld%ld%*d%ld%ld%ld%ld%ld%ld%ld",
@@ -473,7 +472,7 @@ static int do_tunnels_list(struct ip_tunnel_parm *p)
continue;
type = do_ioctl_get_iftype(name);
if (type == -1) {
- fprintf(stderr, "Failed to get type of [%s]\n", name);
+ fprintf(stderr, _("Failed to get type of [%s]\n"), name);
continue;
}
if (type != ARPHRD_TUNNEL && type != ARPHRD_IPGRE && type != ARPHRD_SIT)
@@ -489,10 +488,10 @@ static int do_tunnels_list(struct ip_tunnel_parm *p)
continue;
print_tunnel(&p1);
if (show_stats) {
- printf("RX: Packets Bytes Errors CsumErrs OutOfSeq Mcasts\n");
+ printf(_("RX: Packets Bytes Errors CsumErrs OutOfSeq Mcasts\n"));
printf(" %-10ld %-12ld %-6ld %-8ld %-8ld %-8ld\n",
rx_packets, rx_bytes, rx_errs, rx_frame, rx_fifo, rx_multi);
- printf("TX: Packets Bytes Errors DeadLoop NoRoute NoBufs\n");
+ printf(_("TX: Packets Bytes Errors DeadLoop NoRoute NoBufs\n"));
printf(" %-10ld %-12ld %-6ld %-8ld %-8ld %-6ld\n\n",
tx_packets, tx_bytes, tx_errs, tx_colls, tx_carrier, tx_drops);
}
diff --git a/netstat.c b/netstat.c
index f21589d..7770690 100644
--- a/netstat.c
+++ b/netstat.c
@@ -6,7 +6,7 @@
* NET-3 Networking Distribution for the LINUX operating
* system.
*
- * Version: $Id: netstat.c,v 1.24 1999/03/17 14:00:09 philip Exp $
+ * Version: $Id: netstat.c,v 1.25 1999/03/24 09:49:52 philip Exp $
*
* Authors: Fred Baumgarten, <dc6iq@insu1.etec.uni-karlsruhe.de>
* Fred N. van Kempen, <waltje@uwalt.nl.mugnet.org>
@@ -424,7 +424,7 @@ static int netrom_info(void)
ret = sscanf(buffer + 30, "%s %*x/%*x %*x/%*x %d %d %d %*d %*d/%*d %*d/%*d %*d/%*d %*d/%*d %*d/%*d %*d %d %d %*d",
dev, &st, &vs, &vr, &sendq, &recvq);
if (ret != 6) {
- printf("Problem reading data from %s\n", _PATH_PROCNET_NR);
+ printf(_("Problem reading data from %s\n"), _PATH_PROCNET_NR);
continue;
}
printf("%-9s %-9s %-9s %-6s %-11s %03d/%03d %-6d %-6d\n",
@@ -1188,7 +1188,7 @@ static int ax25_info(void)
ret = sscanf(buffer + 20, "%s %d %d %d %*d %*d/%*d %*d/%*d %*d/%*d %*d/%*d %*d/%*d %*d %*d %*d %d %d %*d",
buf, &st, &vs, &vr, &sendq, &recvq);
if (ret != 4 && ret != 6) {
- printf("Problem reading data from %s\n", _PATH_PROCNET_AX25);
+ printf(_("Problem reading data from %s\n"), _PATH_PROCNET_AX25);
continue;
}
dev = buf;
@@ -1208,7 +1208,7 @@ static int ax25_info(void)
ret = sscanf(p, "%d %d %d %*d %*d %*d %*d %*d %*d %*d %*d %*d %*d %*d %*d %*d %*d %d %d %*d",
&st, &vs, &vr, &sendq, &recvq);
if (ret != 3 && ret != 5) {
- printf("problem reading data from %s\n", _PATH_PROCNET_AX25);
+ printf(_("problem reading data from %s\n"), _PATH_PROCNET_AX25);
continue;
}
/*
@@ -1347,7 +1347,7 @@ void ife_print(struct interface *ptr)
ptr->stats.tx_packets, ptr->stats.tx_errors,
ptr->stats.tx_dropped, ptr->stats.tx_fifo_errors);
} else {
- printf("%-56s", " - no statistics available -");
+ printf("%-56s", _(" - no statistics available -"));
}
if (ptr->flags == 0)
printf(_("[NO FLAGS]"));
@@ -1687,8 +1687,8 @@ int main
#if HAVE_AFINET6
printf( "IPv6/");
#endif
- printf( "IPv4 Group Memberships\n" );
- printf( "Interface RefCnt Group\n" );
+ printf( _("IPv4 Group Memberships\n") );
+ printf( _("Interface RefCnt Group\n") );
printf( "--------------- ------ ---------------------\n" );
i = igmp_info();
if (i)
diff --git a/po/Makefile b/po/Makefile
index af74218..8253c24 100644
--- a/po/Makefile
+++ b/po/Makefile
@@ -23,7 +23,7 @@ POTFILES=../arp.c ../hostname.c ../ifconfig.c ../netstat.c ../rarp.c \
../lib/rose_gr.c ../lib/setroute.c ../lib/sit.c ../lib/slip.c \
../lib/slip_ac.c ../lib/tr.c ../lib/tunnel.c ../lib/unix.c \
../lib/util.c ../lib/interface.c ../lib/sockets.c ../lib/util-ank.c \
- ../ipmaddr.c ../slattach.c
+ ../ipmaddr.c ../slattach.c ../iptunnel.c
all: $(NLSPACKAGE).pot $(CATALOGS)
diff --git a/po/net-tools.pot b/po/net-tools.pot
index ce73ded..bb5917c 100644
--- a/po/net-tools.pot
+++ b/po/net-tools.pot
@@ -6,7 +6,7 @@
msgid ""
msgstr ""
"Project-Id-Version: PACKAGE VERSION\n"
-"POT-Creation-Date: 1999-03-06 00:09+0100\n"
+"POT-Creation-Date: 1999-03-23 20:34+0200\n"
"PO-Revision-Date: YEAR-MO-DA HO:MI+ZONE\n"
"Last-Translator: FULL NAME <EMAIL@ADDRESS>\n"
"Language-Team: LANGUAGE <LL@li.org>\n"
@@ -23,6 +23,20 @@ msgstr ""
msgid "No ARP entry for %s\n"
msgstr ""
+#: ../arp.c:238
+#, c-format
+msgid "arp: cant get HW-Address for `%s': %s.\n"
+msgstr ""
+
+#: ../arp.c:242
+msgid "arp: protocol type mismatch.\n"
+msgstr ""
+
+#: ../arp.c:251
+#, c-format
+msgid "arp: device `%s' has HW address %s `%s'.\n"
+msgstr ""
+
#: ../arp.c:281
msgid "arp: need hardware address\n"
msgstr ""
@@ -50,11 +64,39 @@ msgstr ""
msgid "Address\t\t\tHWtype\tHWaddress\t Flags Mask\t\t Iface\n"
msgstr ""
+#: ../arp.c:458
+msgid "(incomplete)"
+msgstr ""
+
+#: ../arp.c:475
+#, c-format
+msgid "%s (%s) at "
+msgstr ""
+
+#: ../arp.c:481
+msgid "<incomplete> "
+msgstr ""
+
+#: ../arp.c:487
+#, c-format
+msgid "netmask %s "
+msgstr ""
+
+#: ../arp.c:504
+#, c-format
+msgid "on %s\n"
+msgstr ""
+
#: ../arp.c:583
#, c-format
msgid "Entries: %d\tSkipped: %d\tFound: %d\n"
msgstr ""
+#: ../arp.c:587
+#, c-format
+msgid "%s (%s) -- no entry\n"
+msgstr ""
+
#: ../arp.c:589
#, c-format
msgid "arp: in %d entries no match found.\n"
@@ -154,6 +196,10 @@ msgstr ""
msgid "%s: address family not supported!\n"
msgstr ""
+#: ../arp.c:693
+msgid "arp: -N not yet supported.\n"
+msgstr ""
+
#: ../arp.c:703
#, c-format
msgid "arp: %s: unknown address family.\n"
@@ -729,6 +775,11 @@ msgid ""
"Recv-Q\n"
msgstr ""
+#: ../netstat.c:427 ../netstat.c:1191
+#, c-format
+msgid "Problem reading data from %s\n"
+msgstr ""
+
#: ../netstat.c:462
msgid "SYN_SENT"
msgstr ""
@@ -898,6 +949,11 @@ msgstr ""
msgid "Dest Source Device State Vr/Vs Send-Q Recv-Q\n"
msgstr ""
+#: ../netstat.c:1211
+#, c-format
+msgid "problem reading data from %s\n"
+msgstr ""
+
#: ../netstat.c:1262
msgid ""
"Active IPX sockets\n"
@@ -917,6 +973,10 @@ msgstr ""
msgid "UNK."
msgstr ""
+#: ../netstat.c:1350
+msgid " - no statistics available -"
+msgstr ""
+
#: ../netstat.c:1353
msgid "[NO FLAGS]"
msgstr ""
@@ -1051,6 +1111,14 @@ msgstr ""
msgid " Timer"
msgstr ""
+#: ../netstat.c:1690
+msgid "IPv4 Group Memberships\n"
+msgstr ""
+
+#: ../netstat.c:1691
+msgid "Interface RefCnt Group\n"
+msgstr ""
+
#: ../rarp.c:43
msgid "This kernel does not support RARP.\n"
msgstr ""
@@ -1159,6 +1227,103 @@ msgstr ""
msgid "%s\tnibble %lu trigger %lu\n"
msgstr ""
+#: ../iptunnel.c:61
+msgid "Usage: iptunnel { add | change | del | show } [ NAME ]\n"
+msgstr ""
+
+#: ../iptunnel.c:62
+msgid ""
+" [ mode { ipip | gre | sit } ] [ remote ADDR ] [ local ADDR ]\n"
+msgstr ""
+
+#: ../iptunnel.c:63
+msgid " [ [i|o]seq ] [ [i|o]key KEY ] [ [i|o]csum ]\n"
+msgstr ""
+
+#: ../iptunnel.c:64
+msgid ""
+" [ ttl TTL ] [ tos TOS ] [ nopmtudisc ] [ dev PHYS_DEV ]\n"
+"\n"
+msgstr ""
+
+#: ../iptunnel.c:65
+msgid "Where: NAME := STRING\n"
+msgstr ""
+
+#: ../iptunnel.c:66
+msgid " ADDR := { IP_ADDRESS | any }\n"
+msgstr ""
+
+#: ../iptunnel.c:67
+msgid " TOS := { NUMBER | inherit }\n"
+msgstr ""
+
+#: ../iptunnel.c:68
+msgid " TTL := { 1..255 | inherit }\n"
+msgstr ""
+
+#: ../iptunnel.c:69
+msgid " KEY := { DOTTED_QUAD | NUMBER }\n"
+msgstr ""
+
+#: ../iptunnel.c:307
+msgid "Keys are not allowed with ipip and sit.\n"
+msgstr ""
+
+#: ../iptunnel.c:327
+msgid "Broadcast tunnel requires a source address.\n"
+msgstr ""
+
+#: ../iptunnel.c:342
+msgid "ttl != 0 and noptmudisc are incompatible\n"
+msgstr ""
+
+#: ../iptunnel.c:354
+msgid "cannot determine tunnel mode (ipip, gre or sit)\n"
+msgstr ""
+
+#: ../iptunnel.c:392
+#, c-format
+msgid "%s: %s/ip remote %s local %s "
+msgstr ""
+
+#: ../iptunnel.c:396
+msgid "unknown"
+msgstr ""
+
+#: ../iptunnel.c:428
+msgid " Drop packets out of sequence.\n"
+msgstr ""
+
+#: ../iptunnel.c:430
+msgid " Checksum in received packet is required.\n"
+msgstr ""
+
+#: ../iptunnel.c:432
+msgid " Sequence packets on output.\n"
+msgstr ""
+
+#: ../iptunnel.c:434
+msgid " Checksum output packets.\n"
+msgstr ""
+
+#: ../iptunnel.c:462
+msgid "Wrong format of /proc/net/dev. Sorry.\n"
+msgstr ""
+
+#: ../iptunnel.c:475
+#, c-format
+msgid "Failed to get type of [%s]\n"
+msgstr ""
+
+#: ../iptunnel.c:491
+msgid "RX: Packets Bytes Errors CsumErrs OutOfSeq Mcasts\n"
+msgstr ""
+
+#: ../iptunnel.c:494
+msgid "TX: Packets Bytes Errors DeadLoop NoRoute NoBufs\n"
+msgstr ""
+
#: ../statistics.c:45
msgid "ICMP input histogram:"
msgstr ""
@@ -2073,6 +2238,16 @@ msgstr ""
msgid " ipmaddr show [ dev STRING ] [ ipv4 | ipv6 | link | all ]\n"
msgstr ""
+#: ../ipmaddr.c:256
+#, c-format
+msgid "family %d "
+msgstr ""
+
+#: ../ipmaddr.c:265
+#, c-format
+msgid " users %d"
+msgstr ""
+
#: ../ipmaddr.c:351
msgid "Cannot create socket"
msgstr ""
@@ -2131,3 +2306,18 @@ msgstr ""
#, c-format
msgid "slattach: unsupported protocol %s\n"
msgstr ""
+
+#: ../slattach.c:685
+#, c-format
+msgid "%s started"
+msgstr ""
+
+#: ../slattach.c:686
+#, c-format
+msgid " on %s"
+msgstr ""
+
+#: ../slattach.c:687
+#, c-format
+msgid " interface %s\n"
+msgstr ""
diff --git a/slattach.c b/slattach.c
index 64c17ea..4f79a00 100644
--- a/slattach.c
+++ b/slattach.c
@@ -682,9 +682,9 @@ main(int argc, char *argv[])
(*ht->activate)(tty_fd);
if (opt_v == 1) {
tty_get_name(buff);
- printf("%s started", proto);
- if (sp != NULL) printf(" on %s", sp);
- printf(" interface %s\n", buff);
+ printf(_("%s started"), proto);
+ if (sp != NULL) printf(_(" on %s"), sp);
+ printf(_(" interface %s\n"), buff);
}
/* Configure keepalive and outfill. */