aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathias Krause <minipli@grsecurity.net>2024-07-30 23:30:25 +0200
committerSam James <sam@gentoo.org>2024-08-09 11:02:44 +0100
commit101ddccc4fad47ac8bef08ff3e30cc81727f477b (patch)
treea4e14f10a56877ca4029a6d5475e9f6af50b1789
parentpspax: fix libcap memory leaks (diff)
downloadpax-utils-101ddccc4fad47ac8bef08ff3e30cc81727f477b.tar.gz
pax-utils-101ddccc4fad47ac8bef08ff3e30cc81727f477b.tar.bz2
pax-utils-101ddccc4fad47ac8bef08ff3e30cc81727f477b.zip
meson: avoid using replace() to not unnecessarily bump meson >= 0.58.0
Debian bullseye ships with meson 0.56.2 which is too old to understand replace(). Work around that with split() and string concatenation. Signed-off-by: Mathias Krause <minipli@grsecurity.net> Closes: https://github.com/gentoo/pax-utils/pull/16 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--man/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/man/meson.build b/man/meson.build
index 09ac0d5..c6982d2 100644
--- a/man/meson.build
+++ b/man/meson.build
@@ -19,7 +19,7 @@ fs = import('fs')
out_pages = []
generated_man_pages_exist = true
foreach page : pages
- man_page_name = page.replace('.docbook', '.1')
+ man_page_name = page.split('.')[0] + '.1'
out_pages += man_page_name
if not fs.exists(man_page_name)
generated_man_pages_exist = false