aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@chromium.org>2024-01-24 10:35:52 -0500
committerMike Frysinger <vapier@gentoo.org>2024-01-24 10:35:52 -0500
commit063a90661c0423172e23405c2548e649a1631796 (patch)
tree361a0b04b7d9b28d772a5964b029ad137f194ef5 /meson.build
parentbuild: use standard config.h naming (diff)
downloadpax-utils-063a90661c0423172e23405c2548e649a1631796.tar.gz
pax-utils-063a90661c0423172e23405c2548e649a1631796.tar.bz2
pax-utils-063a90661c0423172e23405c2548e649a1631796.zip
build: use standard HAVE_xxx define style
Use the more standard HAVE_xxx convention, and only define when available. This avoids further confusion with code that is using "#ifdef" already. Signed-off-by: Mike Frysinger <vapier@chromium.org> Signed-off-by: Mike Frysinger <vapier@gentoo.org>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 1 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index c91bb64..e891d98 100644
--- a/meson.build
+++ b/meson.build
@@ -48,11 +48,9 @@ foreach x : [
'elf-hints.h',
'glob.h',
]
- x_exists = 0
if cc.has_header(x)
- x_exists = 1
+ probe_results.set('HAVE_' + x.to_upper().underscorify(), 1)
endif
- probe_results.set('HAS_' + x.to_upper().underscorify(), x_exists)
endforeach
configure_file(