aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-11-08 20:37:34 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-11-08 20:37:34 +0200
commit686faa1134212732ce0aa01c3d792021e76570e6 (patch)
treedf3281ba6e0d1cdac6039994fa7f8846cb2aa6cb
parentpyproject.toml: depend on flit_core >=3.8 (diff)
downloadsnakeoil-686faa1134212732ce0aa01c3d792021e76570e6.tar.gz
snakeoil-686faa1134212732ce0aa01c3d792021e76570e6.tar.bz2
snakeoil-686faa1134212732ce0aa01c3d792021e76570e6.zip
drop py3.8 support
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--.github/workflows/test.yml8
-rw-r--r--pyproject.toml3
2 files changed, 5 insertions, 6 deletions
diff --git a/.github/workflows/test.yml b/.github/workflows/test.yml
index bdff1444..389746d5 100644
--- a/.github/workflows/test.yml
+++ b/.github/workflows/test.yml
@@ -13,12 +13,12 @@ jobs:
strategy:
matrix:
os: [ubuntu-latest]
- python-version: ['3.8', '3.9', '3.10', 'pypy-3.8', 'pypy-3.9']
+ python-version: ['3.9', '3.10', '3.11', 'pypy-3.8', 'pypy-3.9']
experimental: [false]
include:
- - os: ubuntu-latest
- python-version: '3.11.0-beta - 3.11'
- experimental: true
+ # - os: ubuntu-latest
+ # python-version: '3.11.0-beta - 3.11'
+ # experimental: true
- os: macos-latest
python-version: '3.10'
experimental: false
diff --git a/pyproject.toml b/pyproject.toml
index c250cee4..99d72b11 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -6,7 +6,7 @@ build-backend = "flit_core.buildapi"
name = "snakeoil"
description = "misc common functionality and useful optimizations"
readme = "README.rst"
-requires-python = "~=3.8"
+requires-python = "~=3.9"
authors = [
{name = "Tim Harder", email = "radhermit@gmail.com"},
{name = "Arthur Zamarin", email = "arthurzam@gentoo.org"},
@@ -17,7 +17,6 @@ maintainers = [
classifiers = [
"Intended Audience :: Developers",
"License :: OSI Approved :: BSD License",
- "Programming Language :: Python :: 3.8",
"Programming Language :: Python :: 3.9",
"Programming Language :: Python :: 3.10",
"Programming Language :: Python :: 3.11",