aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2020-01-01 18:53:32 +0100
committerFabian Groffen <grobian@gentoo.org>2020-01-01 18:53:32 +0100
commit3e6a2e36af413a4dc1469a4042c8ce1aae95dfc9 (patch)
tree4017fff1545ecf2e6ab16c93d1205dfebe533dc4 /qgrep.c
parentlibq/atom: stick to PMS for PVR (diff)
downloadportage-utils-3e6a2e36af413a4dc1469a4042c8ce1aae95dfc9.tar.gz
portage-utils-3e6a2e36af413a4dc1469a4042c8ce1aae95dfc9.tar.bz2
portage-utils-3e6a2e36af413a4dc1469a4042c8ce1aae95dfc9.zip
*: use new PF in places were it was simulated
Signed-off-by: Fabian Groffen <grobian@gentoo.org>
Diffstat (limited to 'qgrep.c')
-rw-r--r--qgrep.c7
1 files changed, 3 insertions, 4 deletions
diff --git a/qgrep.c b/qgrep.c
index 2a64d1b6..4d8c27f9 100644
--- a/qgrep.c
+++ b/qgrep.c
@@ -1,5 +1,5 @@
/*
- * Copyright 2005-2019 Gentoo Foundation
+ * Copyright 2005-2020 Gentoo Foundation
* Distributed under the terms of the GNU General Public License v2
*
* Copyright 2005 Petteri Räty - <betelgeuse@gentoo.org>
@@ -416,9 +416,8 @@ qgrep_cache_cb(tree_pkg_ctx *pkg_ctx, void *priv)
}
/* cat/pkg/pkg-ver.ebuild */
- snprintf(buf, sizeof(buf), "%s/%s/%s-%s.ebuild",
- patom->CATEGORY, patom->PN, patom->PN,
- patom->PR_int > 0 ? patom->PVR : patom->PV);
+ snprintf(buf, sizeof(buf), "%s/%s/%s.ebuild",
+ patom->CATEGORY, patom->PN, patom->PF);
label = NULL;
if (data->show_name) {