aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2018-09-23 16:18:33 +0300
committerJimi Huotari <chiitoo@gentoo.org>2018-09-23 17:57:38 +0300
commit182b079cd39004a600b9dddce6d47449574fd5fc (patch)
tree1aa34804485a78180ae20a9f85e9774522e8582c /dev-libs
parentlxqt-base/lxqt-themes: move to x11-themes/lxqt-themes (diff)
downloadqt-182b079cd39004a600b9dddce6d47449574fd5fc.tar.gz
qt-182b079cd39004a600b9dddce6d47449574fd5fc.tar.bz2
qt-182b079cd39004a600b9dddce6d47449574fd5fc.zip
lxqt: sync related ebuilds/metadata with the main Gentoo repo tree
With this, the metadata and 9999 ebuilds are in sync with the 0.13.0 versions found via the official Gentoo repository tree, with the following exceptions: - Polkit is optional. - Some of the USE-flags are not used/included in the metadata. - A patch for 'lxqt-config' is not needed. - The handling of translations has been changed upstream, so 'lxqt-meta' does not depend on 'lxqt-l10n' due to file collisions. Package-Manager: Portage-2.3.49, Repoman-2.3.11
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libqtxdg/libqtxdg-9999.ebuild24
-rw-r--r--dev-libs/libqtxdg/metadata.xml19
2 files changed, 23 insertions, 20 deletions
diff --git a/dev-libs/libqtxdg/libqtxdg-9999.ebuild b/dev-libs/libqtxdg/libqtxdg-9999.ebuild
index 3edc5ce7..67317650 100644
--- a/dev-libs/libqtxdg/libqtxdg-9999.ebuild
+++ b/dev-libs/libqtxdg/libqtxdg-9999.ebuild
@@ -1,39 +1,38 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
+
inherit cmake-utils virtualx
DESCRIPTION="A Qt implementation of XDG standards"
HOMEPAGE="https://lxqt.org/"
-if [[ ${PV} == *9999* ]]; then
+if [[ ${PV} == *9999 ]]; then
inherit git-r3
- EGIT_REPO_URI="https://github.com/lxde/${PN}.git"
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
else
- SRC_URI="https://github.com/lxde/${PN}/releases/download/${PV}/${P}.tar.xz"
+ SRC_URI="https://downloads.lxqt.org/downloads/${PN}/${PV}/${P}.tar.xz"
KEYWORDS="~amd64 ~arm ~arm64 ~x86"
fi
-LICENSE="LGPL-2.1"
+LICENSE="LGPL-2.1+ Nokia-Qt-LGPL-Exception-1.1"
SLOT="0"
IUSE="test"
-CDEPEND="
+RDEPEND="
dev-qt/qtcore:5
dev-qt/qtdbus:5
- dev-qt/qtgui:5
+ dev-qt/qtgui:5=
dev-qt/qtsvg:5
dev-qt/qtwidgets:5
dev-qt/qtxml:5
+ x11-misc/xdg-utils
"
-DEPEND="${CDEPEND}
+DEPEND="${RDEPEND}
virtual/pkgconfig
test? ( dev-qt/qttest:5 )
"
-RDEPEND="${CDEPEND}
- x11-misc/xdg-utils
-"
src_configure() {
local mycmakeargs=(
@@ -43,5 +42,6 @@ src_configure() {
}
src_test() {
- VIRTUALX_COMMAND="cmake-utils_src_test" virtualmake
+ # Tests don't work with C
+ LC_ALL=en_US.utf8 virtx cmake-utils_src_test
}
diff --git a/dev-libs/libqtxdg/metadata.xml b/dev-libs/libqtxdg/metadata.xml
index 77812fec..2906ccd4 100644
--- a/dev-libs/libqtxdg/metadata.xml
+++ b/dev-libs/libqtxdg/metadata.xml
@@ -1,12 +1,15 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="project">
- <email>lxqt@gentoo.org</email>
- <name>LXQt</name>
- </maintainer>
-<maintainer type="project">
- <email>qt@gentoo.org</email>
- <name>Gentoo Qt Project</name>
- </maintainer>
+ <maintainer type="project">
+ <email>lxqt@gentoo.org</email>
+ <name>LXQt</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>qt@gentoo.org</email>
+ <name>Gentoo Qt Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">lxqt/libqtxdg</remote-id>
+ </upstream>
</pkgmetadata>