aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-12-24 00:25:19 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-12-31 16:02:13 +0100
commit716b4578b4b57d4caf861ff072475cdad3b0b114 (patch)
tree9cbc9987430cff317051c914c34d013e650fc5cf /dev-libs
parent*/*: Switch qt proj packages to cmake.eclass (diff)
downloadqt-716b4578b4b57d4caf861ff072475cdad3b0b114.tar.gz
qt-716b4578b4b57d4caf861ff072475cdad3b0b114.tar.bz2
qt-716b4578b4b57d4caf861ff072475cdad3b0b114.zip
*/*: Switch lxqt proj packages to cmake.eclass
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libqtxdg/libqtxdg-9999.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/dev-libs/libqtxdg/libqtxdg-9999.ebuild b/dev-libs/libqtxdg/libqtxdg-9999.ebuild
index f01b3321..60e5c259 100644
--- a/dev-libs/libqtxdg/libqtxdg-9999.ebuild
+++ b/dev-libs/libqtxdg/libqtxdg-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils virtualx
+inherit cmake virtualx
DESCRIPTION="A Qt implementation of XDG standards"
HOMEPAGE="https://lxqt.org/"
@@ -41,10 +41,10 @@ src_configure() {
local mycmakeargs=(
-DBUILD_TESTS=$(usex test)
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_test() {
# Tests don't work with C
- LC_ALL=en_US.utf8 virtx cmake-utils_src_test
+ LC_ALL=en_US.utf8 virtx cmake_src_test
}