aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <gentoo@aisha.cc>2020-10-10 01:26:01 +0000
committerAisha Tammy <gentoo@aisha.cc>2020-10-10 01:26:01 +0000
commitad9ae04669682cf6c0a78070f46e8e5e101e612e (patch)
tree567b10ecb2683a1c8d6b5f96da1a6d138b76414d /sys-cluster
parentpatchers: removed patches directory for packages distributed by ::gentoo (diff)
downloadsci-ad9ae04669682cf6c0a78070f46e8e5e101e612e.tar.gz
sci-ad9ae04669682cf6c0a78070f46e8e5e101e612e.tar.bz2
sci-ad9ae04669682cf6c0a78070f46e8e5e101e612e.zip
sys-cluster/hpl: drop package
present in ::gentoo Signed-off-by: Aisha Tammy <gentoo@aisha.cc>
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/hpl/Manifest2
-rw-r--r--sys-cluster/hpl/hpl-2.0-r1.ebuild67
-rw-r--r--sys-cluster/hpl/hpl-2.1.ebuild71
-rw-r--r--sys-cluster/hpl/metadata.xml8
4 files changed, 0 insertions, 148 deletions
diff --git a/sys-cluster/hpl/Manifest b/sys-cluster/hpl/Manifest
deleted file mode 100644
index 492955e56..000000000
--- a/sys-cluster/hpl/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST hpl-2.0.tar.gz 591087 BLAKE2B d3fd738c40f89916c7a5a7cbb561d30c8b9defd08d552b6aeea707f2b6b87a4774d6dce4b9fd7983ee12b112f319e574b89fd8158a381e997dfb86a3572d5f95 SHA512 3aa76144526b01ec40d940cae50d47e480e2760a36d1e95bc6e431b216407db190946fc3d99a6a7caf7b61bcc76d805d28da3ef0b141ff467854e1cdf10bb274
-DIST hpl-2.1.tar.gz 527433 BLAKE2B ccc3f881c3e584ef36801ac5584b5d5e4a354723100c4ffae943689c95763609ea5058b1eb376fe802c8a8c84ce24995aa12301f01cf122462f90308f7ba3588 SHA512 ed39e407341d1cfe2d4d7e50f029e3ca62c7e87e82c3b09a89fd231c5cb4f1c95857f050a940bfd60b724eaa9fdab8631a0693a14b6e9dac82c05897bff557a4
diff --git a/sys-cluster/hpl/hpl-2.0-r1.ebuild b/sys-cluster/hpl/hpl-2.0-r1.ebuild
deleted file mode 100644
index 8b80e4c1c..000000000
--- a/sys-cluster/hpl/hpl-2.0-r1.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit eutils mpi toolchain-funcs
-
-DESCRIPTION="High-Performance Linpack Benchmark for Distributed-Memory Computers"
-HOMEPAGE="http://www.netlib.org/benchmark/hpl/"
-SRC_URI="http://www.netlib.org/benchmark/hpl/hpl-${PV}.tar.gz"
-
-SLOT="0"
-LICENSE="HPL"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc"
-
-RDEPEND="
- $(mpi_pkg_deplist)
- virtual/blas
- virtual/lapack"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-src_prepare() {
- local mpicc_path="$(mpi_pkg_cc)"
-
- cp setup/Make.Linux_PII_FBLAS Make.gentoo_hpl_fblas_x86 || die
- sed -i \
- -e "/^TOPdir/s,= .*,= ${S}," \
- -e '/^HPL_OPTS\>/s,=,= -DHPL_DETAILED_TIMING -DHPL_COPY_L,' \
- -e '/^ARCH\>/s,= .*,= gentoo_hpl_fblas_x86,' \
- -e '/^MPdir\>/s,= .*,=,' \
- -e '/^MPlib\>/s,= .*,=,' \
- -e "/^LAlib\>/s,= .*,= $($(tc-getPKG_CONFIG) --libs-only-l blas lapack)," \
- -e "/^LINKER\>/s,= .*,= ${mpicc_path}," \
- -e "/^CC\>/s,= .*,= ${mpicc_path}," \
- -e "/^LINKFLAGS\>/s|= .*|= ${LDFLAGS} $($(tc-getPKG_CONFIG) --libs-only-L blas lapack)|" \
- Make.gentoo_hpl_fblas_x86 || die
- default
-}
-
-src_compile() {
- # do NOT use emake here
- mpi_pkg_set_env
- # parallel make failure bug #321539
- HOME=${WORKDIR} emake -j1 arch=gentoo_hpl_fblas_x86
- mpi_pkg_restore_env
-}
-
-src_install() {
- mpi_dobin bin/gentoo_hpl_fblas_x86/xhpl
- mpi_dolib.a lib/gentoo_hpl_fblas_x86/libhpl.a
- mpi_dodoc INSTALL BUGS COPYRIGHT HISTORY README TUNING \
- bin/gentoo_hpl_fblas_x86/HPL.dat
- mpi_doman man/man3/*.3
- if use doc; then
- mpi_dohtml -r www/*
- fi
-}
-
-pkg_postinst() {
- local d=$(mpi_root)
- einfo "Remember to copy $(mpi_root)usr/share/doc/${PF}/HPL.dat to your working directory first!"
- einfo "Typically one may run hpl by executing the following:"
- einfo "\"mpiexec -np 4 /usr/bin/xhpl\""
- einfo "where -np specifies the number of processes."
-}
diff --git a/sys-cluster/hpl/hpl-2.1.ebuild b/sys-cluster/hpl/hpl-2.1.ebuild
deleted file mode 100644
index ba91a5d66..000000000
--- a/sys-cluster/hpl/hpl-2.1.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit eutils mpi multilib
-
-DESCRIPTION="High-Performance Linpack Benchmark for Distributed-Memory Computers"
-HOMEPAGE="http://www.netlib.org/benchmark/hpl/"
-SRC_URI="http://www.netlib.org/benchmark/hpl/hpl-${PV}.tar.gz"
-
-SLOT="0"
-LICENSE="HPL"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc"
-
-RDEPEND="
- $(mpi_pkg_deplist)
- virtual/blas
- virtual/lapack"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-src_prepare() {
- local mpicc_path="$(mpi_pkg_cc)"
- local a=""
- local locallib="${EPREFIX}/usr/$(get_libdir)/lib"
-
- cp setup/Make.Linux_PII_FBLAS Make.gentoo_hpl_fblas_x86 || die
- sed -i \
- -e "/^TOPdir/s,= .*,= ${S}," \
- -e '/^HPL_OPTS\>/s,=,= -DHPL_DETAILED_TIMING -DHPL_COPY_L,' \
- -e '/^ARCH\>/s,= .*,= gentoo_hpl_fblas_x86,' \
- -e '/^MPdir\>/s,= .*,=,' \
- -e '/^MPlib\>/s,= .*,=,' \
- -e "/^LAlib\>/s%= .*%= $($(tc-getPKG_CONFIG) --libs blas lapack)%" \
- -e "/^LINKER\>/s,= .*,= ${mpicc_path}," \
- -e "/^CC\>/s,= .*,= ${mpicc_path}," \
- -e "/^CCFLAGS\>/s|= .*|= \$(HPL_DEFS) ${CFLAGS}|" \
- -e "/^LINKFLAGS\>/s|= .*|= ${LDFLAGS}|" \
- Make.gentoo_hpl_fblas_x86 || die
- default
-}
-
-src_compile() {
- # do NOT use emake here
- mpi_pkg_set_env
- # parallel make failure bug #321539
- HOME=${WORKDIR} emake -j1 arch=gentoo_hpl_fblas_x86
- mpi_pkg_restore_env
-}
-
-src_install() {
- mpi_dobin bin/gentoo_hpl_fblas_x86/xhpl
- mpi_dolib.a lib/gentoo_hpl_fblas_x86/libhpl.a
- mpi_dodoc INSTALL BUGS COPYRIGHT HISTORY README TUNING
- mpi_doman man/man3/*.3
- if use doc; then
- mpi_dohtml -r www/*
- fi
- insinto $(mpi_root)usr/share/hpl
- mpi_doins bin/gentoo_hpl_fblas_x86/HPL.dat
-}
-
-pkg_postinst() {
- local d=$(mpi_root)
- einfo "Remember to copy $(mpi_root)usr/share/hpl/HPL.dat to your working directory"
- einfo "before running xhpl. Typically one may run hpl by executing:"
- einfo "\"mpiexec -np 4 /usr/bin/xhpl\""
- einfo "where -np specifies the number of processes."
-}
diff --git a/sys-cluster/hpl/metadata.xml b/sys-cluster/hpl/metadata.xml
deleted file mode 100644
index 8bf4b5f36..000000000
--- a/sys-cluster/hpl/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>cluster@gentoo.org</email>
- <name>Gentoo Cluster Project</name>
- </maintainer>
-</pkgmetadata>