summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-11-21 05:38:00 +0000
committerSam James <sam@gentoo.org>2022-07-22 20:36:46 +0000
commit4f26ab54a0cb90964360b2e99001e395b4bad778 (patch)
tree625a84e4d27b7d123bb358e734bb60cf6b79901f /sys-devel/gdb/gdb-6.6-r2.ebuild
parentdrop outdated packages (diff)
downloadtoolchain-4f26ab54a0cb90964360b2e99001e395b4bad778.tar.gz
toolchain-4f26ab54a0cb90964360b2e99001e395b4bad778.tar.bz2
toolchain-4f26ab54a0cb90964360b2e99001e395b4bad778.zip
Revert "drop outdated packages"
This reverts commit ba79ef07c9aea05907210217ee8bcb705e43c8c7. The overlay exists for older versions of toolchain packages and the commit being reverted removed every single ebuild from the overlay. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-devel/gdb/gdb-6.6-r2.ebuild')
-rw-r--r--sys-devel/gdb/gdb-6.6-r2.ebuild74
1 files changed, 74 insertions, 0 deletions
diff --git a/sys-devel/gdb/gdb-6.6-r2.ebuild b/sys-devel/gdb/gdb-6.6-r2.ebuild
new file mode 100644
index 0000000..c3d0cdd
--- /dev/null
+++ b/sys-devel/gdb/gdb-6.6-r2.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+inherit flag-o-matic eutils
+
+export CTARGET=${CTARGET:-${CHOST}}
+if [[ ${CTARGET} == ${CHOST} ]] ; then
+ if [[ ${CATEGORY} == cross-* ]] ; then
+ export CTARGET=${CATEGORY#cross-}
+ fi
+fi
+
+PATCH_VER="1.3"
+DESCRIPTION="GNU debugger"
+HOMEPAGE="http://sourceware.org/gdb/"
+SRC_URI="mirror://gnu/gdb/${P}.tar.bz2
+ ftp://sourceware.org/pub/gdb/releases/${P}.tar.bz2
+ mirror://gentoo/${P}-patches-${PATCH_VER}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sparc x86 ~x86-fbsd"
+IUSE="nls test vanilla"
+
+RDEPEND=">=sys-libs/ncurses-5.2-r2"
+DEPEND="${RDEPEND}
+ test? ( dev-util/dejagnu )
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ ! use vanilla && EPATCH_SUFFIX="patch" epatch "${WORKDIR}"/patch
+ strip-linguas -u bfd/po opcodes/po
+}
+
+src_compile() {
+ replace-flags -O? -O2
+ econf \
+ --disable-werror \
+ $(use_enable nls) \
+ || die
+ emake || die
+}
+
+src_test() {
+ make check || ewarn "tests failed"
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ libdir=/nukeme includedir=/nukeme \
+ install || die
+ rm -r "${D}"/nukeme || die
+
+ # Don't install docs when building a cross-gdb
+ if [[ ${CTARGET} != ${CHOST} ]] ; then
+ rm -r "${D}"/usr/share
+ return 0
+ fi
+
+ dodoc README
+ docinto gdb
+ dodoc gdb/CONTRIBUTE gdb/README gdb/MAINTAINERS \
+ gdb/NEWS gdb/ChangeLog gdb/PROBLEMS
+ docinto sim
+ dodoc sim/ChangeLog sim/MAINTAINERS sim/README-HACKING
+
+ dodoc "${WORKDIR}"/extra/gdbinit.sample
+
+ # Remove shared info pages
+ rm -f "${D}"/usr/share/info/{annotate,bfd,configure,standards}.info*
+}