summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorJorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>2018-02-20 20:41:33 +0000
committerJorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>2018-02-20 20:41:33 +0000
commit73b92f19276632457cf75055da1e0bc58ee4912c (patch)
tree1eb38e5a03f4f1d21377584f0912bc61cc60330e /dev-db
parentdev-db/phpmyadmin: Update Manifest to use the new hashes. (diff)
downloadjmbsvicetto-73b92f19276632457cf75055da1e0bc58ee4912c.tar.gz
jmbsvicetto-73b92f19276632457cf75055da1e0bc58ee4912c.tar.bz2
jmbsvicetto-73b92f19276632457cf75055da1e0bc58ee4912c.zip
dev-db/phpmyadmin: Security bump to address PMASA-2018-1 (CVE-2018-7260).
Bug: https://bugs.gentoo.org/648330 Signed-off-by: Jorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/phpmyadmin/Manifest1
-rw-r--r--dev-db/phpmyadmin/phpmyadmin-4.7.8.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/dev-db/phpmyadmin/Manifest b/dev-db/phpmyadmin/Manifest
index a894219..de868bd 100644
--- a/dev-db/phpmyadmin/Manifest
+++ b/dev-db/phpmyadmin/Manifest
@@ -1,2 +1,3 @@
DIST phpMyAdmin-4.0.10.20-all-languages.tar.xz 4323896 SHA256 16595dd62c8256caa999beb722d793674da86054e117b9968f82352d84233b24 SHA512 e1d8b8a503eaa19a090d24d5ad011241aab06c2767138424d875edd82a868b4ebcdf5bba154b7eefef23b41d1949dcd021defe17e9047d0bf5fcfd0d6a5f4d27 WHIRLPOOL 80983dbeeca9cf1a279c35c652f4c5c0f239ba2aa9456a0707a1686b1f0322a949cd42fa8d949efce1d9e849ee3030c8487faccc79c1f65458ac73b205f119a6
DIST phpMyAdmin-4.7.7-all-languages.tar.xz 6411768 BLAKE2B 59ea3c69ee6bd019d5ff61f16ec37c39b9f94dde72198acd1892d4212d2258b9913305d22c93f6925426a9554c411ebf1a20beeae0a5b5a4f869a3bf7da9d73b SHA512 7eab8567a7889b79839104c3a46cfa7a841cb7188dc0bb0a306a6e15d06265b70e2b389c25e69bef2ebb77c7460381342322e2cfe546686d9b314b99c9419513
+DIST phpMyAdmin-4.7.8-all-languages.tar.xz 6218056 BLAKE2B 879ef6703711725781fcf3b4c9ab607741c4df0d2f1955f632087e33b599e54128c0811dbd125d9015a0ec597dd6d9af54e7136e91f8637badf698ad7a30b8ba SHA512 ae6edcfba72413a6e0af0b120a99809320a840ab332ae77263f21e14f3b34a38cca70591628ba5818d6732ff6d23551ea51cbf6a75012d2326d0fab1c2a1b9ae
diff --git a/dev-db/phpmyadmin/phpmyadmin-4.7.8.ebuild b/dev-db/phpmyadmin/phpmyadmin-4.7.8.ebuild
new file mode 100644
index 0000000..957fab2
--- /dev/null
+++ b/dev-db/phpmyadmin/phpmyadmin-4.7.8.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+inherit eutils webapp
+
+MY_PV=${PV/_/-}
+MY_PN="phpMyAdmin"
+MY_P="${MY_PN}-${MY_PV}-all-languages"
+
+DESCRIPTION="Web-based administration for MySQL database in PHP"
+HOMEPAGE="https://www.phpmyadmin.net/"
+SRC_URI="https://files.phpmyadmin.net/${MY_PN}/${MY_PV}/${MY_P}.tar.xz"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="setup"
+
+RDEPEND="
+ dev-lang/php[crypt,ctype,filter,json,session,unicode]
+ || (
+ dev-lang/php[mysqli]
+ dev-lang/php[mysql]
+ )
+ virtual/httpd-php:*
+"
+
+need_httpd_cgi
+
+S="${WORKDIR}"/${MY_P}
+
+pkg_setup() {
+ webapp_pkg_setup
+}
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc README RELEASE-DATE-${MY_PV} ChangeLog || die
+ rm -f LICENSE README* RELEASE-DATE-${MY_PV}
+
+ if ! use setup; then
+ rm -rf setup || die "Cannot remove setup utility"
+ elog "The phpMyAdmin setup utility has been removed."
+ elog "It is a regular target of various exploits. If you need it, set USE=setup."
+ else
+ elog "You should consider disabling the setup USE flag"
+ elog "to exclude the setup utility if you don't use it."
+ elog "It regularly is the target of various exploits."
+ fi
+
+ insinto "${MY_HTDOCSDIR#${EPREFIX}}"
+ doins -r .
+
+ webapp_configfile "${MY_HTDOCSDIR#${EPREFIX}}"/libraries/config.default.php
+ webapp_serverowned "${MY_HTDOCSDIR#${EPREFIX}}"/libraries/config.default.php
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en-3.1.txt
+ webapp_src_install
+}