summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2023-09-18 19:38:55 +0300
committerJoonas Niilola <juippis@gentoo.org>2023-09-18 19:39:49 +0300
commitfc8ed35c279112504ed48f3b7a91a095ff5e51f8 (patch)
tree2c4b24ea438ae4d01a3d98dc08b0e06880b12ab5
parentapp-mobilephone/heimdall: 2.0.2 version bump (diff)
downloadgentoo-fc8ed35c279112504ed48f3b7a91a095ff5e51f8.tar.gz
gentoo-fc8ed35c279112504ed48f3b7a91a095ff5e51f8.tar.bz2
gentoo-fc8ed35c279112504ed48f3b7a91a095ff5e51f8.zip
app-mobilephone/heimdall: call udev_reload in pkg_postrm phase
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--app-mobilephone/heimdall/heimdall-2.0.2.ebuild8
-rw-r--r--app-mobilephone/heimdall/heimdall-9999.ebuild6
2 files changed, 11 insertions, 3 deletions
diff --git a/app-mobilephone/heimdall/heimdall-2.0.2.ebuild b/app-mobilephone/heimdall/heimdall-2.0.2.ebuild
index b1c61d9f7b06..7595551d2aa5 100644
--- a/app-mobilephone/heimdall/heimdall-2.0.2.ebuild
+++ b/app-mobilephone/heimdall/heimdall-2.0.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -7,7 +7,7 @@ inherit cmake udev
if [[ ${PV} != 9999 ]]; then
SRC_URI="https://git.sr.ht/~grimler/Heimdall/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="amd64 ~arm64"
+ KEYWORDS="~amd64 ~arm64"
S="${WORKDIR}/Heimdall-v${PV}"
else
inherit git-r3
@@ -50,3 +50,7 @@ src_install() {
pkg_postinst() {
udev_reload
}
+
+pkg_postrm() {
+ udev_reload
+}
diff --git a/app-mobilephone/heimdall/heimdall-9999.ebuild b/app-mobilephone/heimdall/heimdall-9999.ebuild
index b1c61d9f7b06..69599346a8bb 100644
--- a/app-mobilephone/heimdall/heimdall-9999.ebuild
+++ b/app-mobilephone/heimdall/heimdall-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -50,3 +50,7 @@ src_install() {
pkg_postinst() {
udev_reload
}
+
+pkg_postrm() {
+ udev_reload
+}