summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Zander <negril.nx+gentoo@gmail.com>2024-07-31 16:14:23 +0200
committerEli Schwartz <eschwartz@gentoo.org>2024-07-31 17:16:53 -0400
commit7c38af27bfc3c247cdd02f09fbbf05477ab06999 (patch)
tree1b5e0b76b0f103bea4801cfc3745827c112a9ddf /app-arch
parentapp-text/zeal: version bump to 0.7.1 (qt6 only) (diff)
downloadgentoo-7c38af27bfc3c247cdd02f09fbbf05477ab06999.tar.gz
gentoo-7c38af27bfc3c247cdd02f09fbbf05477ab06999.tar.bz2
gentoo-7c38af27bfc3c247cdd02f09fbbf05477ab06999.zip
app-arch/libdeflate: 1.20, 9999 enable multilib
Bug: https://bugs.gentoo.org/930111 Signed-off-by: Paul Zander <negril.nx+gentoo@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/37882 Signed-off-by: Eli Schwartz <eschwartz@gentoo.org>
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/libdeflate/libdeflate-1.20.ebuild6
-rw-r--r--app-arch/libdeflate/libdeflate-9999.ebuild8
2 files changed, 7 insertions, 7 deletions
diff --git a/app-arch/libdeflate/libdeflate-1.20.ebuild b/app-arch/libdeflate/libdeflate-1.20.ebuild
index 62ed3cb5e592..395b2234ceea 100644
--- a/app-arch/libdeflate/libdeflate-1.20.ebuild
+++ b/app-arch/libdeflate/libdeflate-1.20.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit cmake
+inherit cmake-multilib
DESCRIPTION="Heavily optimized DEFLATE/zlib/gzip (de)compression"
HOMEPAGE="https://github.com/ebiggers/libdeflate"
@@ -31,7 +31,7 @@ REQUIRED_USE="
"
DEPEND="
- test? ( sys-libs/zlib )
+ test? ( sys-libs/zlib[${MULTILIB_USEDEP}] )
"
PATCHES=(
@@ -55,5 +55,5 @@ src_configure() {
-DLIBDEFLATE_BUILD_TESTS="$(usex test)"
)
- cmake_src_configure
+ cmake-multilib_src_configure
}
diff --git a/app-arch/libdeflate/libdeflate-9999.ebuild b/app-arch/libdeflate/libdeflate-9999.ebuild
index 2ed3a652def2..395b2234ceea 100644
--- a/app-arch/libdeflate/libdeflate-9999.ebuild
+++ b/app-arch/libdeflate/libdeflate-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit cmake
+inherit cmake-multilib
DESCRIPTION="Heavily optimized DEFLATE/zlib/gzip (de)compression"
HOMEPAGE="https://github.com/ebiggers/libdeflate"
@@ -13,7 +13,7 @@ if [[ ${PV} == *9999* ]]; then
EGIT_REPO_URI="https://github.com/ebiggers/libdeflate.git"
else
SRC_URI="https://github.com/ebiggers/libdeflate/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
fi
LICENSE="MIT"
@@ -31,7 +31,7 @@ REQUIRED_USE="
"
DEPEND="
- test? ( sys-libs/zlib )
+ test? ( sys-libs/zlib[${MULTILIB_USEDEP}] )
"
PATCHES=(
@@ -55,5 +55,5 @@ src_configure() {
-DLIBDEFLATE_BUILD_TESTS="$(usex test)"
)
- cmake_src_configure
+ cmake-multilib_src_configure
}