summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-06-15 23:39:50 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-06-16 00:23:28 +0200
commitceea9a6ae0c3c2b6fe1cc9006a494ffda7c93ff9 (patch)
treee0889fb92e40618193b02452a06bc2ce2961ea38 /app-containers
parentapp-containers/devcontainer: drop old 0.59.1 (diff)
downloadgentoo-ceea9a6ae0c3c2b6fe1cc9006a494ffda7c93ff9.tar.gz
gentoo-ceea9a6ae0c3c2b6fe1cc9006a494ffda7c93ff9.tar.bz2
gentoo-ceea9a6ae0c3c2b6fe1cc9006a494ffda7c93ff9.zip
app-containers/devcontainer: bump to 0.64.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-containers')
-rw-r--r--app-containers/devcontainer/Manifest1
-rw-r--r--app-containers/devcontainer/devcontainer-0.64.0.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/app-containers/devcontainer/Manifest b/app-containers/devcontainer/Manifest
index 86f5a06ef848..107e53f15443 100644
--- a/app-containers/devcontainer/Manifest
+++ b/app-containers/devcontainer/Manifest
@@ -1,2 +1,3 @@
DIST devcontainer-0.60.0.tgz 619324 BLAKE2B 8ef60c2a195b24e850ce923b79983a2514645587a2ef9739a05ce4440140595dad3d87896e6997455daf2afd3d09b8da77d9c304a3ce305b4ab6edb2ea41ab9a SHA512 f1edba9bbb8d635db492daa52d6b38063d426b7860bd9d56327ecf1b66a3777374ee1cc96cff080fe6af7e384e64e608516412c71eb1437c82938868f6389439
DIST devcontainer-0.62.0.tgz 619481 BLAKE2B 69dc4a1b872c9afe4b3ef631f4626973523956c85e192fe1bbaf3930a836aa02c1caf51739a235869cfb67c0628de64069eab8e59a41da70f97c2f3e1d16de16 SHA512 dae5013c13df36ea0f7073a23b7484c8a5261f84bba9a8ed16b094ad89e8d3a9527922dfc43feb7a72a6f172ca9d89197bd05e29172ba433338f3365cf4e9852
+DIST devcontainer-0.64.0.tgz 619776 BLAKE2B 99c5fa724915f107f99d629cef86eff3635bf1a66fedfabd26cef8d83588e609fa9ba51d1264a921c03c4a938302ef3d874a2234904f23da38bc72ddd43c13f8 SHA512 6caea7759074b48760b22bb127feb2d18ae88b7d826f2e4e703de3c0680cbe98ecf0a936b76e80c4a20ab446ca60851e4446e4474fcac62969722260ff474c6f
diff --git a/app-containers/devcontainer/devcontainer-0.64.0.ebuild b/app-containers/devcontainer/devcontainer-0.64.0.ebuild
new file mode 100644
index 000000000000..991cd956e37b
--- /dev/null
+++ b/app-containers/devcontainer/devcontainer-0.64.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Reference implementation of the Development Containers specification"
+HOMEPAGE="https://containers.dev/
+ https://github.com/devcontainers/cli/"
+SRC_URI="https://registry.npmjs.org/@devcontainers/cli/-/cli-${PV}.tgz
+ -> ${P}.tgz"
+S="${WORKDIR}/package"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ net-libs/nodejs
+"
+BDEPEND="
+ >=net-libs/nodejs-16[npm]
+"
+
+DOCS=( CHANGELOG.md README.md )
+
+src_compile() {
+ # Skip, nothing to compile here.
+ :
+}
+
+src_install() {
+ local -a my_npm_opts=(
+ --audit false
+ --color false
+ --foreground-scripts
+ --global
+ --offline
+ --omit dev
+ --prefix "${ED}/usr"
+ --progress false
+ --verbose
+ )
+ npm "${my_npm_opts[@]}" install "${DISTDIR}/${P}.tgz" || die "npm install failed"
+
+ einstalldocs
+}