summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2020-11-14 21:17:29 +0100
committerDavid Seifert <soap@gentoo.org>2020-11-14 21:17:29 +0100
commitdca7f39e5dbe96e6b1ded000f4e4559518421472 (patch)
tree2f11fafb8c9dfc663ff224083445f28d5bcfcff1 /app-crypt/dieharder
parentapp-arch/wimlib: disable static libs (diff)
downloadgentoo-dca7f39e5dbe96e6b1ded000f4e4559518421472.tar.gz
gentoo-dca7f39e5dbe96e6b1ded000f4e4559518421472.tar.bz2
gentoo-dca7f39e5dbe96e6b1ded000f4e4559518421472.zip
app-crypt/dieharder: disable static libs
Closes: https://bugs.gentoo.org/726434 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-crypt/dieharder')
-rw-r--r--app-crypt/dieharder/dieharder-3.31.1-r3.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/app-crypt/dieharder/dieharder-3.31.1-r3.ebuild b/app-crypt/dieharder/dieharder-3.31.1-r3.ebuild
index 8fd1209bd490..269cb352cf1f 100644
--- a/app-crypt/dieharder/dieharder-3.31.1-r3.ebuild
+++ b/app-crypt/dieharder/dieharder-3.31.1-r3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -37,6 +37,10 @@ pkg_setup() {
)
}
+src_configure() {
+ econf --disable-static
+}
+
src_compile() {
emake -j1
use doc && emake -C manual
@@ -53,4 +57,6 @@ src_install() {
dodoc dieharder/README dieharder/NOTES
docinto "libdieharder"
dodoc libdieharder/README libdieharder/NOTES
+
+ find "${ED}" -name '*.la' -delete || die
}