summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-emacs/csharp-mode
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-emacs/csharp-mode')
-rw-r--r--app-emacs/csharp-mode/Manifest1
-rw-r--r--app-emacs/csharp-mode/csharp-mode-0.7.0-r1.ebuild18
-rw-r--r--app-emacs/csharp-mode/files/50csharp-mode-gentoo.el3
-rw-r--r--app-emacs/csharp-mode/files/csharp-mode-0.7.0-emacs-24.4.patch14
-rw-r--r--app-emacs/csharp-mode/metadata.xml5
5 files changed, 41 insertions, 0 deletions
diff --git a/app-emacs/csharp-mode/Manifest b/app-emacs/csharp-mode/Manifest
new file mode 100644
index 000000000000..cf09a3d5a260
--- /dev/null
+++ b/app-emacs/csharp-mode/Manifest
@@ -0,0 +1 @@
+DIST csharp-mode-0.7.0.tar.bz2 6254 SHA256 e72a17972283691c33080aaa60d8060576d2951f1e374da223cf76468bd2eeec SHA512 b6cbf2899853c29f44d19f37a01984a03c61f7bde144880f6f32e2a890d3b90a546ff69ad328d157e5494191aed37836373f49ddbafac49d8b9bd1cea3e22de9 WHIRLPOOL 58816ec16158adb4de40fe27540a3734813012ecd7f345fc048faa4807d85ecef9617d82e30f945ad7dfb1452ef066a1ed3e38c3e792e43940e23464ba70c552
diff --git a/app-emacs/csharp-mode/csharp-mode-0.7.0-r1.ebuild b/app-emacs/csharp-mode/csharp-mode-0.7.0-r1.ebuild
new file mode 100644
index 000000000000..3dd19ba87286
--- /dev/null
+++ b/app-emacs/csharp-mode/csharp-mode-0.7.0-r1.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit elisp
+
+DESCRIPTION="A derived Emacs mode implementing most of the C# rules"
+HOMEPAGE="http://mfgames.com/csharp-mode/start"
+SRC_URI="http://mfgames.com/releases/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+
+ELISP_PATCHES="${P}-emacs-24.4.patch"
+SITEFILE="50${PN}-gentoo.el"
diff --git a/app-emacs/csharp-mode/files/50csharp-mode-gentoo.el b/app-emacs/csharp-mode/files/50csharp-mode-gentoo.el
new file mode 100644
index 000000000000..ea2056b6a29d
--- /dev/null
+++ b/app-emacs/csharp-mode/files/50csharp-mode-gentoo.el
@@ -0,0 +1,3 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'csharp-mode "csharp-mode" "Major mode for editing C# code." t)
+(add-to-list 'auto-mode-alist '("\\.cs\\'" . csharp-mode))
diff --git a/app-emacs/csharp-mode/files/csharp-mode-0.7.0-emacs-24.4.patch b/app-emacs/csharp-mode/files/csharp-mode-0.7.0-emacs-24.4.patch
new file mode 100644
index 000000000000..c3f73201cbae
--- /dev/null
+++ b/app-emacs/csharp-mode/files/csharp-mode-0.7.0-emacs-24.4.patch
@@ -0,0 +1,14 @@
+https://bugs.gentoo.org/528374
+
+--- a/csharp-mode.el
++++ b/csharp-mode.el
+@@ -125,6 +125,9 @@
+ (stringp byte-compile-dest-file))
+ (cons (file-name-directory byte-compile-dest-file) load-path)
+ load-path)))
++ (and (= emacs-major-version 24)
++ (>= emacs-minor-version 4)
++ (require 'cl))
+ (load "cc-mode" nil t)
+ (load "cc-fonts" nil t)
+ (load "cc-langs" nil t)))
diff --git a/app-emacs/csharp-mode/metadata.xml b/app-emacs/csharp-mode/metadata.xml
new file mode 100644
index 000000000000..bc306fe58224
--- /dev/null
+++ b/app-emacs/csharp-mode/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>emacs</herd>
+</pkgmetadata>