summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2024-07-26 22:47:15 +0900
committerAkinori Hattori <hattya@gentoo.org>2024-07-26 22:47:15 +0900
commit83769d8931d67250ceabc9187e6510019013be76 (patch)
tree2eb979c08cac235cf5abc9ebd2a5893953f013ec /app-i18n
parentapp-i18n/ibus-typing-booster: drop old (diff)
downloadgentoo-83769d8931d67250ceabc9187e6510019013be76.tar.gz
gentoo-83769d8931d67250ceabc9187e6510019013be76.tar.bz2
gentoo-83769d8931d67250ceabc9187e6510019013be76.zip
app-i18n/ibus-typing-booster: new upstream release
Signed-off-by: Akinori Hattori <hattya@gentoo.org>
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/ibus-typing-booster/Manifest1
-rw-r--r--app-i18n/ibus-typing-booster/ibus-typing-booster-2.25.14.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/app-i18n/ibus-typing-booster/Manifest b/app-i18n/ibus-typing-booster/Manifest
index e7a475853656..a8db75fefe1f 100644
--- a/app-i18n/ibus-typing-booster/Manifest
+++ b/app-i18n/ibus-typing-booster/Manifest
@@ -1,2 +1,3 @@
DIST ibus-typing-booster-2.25.11.tar.gz 13239747 BLAKE2B 13273ee1bc7b86ff60b79a9303da59b1e7f01675e1bf7919ead5c79ea04068db2aee67ff41610f24112a346f3be079108f6aa1a2e40fcb7cfdb6378aea949326 SHA512 97137a0ad68b96c7a4bbd560f916e1f42f4ee191f867967a35ac52031d48940d1942d4bdcad7d08a0430f8cdc32232c82042460b8fe819c313fc96c72df73db6
DIST ibus-typing-booster-2.25.13.tar.gz 13254481 BLAKE2B 34739007b1bc4a78c731816d6c2659276b93d0ecaf8d28e3c0e81169543b9234314a0b7279de8568f44c0fc87f20e857ead6e41e3799227eac8dc81ab601dd46 SHA512 634a554b6921594cd0f90618fbed15597362b1442e6c1dfb6b2aab8a80010243108b2d7411fde9e87577e60394172f6051ef36330d178eb28a030b58bb343240
+DIST ibus-typing-booster-2.25.14.tar.gz 13450399 BLAKE2B 2a8d5b823e51aee782bede9ddd08b10217744a646f309b46e320359631aee76c4b451d124d365e2b843b09cb8263603da490e99eef0073b8487ff4e42a079f73 SHA512 1687d2c4e51ffc8b84895845c7d37c3d6e186211fe0b2dd4f9bfc2f36168dc3bc993b8cfdc2e49ce108dfe7d1d9bdbc81480e952b832950fcccc53c9e523fe92
diff --git a/app-i18n/ibus-typing-booster/ibus-typing-booster-2.25.14.ebuild b/app-i18n/ibus-typing-booster/ibus-typing-booster-2.25.14.ebuild
new file mode 100644
index 000000000000..97351b6920ac
--- /dev/null
+++ b/app-i18n/ibus-typing-booster/ibus-typing-booster-2.25.14.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_REQ_USE="sqlite(+)"
+
+inherit gnome2-utils python-single-r1 xdg
+
+DESCRIPTION="Completion input method for IBus"
+HOMEPAGE="https://mike-fabian.github.io/ibus-typing-booster"
+SRC_URI="https://github.com/mike-fabian/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ dev-libs/m17n-lib
+ $(python_gen_cond_dep '
+ app-i18n/ibus[python(+),${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pyenchant[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/pyxdg[${PYTHON_USEDEP}]
+ ')"
+RDEPEND="${DEPEND}
+ >=dev-db/m17n-db-1.7"
+BDEPEND="sys-devel/gettext
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ sed -i "s|/usr\(/bin/sh\)|\1|" {engine,setup}/*.in
+}
+
+pkg_preinst() {
+ xdg_pkg_preinst
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}