summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2020-07-20 09:57:14 +0200
committerAlfredo Tupone <tupone@gentoo.org>2020-07-20 09:58:07 +0200
commit39559f13bcdf09517195c5c37f5f50dc4f59bb08 (patch)
tree52fe8ae108a54c511b8c5e2bf5d08ef1763ac99b /dev-db/phppgadmin
parentmedia-sound/hydrogen: fixed qttest dep which is needed always (diff)
downloadgentoo-39559f13bcdf09517195c5c37f5f50dc4f59bb08.tar.gz
gentoo-39559f13bcdf09517195c5c37f5f50dc4f59bb08.tar.bz2
gentoo-39559f13bcdf09517195c5c37f5f50dc4f59bb08.zip
dev-db/phppgadmin: readd to the tree
Package-Manager: Portage-2.3.99, Repoman-2.3.23 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-db/phppgadmin')
-rw-r--r--dev-db/phppgadmin/Manifest1
-rw-r--r--dev-db/phppgadmin/files/postinstall-en.txt4
-rw-r--r--dev-db/phppgadmin/metadata.xml11
-rw-r--r--dev-db/phppgadmin/phppgadmin-5.6.0.ebuild38
4 files changed, 54 insertions, 0 deletions
diff --git a/dev-db/phppgadmin/Manifest b/dev-db/phppgadmin/Manifest
new file mode 100644
index 000000000000..9ef1200084b2
--- /dev/null
+++ b/dev-db/phppgadmin/Manifest
@@ -0,0 +1 @@
+DIST phpPgAdmin-5.6.0.tar.bz2 880640 BLAKE2B a49fb97c26c35323b567f06002cc6da9f3efacb4be99633e6ad4d6a53015e557ef3c98a4bf9c4dedf525b86354816e744f6159bad7db6f52fe2c03223f0be9a1 SHA512 afe4c99322bb24bf1895afb20dd87dcad1fc7d887b9271d9dd6b56779a7b5c8aa7293cdc7fa560a62a830adbf5453914a4783a1265915b24594779c0beeaecda
diff --git a/dev-db/phppgadmin/files/postinstall-en.txt b/dev-db/phppgadmin/files/postinstall-en.txt
new file mode 100644
index 000000000000..003fe5003bbd
--- /dev/null
+++ b/dev-db/phppgadmin/files/postinstall-en.txt
@@ -0,0 +1,4 @@
+Make sure you edit ${MY_INSTALLDIR}/conf/config.inc.php
+
+To use the reports database, you have to manually execute
+psql -f ${MY_INSTALLDIR}/sql/reports-pgsql.sql
diff --git a/dev-db/phppgadmin/metadata.xml b/dev-db/phppgadmin/metadata.xml
new file mode 100644
index 000000000000..8390195bb165
--- /dev/null
+++ b/dev-db/phppgadmin/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>tupone@gentoo.org</email>
+ <name>Tupone Alfredo</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">phppgadmin</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-db/phppgadmin/phppgadmin-5.6.0.ebuild b/dev-db/phppgadmin/phppgadmin-5.6.0.ebuild
new file mode 100644
index 000000000000..e0ec4521ab80
--- /dev/null
+++ b/dev-db/phppgadmin/phppgadmin-5.6.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit webapp
+
+MY_P="phpPgAdmin-${PV}"
+
+DESCRIPTION="Web-based administration for Postgres database in php"
+HOMEPAGE="http://phppgadmin.sourceforge.net/"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/REL_$(ver_rs 1- -)/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="dev-lang/php[postgres,session]"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ webapp_src_preinst
+
+ local doc
+ local docs="CREDITS DEVELOPERS FAQ HISTORY INSTALL TODO TRANSLATORS"
+ dodoc ${docs}
+ mv conf/config.inc.php-dist conf/config.inc.php
+
+ cp -r * "${D}"${MY_HTDOCSDIR}
+ for doc in ${docs} INSTALL LICENSE; do
+ rm -f "${D}"${MY_HTDOCSDIR}/${doc}
+ done
+
+ webapp_configfile ${MY_HTDOCSDIR}/conf/config.inc.php
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+ webapp_src_install
+}