summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2020-11-23 15:15:04 -0800
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2020-11-23 16:39:11 -0800
commit386ce9fb4a7ed7dec4553d410ffbf5c5a5341aee (patch)
tree7a14326bfd2e84bb9ada49e098350851a3737978 /dev-lang/rust
parentdev-lang/rust-bin: always eselect newest rust (diff)
downloadgentoo-386ce9fb4a7ed7dec4553d410ffbf5c5a5341aee.tar.gz
gentoo-386ce9fb4a7ed7dec4553d410ffbf5c5a5341aee.tar.bz2
gentoo-386ce9fb4a7ed7dec4553d410ffbf5c5a5341aee.zip
dev-lang/rust: always eselect latest rust
Package-Manager: Portage-3.0.10, Repoman-3.0.2 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'dev-lang/rust')
-rw-r--r--dev-lang/rust/rust-1.45.2.ebuild2
-rw-r--r--dev-lang/rust/rust-1.46.0.ebuild2
-rw-r--r--dev-lang/rust/rust-1.47.0-r1.ebuild2
3 files changed, 3 insertions, 3 deletions
diff --git a/dev-lang/rust/rust-1.45.2.ebuild b/dev-lang/rust/rust-1.45.2.ebuild
index 767a01b9f91b..022e6bc56ca6 100644
--- a/dev-lang/rust/rust-1.45.2.ebuild
+++ b/dev-lang/rust/rust-1.45.2.ebuild
@@ -523,7 +523,7 @@ src_install() {
}
pkg_postinst() {
- eselect rust update --if-unset
+ eselect rust update
elog "Rust installs a helper script for calling GDB and LLDB,"
elog "for your convenience it is installed under /usr/bin/rust-{gdb,lldb}-${PV}."
diff --git a/dev-lang/rust/rust-1.46.0.ebuild b/dev-lang/rust/rust-1.46.0.ebuild
index 9bb19adc29f4..3be34e81fda6 100644
--- a/dev-lang/rust/rust-1.46.0.ebuild
+++ b/dev-lang/rust/rust-1.46.0.ebuild
@@ -558,7 +558,7 @@ src_install() {
}
pkg_postinst() {
- eselect rust update --if-unset
+ eselect rust update
elog "Rust installs a helper script for calling GDB and LLDB,"
elog "for your convenience it is installed under /usr/bin/rust-{gdb,lldb}-${PV}."
diff --git a/dev-lang/rust/rust-1.47.0-r1.ebuild b/dev-lang/rust/rust-1.47.0-r1.ebuild
index eb58cb752e8e..3b09bae51840 100644
--- a/dev-lang/rust/rust-1.47.0-r1.ebuild
+++ b/dev-lang/rust/rust-1.47.0-r1.ebuild
@@ -576,7 +576,7 @@ src_install() {
}
pkg_postinst() {
- eselect rust update --if-unset
+ eselect rust update
elog "Rust installs a helper script for calling GDB and LLDB,"
elog "for your convenience it is installed under /usr/bin/rust-{gdb,lldb}-${PV}."