summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-02-29 00:45:50 +0000
committerSam James <sam@gentoo.org>2024-02-29 00:45:50 +0000
commit0ce97e67de4e5ca16fa28930949bbea55df91185 (patch)
treec92f51fd11ee50f156bab87efe4be0f775c00ce4 /dev-libs/libev
parentwww-client/elinks: mark LTO-unsafe (diff)
downloadgentoo-0ce97e67de4e5ca16fa28930949bbea55df91185.tar.gz
gentoo-0ce97e67de4e5ca16fa28930949bbea55df91185.tar.bz2
gentoo-0ce97e67de4e5ca16fa28930949bbea55df91185.zip
dev-libs/libev: filter LTO, no-SA
Broken quite badly, no upstream bug tracker AFAICT. And broken in many bundled copies all over the place (which are modified...) Closes: https://bugs.gentoo.org/855869 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/libev')
-rw-r--r--dev-libs/libev/libev-4.33.ebuild12
1 files changed, 10 insertions, 2 deletions
diff --git a/dev-libs/libev/libev-4.33.ebuild b/dev-libs/libev/libev-4.33.ebuild
index 127618dc6d37..b8ffdb37c3da 100644
--- a/dev-libs/libev/libev-4.33.ebuild
+++ b/dev-libs/libev/libev-4.33.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit autotools multilib-minimal
+inherit autotools flag-o-matic multilib-minimal
DESCRIPTION="A high-performance event loop/event model with lots of feature"
HOMEPAGE="http://software.schmorp.de/pkg/libev.html"
@@ -27,6 +27,14 @@ src_prepare() {
eautoreconf
}
+src_configure() {
+ # See bug #855869 and its large number of dupes in bundled libev copies.
+ filter-lto
+ append-flags -fno-strict-aliasing
+
+ multilib-minimal_src_configure
+}
+
multilib_src_configure() {
ECONF_SOURCE="${S}" \
econf \