summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2024-01-14 03:34:28 +0100
committerConrad Kostecki <conikost@gentoo.org>2024-01-14 03:34:28 +0100
commit1e580706d90e381d75f5a7398cb08e861c1a35bf (patch)
treee6d5c1fc04d6ff3c69141fb0e7965104370062a5 /dev-lua
parentdev-lua/luacheck: stable all-arches (diff)
downloadgentoo-1e580706d90e381d75f5a7398cb08e861c1a35bf.tar.gz
gentoo-1e580706d90e381d75f5a7398cb08e861c1a35bf.tar.bz2
gentoo-1e580706d90e381d75f5a7398cb08e861c1a35bf.zip
dev-lua/luacheck: drop 1.1.1
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-lua')
-rw-r--r--dev-lua/luacheck/Manifest1
-rw-r--r--dev-lua/luacheck/luacheck-1.1.1.ebuild66
2 files changed, 0 insertions, 67 deletions
diff --git a/dev-lua/luacheck/Manifest b/dev-lua/luacheck/Manifest
index 875925070cb1..96122383debe 100644
--- a/dev-lua/luacheck/Manifest
+++ b/dev-lua/luacheck/Manifest
@@ -1,2 +1 @@
-DIST luacheck-1.1.1.tar.gz 179107 BLAKE2B 48fb07d4d74206581054718c0b422a65b7de01d7e5f05cd9139f19a74bbe0fc0f98977e6b4c97e2d984db98e18a9fe7b3eefaf44b8ab71bf95f84a5c649e9ca6 SHA512 0294cfc49a8a6c1c2ee4d326fd85bf1c8040b6053ed68975d7aa65a33956d9ad8d715281efc319d54ad8f1b66888a0ff263da8d2ccaace16b51bac87d0fb86c7
DIST luacheck-1.1.2.tar.gz 179240 BLAKE2B 52fdf895e14ec42f86078c9a0be3adc91b0d51c525281ec19cc41671437ca2a29a79c1a826026de11b433368b306ddf2b21473b90975d1de1c13b160d208a25b SHA512 38b22cc0fd00905572859092c4138081c5be434b6e3314bc6cee14b859b0fa1dbb078c6474588891ec3e75b378a7be9a09ee164a4ef9291378193f3bdda10365
diff --git a/dev-lua/luacheck/luacheck-1.1.1.ebuild b/dev-lua/luacheck/luacheck-1.1.1.ebuild
deleted file mode 100644
index 24f1c2ecb635..000000000000
--- a/dev-lua/luacheck/luacheck-1.1.1.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-LUA_COMPAT=( lua5-{1..4} luajit )
-
-inherit lua
-
-DESCRIPTION="A tool for linting and static analysis of Lua code"
-HOMEPAGE="https://github.com/lunarmodules/luacheck"
-SRC_URI="https://github.com/lunarmodules/luacheck/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~hppa ~ia64 ppc ppc64 ~riscv ~sparc x86"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-lua/lua-argparse[${LUA_USEDEP}]
- dev-lua/lua-utf8[${LUA_USEDEP}]
- dev-lua/luafilesystem[${LUA_USEDEP}]
-"
-
-DEPEND="${RDEPEND}"
-
-BDEPEND="
- virtual/pkgconfig
- doc? ( dev-python/sphinx )
- test? (
- dev-lua/busted[${LUA_USEDEP}]
- dev-lua/lua_cliargs[${LUA_USEDEP}]
- ${RDEPEND}
- )
-"
-
-PATCHES=( "${FILESDIR}/${PN}-0.23.0-disable-measuring-performance-test.patch" )
-
-src_compile() {
- if use doc; then
- sphinx-build docsrc html || die
- fi
-}
-
-lua_src_test() {
- busted --lua=${ELUA} || die
-}
-
-src_test() {
- lua_foreach_impl lua_src_test
-}
-
-lua_src_install() {
- insinto "$(lua_get_lmod_dir)"
- doins -r src/luacheck
-}
-
-src_install() {
- lua_foreach_impl lua_src_install
-
- newbin bin/luacheck.lua luacheck
-
- use doc && local -a HTML_DOCS=( "html/." )
- einstalldocs
-}