summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2022-01-26 08:55:19 +0100
committerAlfredo Tupone <tupone@gentoo.org>2022-01-26 08:55:19 +0100
commit6593fe642942bc22ddf1cb5a9e83361833b05d7c (patch)
treec387f2b6d6122ecf0916a97720578db2ce10f65c /dev-ml/merlin
parentdev-python/django-configurations: Bump to 2.3.2 (diff)
downloadgentoo-6593fe642942bc22ddf1cb5a9e83361833b05d7c.tar.gz
gentoo-6593fe642942bc22ddf1cb5a9e83361833b05d7c.tar.bz2
gentoo-6593fe642942bc22ddf1cb5a9e83361833b05d7c.zip
dev-ml/merlin: 4.4 bump. ocaml 4.13 ready
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml/merlin')
-rw-r--r--dev-ml/merlin/Manifest3
-rw-r--r--dev-ml/merlin/merlin-4.4.ebuild93
2 files changed, 96 insertions, 0 deletions
diff --git a/dev-ml/merlin/Manifest b/dev-ml/merlin/Manifest
index 93d634bcf027..1159f08039b6 100644
--- a/dev-ml/merlin/Manifest
+++ b/dev-ml/merlin/Manifest
@@ -3,3 +3,6 @@ DIST merlin-4.2-411.tar.gz 1601588 BLAKE2B 348b48ccf2b209bb511450e4ba46ceb3639b1
DIST merlin-4.2-ocaml-4.12.patch.gz 816740 BLAKE2B d96ab1059683799312fc8828e8a46bccaae9279b6d711eb7ed47b6e8631d80e09f236bf6f726bafb37ae243457df3220a9948f4f6de6da20c2a6c66a1edb8f3f SHA512 4eef08ac8a7f240596395d8460a4d3195c1483fb686aa7d5231d7ea28c9c6996196890f76feae951d2539ac7abc1f16ee3c453031e6d19af554ff27d67a63229
DIST merlin-4.3.1-411.tar.gz 1626551 BLAKE2B c4340ff9b50c72208c4cb13d13e26f36463d7c257530d183a293eaaf3d86aaa71745d8154bb5c0e2149003b3cbe5a127fb6187e7bb7fa7024924fd239f981cfc SHA512 bcbba0c1bb1c84eef7becc4a537e1c2a4bd370a33333bfba1029c82fa8b1d9cdf367f98779fe3329286e418c41b06b49bfe796f5cf8058bcd189b4f33aad1abf
DIST merlin-4.3.1-ocaml-4.12.patch.gz 818559 BLAKE2B accf65bd5d5798bafe2be022d685da8f829aa9a9c98784420d8a62646d80ab73d1e189e3601266e09eebd4732ae241e8d11dc9663adac3b03a555db663a6d649 SHA512 8823b6e30e49ab3cf35a78063066f01aa7dcbc9174d45b0fed94a3f50e388c35e7ac810c5548c57d7bcf9304b045c483080496865b011269913120a5509a1149
+DIST merlin-4.4-411.tbz 1314200 BLAKE2B 0d16308e1ece70f8200e78233ecdff553f28e9a83b17f044eba8a4af170b65935b59ecf6e887299d9373b16d0a0cce24e0f9697f7cde4b3889df9db954e796c8 SHA512 82e4b025db6c6ec0c8b53bce82e980bfc2a507b9092dc513fb10c11be0bc2e37ad9efd5436263ecfa03acc3ec3a4b20ef9599b1814abe530f99d84b2f484fecc
+DIST merlin-4.4-412.tbz 1762888 BLAKE2B adee3863e6fab90643db91b5da418324c65d9b2712140fa4f6b65ef3915bc24126a2cf8c2ceda14a914213595ed1951c7c79c388be7ca407f59c230bcc95eecb SHA512 f51b2875b75215d0be378de86b9dca0957b5e62241ce625a46c6341c219582510d37af94dedf67e1d3db61ebacfef8fa764e4719fac16c0b4b99bb85d0b991d4
+DIST merlin-4.4-413.tbz 2284368 BLAKE2B 1c7f0c9cda8dda4fa91888c3ba91eb74cacffe54bdcc3b9ca49ea816558216ece50cab5f69c4d54298610ca0781a6332a8d0e1ed7526711c97fbc1748f45c309 SHA512 b0bf3c7d72dfc7c70e22d60afca5b7fee71a35127839181fdb46e1e15a230e58765960548c545bbef4fdab180291c738cacb724b9ecf284eee5640ebef07c4ff
diff --git a/dev-ml/merlin/merlin-4.4.ebuild b/dev-ml/merlin/merlin-4.4.ebuild
new file mode 100644
index 000000000000..2975d266d475
--- /dev/null
+++ b/dev-ml/merlin/merlin-4.4.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# TODO: vim-plugin, although it's not clear how to make it work here
+inherit elisp-common dune
+
+DESCRIPTION="Context sensitive completion for OCaml in Vim and Emacs"
+HOMEPAGE="https://github.com/ocaml/merlin"
+SRC_URI="https://github.com/ocaml/merlin/releases/download/v${PV}-411/${P}-411.tbz
+ https://github.com/ocaml/merlin/releases/download/v${PV}-412/${P}-412.tbz
+ https://github.com/ocaml/merlin/releases/download/v${PV}-413/${P}-413.tbz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="emacs +ocamlopt test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-ml/csexp:=
+ dev-ml/yojson:=
+ dev-ml/menhir:=
+ >=dev-ml/dune-2.9
+ || (
+ dev-lang/ocaml:0/4.11
+ dev-lang/ocaml:0/4.12
+ dev-lang/ocaml:0/4.13
+ )
+ emacs? (
+ >=app-editors/emacs-23.1:*
+ app-emacs/auto-complete
+ app-emacs/company-mode
+ )
+"
+DEPEND="${RDEPEND}
+ test? ( app-misc/jq )"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_unpack() {
+ default
+ if has_version "dev-lang/ocaml:0/4.11" ; then
+ mv merlin-4.4-411 "${S}" || die
+ elif has_version "dev-lang/ocaml:0/4.12" ; then
+ mv merlin-4.4-412 "${S}" || die
+ elif has_version "dev-lang/ocaml:0/4.13" ; then
+ mv merlin-4.4-413 "${S}" || die
+ fi
+}
+
+src_prepare() {
+ default
+
+ # Handle installation via the eclass
+ rm emacs/dune || die
+
+ # rm failing test
+ rm -r tests/test-dirs/locate/context-detection/cd-mod_constr.t || die
+}
+
+src_compile() {
+ dune build @install
+
+ if use emacs ; then
+ # Build the emacs integration
+ cd emacs || die
+
+ # iedit isn't packaged yet
+ rm merlin-iedit.el || die
+
+ elisp-compile *.el
+ fi
+}
+
+src_install() {
+ dune_src_install
+
+ if use emacs ; then
+ cd "${S}/emacs" || die
+ elisp-install ${PN} *.el *.elc
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}