summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2023-07-02 08:07:34 +0200
committerAlfredo Tupone <tupone@gentoo.org>2023-07-02 09:21:21 +0200
commit613676b0015489265bd138e72c41c89f1fad1ca6 (patch)
tree667148e0c5f0fdb0e7714975372becd37c6decdc /dev-ml/ppx_custom_printf
parentdev-ml/ocaml_intrinsics: add 0.16.0 (diff)
downloadgentoo-613676b0015489265bd138e72c41c89f1fad1ca6.tar.gz
gentoo-613676b0015489265bd138e72c41c89f1fad1ca6.tar.bz2
gentoo-613676b0015489265bd138e72c41c89f1fad1ca6.zip
dev-ml/ppx_custom_printf: add 0.16.0
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml/ppx_custom_printf')
-rw-r--r--dev-ml/ppx_custom_printf/Manifest1
-rw-r--r--dev-ml/ppx_custom_printf/ppx_custom_printf-0.16.0.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-ml/ppx_custom_printf/Manifest b/dev-ml/ppx_custom_printf/Manifest
index c2d0ede4ff2f..d468f35b66b5 100644
--- a/dev-ml/ppx_custom_printf/Manifest
+++ b/dev-ml/ppx_custom_printf/Manifest
@@ -1,3 +1,4 @@
DIST ppx_custom_printf-0.14.0.tar.gz 9600 BLAKE2B 7b921188e158d59a160502b410ac780709b40fd408cf2e06a0adb70952ef3e72144deaee1c40df512cc09997ce87621e0be2a32d28e8408914fb90f3416e0532 SHA512 2f607df87aa372ef602b4aeb44a2d697ff8696001161e544398c3675280ef7af402f4b34b8cfce900791129d2a9db13ccbf4e73518f58487adc47d5188c8652c
DIST ppx_custom_printf-0.14.1.tar.gz 9606 BLAKE2B 81999f3534fcf8daa965274f93812442b170c8bb7bd05d6b4ba2cb7f506e6bba44dadec355733adec790262be25ad62016356cdf7e0ddcebf2080a3238314543 SHA512 0acb5a2964c996a34d1759c1db73219d4db813ab6b96f80feffae34cbcd73fc8c8ab40ccad7ad378d730acb45eff26906533b29716398fc1c10a7bb4ff949443
DIST ppx_custom_printf-0.15.0.tar.gz 9609 BLAKE2B f9a855559bea50d2aec44cc5ed78010afa66bfafe12906a0f115ba484709a759383b41e7bc4fb8557e9869c0c67a6035451a7f1184be0658371c4300e593de39 SHA512 f8776e9037f491b120b0d43ac9b76231c422b9e5f0d7c3f75efdadf9d4ec401266d61f441a2c7c831c99fac10ac98d84e4e62eda44e6fc86f2fa60ead5ecbc86
+DIST ppx_custom_printf-0.16.0.tar.gz 9729 BLAKE2B a527652e9f5ecc2f64f48e77c6d05c8b27e49a01d78132986943c86e6123de673cf34c019b25a9882c9acaeab88302c15d819e80adc09422b42f2d6a6f6975a5 SHA512 9fc09f5434ca41681f2c8c749aa0c3bae051ee3645e820e0e8a16ab0c1ab630b0c9b0af86ef282eade7020635a066729abb9b7d8d91c1667b9e9f1770131f8b7
diff --git a/dev-ml/ppx_custom_printf/ppx_custom_printf-0.16.0.ebuild b/dev-ml/ppx_custom_printf/ppx_custom_printf-0.16.0.ebuild
new file mode 100644
index 000000000000..5b8ba919077e
--- /dev/null
+++ b/dev-ml/ppx_custom_printf/ppx_custom_printf-0.16.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Printf-style format-strings for user-defined string conversion"
+HOMEPAGE="https://github.com/janestreet/ppx_custom_printf"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+ocamlopt"
+
+DEPEND="
+ >=dev-lang/ocaml-4.14
+ dev-ml/ppx_sexp_conv:${SLOT}
+ >=dev-ml/ppxlib-0.28.0:=
+"
+RDEPEND="${DEPEND}"