summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2024-06-15 13:57:00 +0200
committerAlfredo Tupone <tupone@gentoo.org>2024-06-15 17:55:14 +0200
commit1f404d95bd87c649b2603639249a655e35877ec7 (patch)
treee47dc2dc718a0ce75818424b5e1946a0748357d3 /dev-ml
parentdev-ml/base_bigstring: add 0.17.0 (diff)
downloadgentoo-1f404d95bd87c649b2603639249a655e35877ec7.tar.gz
gentoo-1f404d95bd87c649b2603639249a655e35877ec7.tar.bz2
gentoo-1f404d95bd87c649b2603639249a655e35877ec7.zip
dev-ml/core: add 0.17.1
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/core/Manifest1
-rw-r--r--dev-ml/core/core-0.17.1.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-ml/core/Manifest b/dev-ml/core/Manifest
index 144daecced49..4ca4b6709bec 100644
--- a/dev-ml/core/Manifest
+++ b/dev-ml/core/Manifest
@@ -3,3 +3,4 @@ DIST core-0.14.1.tar.gz 361679 BLAKE2B ca43016c760e620f9073defd84a07bacaa0557d42
DIST core-0.15.0.tar.gz 522984 BLAKE2B b6fdc9d7fe133c504f89ba492e63d090e2ca4e413e96eb8c216213ea358d84ae89ef1d372525b53f701e8076e4e0670ea3535f399f3f735b3b7da383901def09 SHA512 a73a3c1c6f0ade9a9e49917bb896e62afc4fda44dd90ffa99ef9ba24debe7166b4fe1b374500a044cad8318d12f250de7fe2dd935015efde379cf91a2241f51b
DIST core-0.15.1.tar.gz 522517 BLAKE2B 1dc1245708f392161ce04ab121dfff550f13a8aa75b967bc3c32f474641b455355bbeb63ef1c7492947f46c3391cd877b96a8e35c083d0406135e840647715b2 SHA512 2c04fdd989d016faaa2dee4b13372d3e228f0011151ae5f747c1eb6206820a61779a87eb7e2ecc6e1ddf77872a69a07636a93d24df61b4a2ba2a1b745f499b16
DIST core-0.16.1.tar.gz 542242 BLAKE2B ad0b3c1b55b960f040dc0ed82a2c3c19447dfe635d2d25adab63a0ea529867cd6692fe258af3c5896ea63b5438f96b75007b4e2e5ea1d34b3c13936a7b369aeb SHA512 5f9f4400b6e42b74ffd57223cb67884368d324739565bbb20162547ede8bd6d0ece3cc265503b674829f9cf373784e8036d4c73e26e9196aa5446de69b63e181
+DIST core-0.17.1.tar.gz 631656 BLAKE2B 88a1c7b4c1ce5e8ca9713a1e92e4ea141aab1b5926427e78855f403449e3104052afca6f66a19d8b4a9b6d5dbac510d0844ace7e74ee7a7a5d6b89528412c94f SHA512 61b415f4fb12c78d30649fff1aabe3a475eea926ce6edb7774031f4dc7f37ea51f5d9337ead6ec73cd93da5fd1ed0f2738c210c71ebc8fe9d7f6135a06bd176f
diff --git a/dev-ml/core/core-0.17.1.ebuild b/dev-ml/core/core-0.17.1.ebuild
new file mode 100644
index 000000000000..b181c9fb8087
--- /dev/null
+++ b/dev-ml/core/core-0.17.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Jane Street's alternative to the standard library"
+HOMEPAGE="https://github.com/janestreet/core"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64"
+IUSE="+ocamlopt"
+
+RDEPEND="
+ >=dev-lang/ocaml-5
+ dev-ml/base:${SLOT}[ocamlopt?]
+ dev-ml/base_bigstring:${SLOT}[ocamlopt?]
+ dev-ml/base_quickcheck:${SLOT}[ocamlopt?]
+ dev-ml/bin_prot:${SLOT}[ocamlopt?]
+ dev-ml/fieldslib:${SLOT}[ocamlopt?]
+ dev-ml/jane-street-headers:${SLOT}[ocamlopt?]
+ dev-ml/jst-config:${SLOT}[ocamlopt?]
+ dev-ml/ppx_assert:${SLOT}[ocamlopt?]
+ dev-ml/ppx_base:${SLOT}[ocamlopt?]
+ dev-ml/ppx_diff:${SLOT}[ocamlopt?]
+ dev-ml/ppx_hash:${SLOT}[ocamlopt?]
+ dev-ml/ppx_inline_test:${SLOT}[ocamlopt?]
+ dev-ml/ppx_jane:${SLOT}[ocamlopt?]
+ dev-ml/ppx_optcomp:${SLOT}[ocamlopt?]
+ dev-ml/ppx_sexp_conv:${SLOT}[ocamlopt?]
+ dev-ml/ppx_sexp_message:${SLOT}[ocamlopt?]
+ dev-ml/sexplib:${SLOT}[ocamlopt?]
+ dev-ml/splittable_random:${SLOT}[ocamlopt?]
+ dev-ml/stdio:${SLOT}[ocamlopt?]
+ dev-ml/time_now:${SLOT}[ocamlopt?]
+ dev-ml/typerep:${SLOT}[ocamlopt?]
+ dev-ml/variantslib:${SLOT}[ocamlopt?]
+"
+DEPEND="${RDEPEND}"
+BDEPEND=">=dev-ml/dune-3.11"