summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-07-01 03:53:37 +1200
committerKent Fredric <kentnl@gentoo.org>2020-07-01 04:01:53 +1200
commit7fbfc32611f111174ac4f7b8d2f2d8e3303f5304 (patch)
treec001b80a0ef949f2e8d890642829969fc195ef43 /dev-perl/Crypt-DES
parentdev-util/clazy: Remove TrailingEmptyLine (diff)
downloadgentoo-7fbfc32611f111174ac4f7b8d2f2d8e3303f5304.tar.gz
gentoo-7fbfc32611f111174ac4f7b8d2f2d8e3303f5304.tar.bz2
gentoo-7fbfc32611f111174ac4f7b8d2f2d8e3303f5304.zip
dev-perl/Crypt-DES: -r bump for EAPI7 and fixes
- EAPI7 - Correct BDEPENDS slightly - Ensure CFLAGS passed through to make ( the existing code that appeared to do this simply _DID NOT WORK_ ) Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/Crypt-DES')
-rw-r--r--dev-perl/Crypt-DES/Crypt-DES-2.70.0-r2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-perl/Crypt-DES/Crypt-DES-2.70.0-r2.ebuild b/dev-perl/Crypt-DES/Crypt-DES-2.70.0-r2.ebuild
new file mode 100644
index 000000000000..ebaea9455c7b
--- /dev/null
+++ b/dev-perl/Crypt-DES/Crypt-DES-2.70.0-r2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=DPARIS
+DIST_VERSION=2.07
+inherit perl-module
+
+DESCRIPTION="Perl DES encryption module"
+
+LICENSE="DES"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ virtual/perl-ExtUtils-MakeMaker
+ test? ( dev-perl/Crypt-CBC )
+"
+src_compile() {
+ mymake=(
+ "OPTIMIZE=${CFLAGS}"
+ )
+ perl-module_src_compile
+}