summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViorel Munteanu <ceamac@gentoo.org>2024-07-11 20:27:32 +0300
committerViorel Munteanu <ceamac@gentoo.org>2024-07-11 21:43:31 +0300
commita7af51316af6c432fd07a74d8d17b096376bfc00 (patch)
tree8a61a98f50db22f1a090e89909a9a36a728cbc02 /dev-php
parentdev-php/PEAR-File_Fortune: treeclean (diff)
downloadgentoo-a7af51316af6c432fd07a74d8d17b096376bfc00.tar.gz
gentoo-a7af51316af6c432fd07a74d8d17b096376bfc00.tar.bz2
gentoo-a7af51316af6c432fd07a74d8d17b096376bfc00.zip
dev-php/PEAR-File_Gettext: treeclean
Bug: https://bugs.gentoo.org/933998 Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/PEAR-File_Gettext/Manifest1
-rw-r--r--dev-php/PEAR-File_Gettext/PEAR-File_Gettext-0.4.2-r1.ebuild14
-rw-r--r--dev-php/PEAR-File_Gettext/files/File_Gettext-0.4.2-construct.patch67
-rw-r--r--dev-php/PEAR-File_Gettext/metadata.xml8
4 files changed, 0 insertions, 90 deletions
diff --git a/dev-php/PEAR-File_Gettext/Manifest b/dev-php/PEAR-File_Gettext/Manifest
deleted file mode 100644
index ebf5d3abba5b..000000000000
--- a/dev-php/PEAR-File_Gettext/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST File_Gettext-0.4.2.tgz 7307 BLAKE2B f1eae4724c62a44515107a0e4cb89aa7abff8f856c5f11a90f6b78dc4e5601cc024e64e8ae0344c3433ffc5355e2dbb9d7e3cc745001ad2098a073bbca0a97da SHA512 cc56430076485d90afca548c78650a2ada4eb8df7e0a58458eded2dca222466aba91d982fb0103e6b63fc4c8140c3ac4c2a4a7c3c77fbc7740922a8b4e33c6a9
diff --git a/dev-php/PEAR-File_Gettext/PEAR-File_Gettext-0.4.2-r1.ebuild b/dev-php/PEAR-File_Gettext/PEAR-File_Gettext-0.4.2-r1.ebuild
deleted file mode 100644
index 87201d00a906..000000000000
--- a/dev-php/PEAR-File_Gettext/PEAR-File_Gettext-0.4.2-r1.ebuild
+++ /dev/null
@@ -1,14 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit php-pear-r2
-
-DESCRIPTION="GNU Gettext file parser"
-
-LICENSE="PHP-3"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~hppa ppc64 ~s390 sparc x86"
-IUSE=""
-PATCHES=( "${FILESDIR/File_Gettext-0.4.2-construct.patch}" )
diff --git a/dev-php/PEAR-File_Gettext/files/File_Gettext-0.4.2-construct.patch b/dev-php/PEAR-File_Gettext/files/File_Gettext-0.4.2-construct.patch
deleted file mode 100644
index 3527814485ab..000000000000
--- a/dev-php/PEAR-File_Gettext/files/File_Gettext-0.4.2-construct.patch
+++ /dev/null
@@ -1,67 +0,0 @@
-diff -aurN a/File/Gettext/MO.php b/File/Gettext/MO.php
---- a/File/Gettext/MO.php 2012-03-03 22:00:49.000000000 -0500
-+++ b/File/Gettext/MO.php 2018-02-16 15:15:17.725027132 -0500
-@@ -60,6 +60,10 @@
- * @access public
- * @return object File_Gettext_MO
- */
-+ function __construct($file = '')
-+ {
-+ $this->file = $file;
-+ }
- function File_Gettext_MO($file = '')
- {
- $this->file = $file;
-diff -aurN a/File/Gettext/PO.php b/File/Gettext/PO.php
---- a/File/Gettext/PO.php 2012-03-03 22:00:49.000000000 -0500
-+++ b/File/Gettext/PO.php 2018-02-16 15:14:57.997419162 -0500
-@@ -42,6 +42,10 @@
- * @access public
- * @return object File_Gettext_PO
- */
-+ function __construct($file = '')
-+ {
-+ $this->file = $file;
-+ }
- function File_Gettext_PO($file = '')
- {
- $this->file = $file;
-diff -aurN a/File/Gettext.php b/File/Gettext.php
---- a/File/Gettext.php 2012-03-03 22:00:49.000000000 -0500
-+++ b/File/Gettext.php 2018-02-16 15:14:27.629022634 -0500
-@@ -85,7 +85,7 @@
- return File_Gettext::raiseError($php_errormsg);
- }
- $class = 'File_Gettext_' . $format;
-- $obref = &new $class($file);
-+ $obref = new $class($file);
- return $obref;
- }
-
-@@ -110,7 +110,7 @@
-
- include_once 'File/Gettext/PO.php';
-
-- $PO = &new File_Gettext_PO($pofile);
-+ $PO = new File_Gettext_PO($pofile);
- if (true !== ($e = $PO->load())) {
- return $e;
- }
-@@ -247,7 +247,7 @@
- function &toMO()
- {
- include_once 'File/Gettext/MO.php';
-- $MO = &new File_Gettext_MO;
-+ $MO = new File_Gettext_MO;
- $MO->fromArray($this->toArray());
- return $MO;
- }
-@@ -261,7 +261,7 @@
- function &toPO()
- {
- include_once 'File/Gettext/PO.php';
-- $PO = &new File_Gettext_PO;
-+ $PO = new File_Gettext_PO;
- $PO->fromArray($this->toArray());
- return $PO;
- }
diff --git a/dev-php/PEAR-File_Gettext/metadata.xml b/dev-php/PEAR-File_Gettext/metadata.xml
deleted file mode 100644
index 222c77f3742a..000000000000
--- a/dev-php/PEAR-File_Gettext/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>php-bugs@gentoo.org</email>
- <name>PHP</name>
- </maintainer>
-</pkgmetadata>