summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-26 19:33:31 +0200
committerMichał Górny <mgorny@gentoo.org>2023-03-26 20:02:19 +0200
commit1007035f85b46ea8145fd11a9813696fdeb60c5e (patch)
tree3f209601e9facdf4c531f6873cbc41fcec776fea /dev-python/filelock
parentdev-python/django-filter: Bump to 23.1 (diff)
downloadgentoo-1007035f85b46ea8145fd11a9813696fdeb60c5e.tar.gz
gentoo-1007035f85b46ea8145fd11a9813696fdeb60c5e.tar.bz2
gentoo-1007035f85b46ea8145fd11a9813696fdeb60c5e.zip
dev-python/filelock: Bump to 3.10.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/filelock')
-rw-r--r--dev-python/filelock/Manifest1
-rw-r--r--dev-python/filelock/filelock-3.10.6.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/filelock/Manifest b/dev-python/filelock/Manifest
index 101ce1453ea6..16b79f0b37d4 100644
--- a/dev-python/filelock/Manifest
+++ b/dev-python/filelock/Manifest
@@ -3,5 +3,6 @@ DIST filelock-3.10.2.tar.gz 10259 BLAKE2B 9d36408d7c86347cb985c5dcaaf8640ba30437
DIST filelock-3.10.3.tar.gz 10283 BLAKE2B bbe49a0dcb2947668bbb5392ac4aa79cc1aa5325fc5214866a57f92c91c041ca4a3767d4f81d11d079ee86d71faf91c65b7c297c604618b53eed490281eaaf07 SHA512 9d94ea7800636d28e2861285ca2771430ef60306a64f842bd753d4201d0ab96f51b2b73d15c8fc5b146653fa7a6b9a268d6ddeec182dd0b400e0c18d47e91dca
DIST filelock-3.10.4.tar.gz 10285 BLAKE2B 7cfd908f2e30e610d635b874611aabbdf6d4d835fc27ad3bf360cb71603ea94eb30e5e98b6802724a617fb4aca57c015e5980400796cfd53d2a251b46e668246 SHA512 7f1c535c13353715efd9d64caca30347ccd5ec18b758c1edacc4a31a2c1cad7dbc43a59c331b88315563e3b2009859a980251492df8058d82240cdd1853f25f9
DIST filelock-3.10.5.tar.gz 10473 BLAKE2B 8cd19ef5a7bf1d49affcb02a7a1e864f7be40b4ba1bf05d5bf926b33466ea355bd34244f561596bafbe73315baa1ff2012cad0a85575bb336331ac4b84010658 SHA512 4c577ce6f99bd8f59d846182abff1c1be5fa310d97e73c36436a317d7af76187a38725d4a8524d2e1b272de95a297dfba9d0e1f8dfd3e6bab0d97f6bd05661b6
+DIST filelock-3.10.6.tar.gz 10478 BLAKE2B dfb9fdc81da83b99833d5412a09ac697ee2488815672f12d798a88c7211d1d9cfe7a7300f35ce2ae6fa018784b0227a79c9ed4a3f96c881c117a6fe3b9d6c03f SHA512 82b962ee2d22788d272f6149bef3587fa2213cce4fad1c843911fcb28f1bbb529c93e09ad854a5abff5dabea0375bd9b797be4dc141b8633f590954c257173b3
DIST filelock-3.9.1.tar.gz 9720 BLAKE2B 4225d718f5c6e7c81e5db5d6ac2af42ce78a6c61b59f85bf8c2aafd71509b4811542e7a7648ffa2b14f3b3e762d975296c095e322e6c6ccf8fa5f1839213531d SHA512 7a240b0014a6570099106c72b376c47b7b23cddc3e70f78e2560ccccfcee31d1078d894c2e3ec6fed2f983859543a84cac03f8834df9e64fcb0a966308f7503e
DIST py-filelock-3.9.0.gh.tar.gz 205047 BLAKE2B 3995f7ad27bb09ca75310c4ada7645f2dd16c09ddb39663394f315443851037f2f9cf08eecb507eba521479696ad1004978d3fdd300a7128ac3354fce2e57d5f SHA512 1235ae9ebdb4c84b0c30e68be91e01eb1acbfcd15c85202fa54a3b91e4e507f221926f8886e1ec91acd4f71d2d88c08f536529b4cebfd2de4fb90118f5dc242e
diff --git a/dev-python/filelock/filelock-3.10.6.ebuild b/dev-python/filelock/filelock-3.10.6.ebuild
new file mode 100644
index 000000000000..86d1f81ea020
--- /dev/null
+++ b/dev-python/filelock/filelock-3.10.6.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2018-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A platform independent file lock for Python"
+HOMEPAGE="
+ https://github.com/tox-dev/py-filelock/
+ https://pypi.org/project/filelock/
+"
+
+LICENSE="Unlicense"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest