summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/ijson
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/ijson')
-rw-r--r--dev-python/ijson/Manifest4
-rw-r--r--dev-python/ijson/ijson-1.1.ebuild20
-rw-r--r--dev-python/ijson/ijson-2.0.ebuild20
-rw-r--r--dev-python/ijson/ijson-2.1.ebuild20
-rw-r--r--dev-python/ijson/ijson-2.2.ebuild24
-rw-r--r--dev-python/ijson/metadata.xml9
6 files changed, 97 insertions, 0 deletions
diff --git a/dev-python/ijson/Manifest b/dev-python/ijson/Manifest
new file mode 100644
index 000000000000..dfa4c60ac55a
--- /dev/null
+++ b/dev-python/ijson/Manifest
@@ -0,0 +1,4 @@
+DIST ijson-1.1.tar.gz 8415 SHA256 33d10eac83d6dd757e2861b4ce06b3467a828481d608017af3d0caeb023ba32a SHA512 aebb3e46688b785a18366230b9f94c1b36d44f0764d8603b7ae50a2426b53eddad883c5d1fbda8f52d655d789880f1a7329bc6d1383ed963e9835d7ec40bdfdf WHIRLPOOL 3921e6fa8f0f8a1b17aa234cdcdcf3fc0d3bb97fce78803b84502ac762f5526cc526ee5fc48d65ecf4e88cde90be71414ef4912bf95781070e5266b7b3809f7b
+DIST ijson-2.0.tar.gz 9560 SHA256 85bfc06b2bb492f205bc5dd9531ff0e64d2e18e03e64665934715d58331c1dd8 SHA512 8ea8b89766d3e3ccc3f0bf348ba9068cd80f24aa7648e7bfd2272e701430445f2ab81744280dce8dde9e18dd0582f0fde784aae61493479b4f5a44a5175d7fc7 WHIRLPOOL 495e023bc79b5ffe55e50975af3c6fb65993156b2a9a32e1b98b1891fc8235c739d854baf511625fba5b1806fcbef8944809e3de13e7feaaedfeb8489c6d7fe3
+DIST ijson-2.1.tar.gz 9859 SHA256 bc69a512399db0469f5faabe34f9f7ce21964d1993c6a6720cc4cea911fb8a45 SHA512 67773540c1d7df6aaaf22b064d0ea7660c8b69b4371a15ec9f46228f1ebbe604aa29b1d93821f62928b41841ecd411419d39c636aae7dddacffd2b8d881d865e WHIRLPOOL ede0bb85abad4023d06eeb036249ffeb2aaafb95774da9a280cb765e2ac0c5e40dfa3ca80a0f043616884391da97d95847ff727e4593ecc9c3db045606c1567b
+DIST ijson-2.2.tar.gz 10282 SHA256 58aeeeda35c9d72061a34861ca7ff7b214e701e413b65f8e9ec06589c4aa2d30 SHA512 bcfc3571ccf6b011e745a2bf84b50ba3793e999cbebb0a2d377d56fa68d5068ecf549457fd14de6849059bc909f2493d6def41c1df581e1283e2826eb1b789b4 WHIRLPOOL 72c0210500f64ec39dfffb9c6aa5f7dcb2b969981bf908af55c554666687694bf0f68912281acdb019cc1beace31ea646c3aaf6bb34330d877ac3d1d1e83aa5f
diff --git a/dev-python/ijson/ijson-1.1.ebuild b/dev-python/ijson/ijson-1.1.ebuild
new file mode 100644
index 000000000000..9f1b05b7c0e9
--- /dev/null
+++ b/dev-python/ijson/ijson-1.1.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Iterative JSON parser with a Pythonic interface"
+HOMEPAGE="https://github.com/isagalaev/ijson http://pypi.python.org/pypi/ijson/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-libs/yajl"
+DEPEND="${RDEPEND}"
diff --git a/dev-python/ijson/ijson-2.0.ebuild b/dev-python/ijson/ijson-2.0.ebuild
new file mode 100644
index 000000000000..9a20a775ad3a
--- /dev/null
+++ b/dev-python/ijson/ijson-2.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Iterative JSON parser with a Pythonic interface"
+HOMEPAGE="https://github.com/isagalaev/ijson http://pypi.python.org/pypi/ijson/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+RDEPEND="dev-libs/yajl"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
diff --git a/dev-python/ijson/ijson-2.1.ebuild b/dev-python/ijson/ijson-2.1.ebuild
new file mode 100644
index 000000000000..2a133942b253
--- /dev/null
+++ b/dev-python/ijson/ijson-2.1.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Iterative JSON parser with a Pythonic interface"
+HOMEPAGE="https://github.com/isagalaev/ijson http://pypi.python.org/pypi/ijson/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-libs/yajl"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
diff --git a/dev-python/ijson/ijson-2.2.ebuild b/dev-python/ijson/ijson-2.2.ebuild
new file mode 100644
index 000000000000..03204571e259
--- /dev/null
+++ b/dev-python/ijson/ijson-2.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Iterative JSON parser with a Pythonic interface"
+HOMEPAGE="https://github.com/isagalaev/ijson http://pypi.python.org/pypi/ijson/"
+SRC_URI="https://github.com/isagalaev/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-libs/yajl"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ ${EPYTHON} tests.py || die
+}
diff --git a/dev-python/ijson/metadata.xml b/dev-python/ijson/metadata.xml
new file mode 100644
index 000000000000..be2e905889cf
--- /dev/null
+++ b/dev-python/ijson/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">ijson</remote-id>
+ <remote-id type="github">isagalaev/ijson</remote-id>
+ </upstream>
+</pkgmetadata>