summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2020-06-04 13:50:55 -0700
committerPatrick McLean <chutzpah@gentoo.org>2020-06-04 13:51:27 -0700
commit6437783817bd159dd7d09dfe8f906162f5c244a4 (patch)
tree1351c0fc8c477906cd66bf91e1044340dc650e30 /dev-python/pytest-services
parentsys-apps/groff: arm64 stable (bug #704420) (diff)
downloadgentoo-6437783817bd159dd7d09dfe8f906162f5c244a4.tar.gz
gentoo-6437783817bd159dd7d09dfe8f906162f5c244a4.tar.bz2
gentoo-6437783817bd159dd7d09dfe8f906162f5c244a4.zip
dev-python/pytest-services-2.0.1: Add missing test deps (bug #708652)
Closes: https://bugs.gentoo.org/708652 Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/pytest-services')
-rw-r--r--dev-python/pytest-services/pytest-services-2.0.1.ebuild16
1 files changed, 11 insertions, 5 deletions
diff --git a/dev-python/pytest-services/pytest-services-2.0.1.ebuild b/dev-python/pytest-services/pytest-services-2.0.1.ebuild
index cecaf44b17d6..a2eec91512b4 100644
--- a/dev-python/pytest-services/pytest-services-2.0.1.ebuild
+++ b/dev-python/pytest-services/pytest-services-2.0.1.ebuild
@@ -4,6 +4,7 @@
EAPI=7
PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1
DESCRIPTION="Collection of fixtures and utility functions to run service processes for pytest"
@@ -15,16 +16,21 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~x86"
IUSE="test"
-RDEPEND="dev-python/requests[${PYTHON_USEDEP}]
+RDEPEND="
+ dev-python/requests[${PYTHON_USEDEP}]
dev-python/psutil[${PYTHON_USEDEP}]
dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/zc-lockfile[${PYTHON_USEDEP}]"
-BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
+ dev-python/zc-lockfile[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? ( ${RDEPEND}
dev-python/mock[${PYTHON_USEDEP}]
dev-python/pylibmc[${PYTHON_USEDEP}]
x11-base/xorg-server[xvfb]
- )"
+ net-misc/memcached
+ !dev-python/pytest-salt
+ )
+"
RESTRICT="!test? ( test )"