summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-09-09 14:39:36 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-09-09 15:39:09 +0200
commitf0c784a9e10dc0daf0036e3adaab760947c55eaf (patch)
tree2e6f61dbe13507c6b768b2767f8c3f6a2ea71f96 /dev-python/pytest-tornasync
parentdev-util/plan9port: new snapshot (diff)
downloadgentoo-f0c784a9e10dc0daf0036e3adaab760947c55eaf.tar.gz
gentoo-f0c784a9e10dc0daf0036e3adaab760947c55eaf.tar.bz2
gentoo-f0c784a9e10dc0daf0036e3adaab760947c55eaf.zip
dev-python/pytest-tornasync: import from ::sci
Package-Manager: Portage-3.0.22, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python/pytest-tornasync')
-rw-r--r--dev-python/pytest-tornasync/Manifest1
-rw-r--r--dev-python/pytest-tornasync/metadata.xml13
-rw-r--r--dev-python/pytest-tornasync/pytest-tornasync-0.6.0_p2.ebuild35
3 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/pytest-tornasync/Manifest b/dev-python/pytest-tornasync/Manifest
new file mode 100644
index 000000000000..591d86f01ace
--- /dev/null
+++ b/dev-python/pytest-tornasync/Manifest
@@ -0,0 +1 @@
+DIST pytest-tornasync-0.6.0.post2.tar.gz 6201 BLAKE2B 6b6a2f941e649fb33373ef39b9d848d68a8af0f5e0d1a5e4496a9160e8e63ea108832437e87382c8203bb2c75673fad37b4ebd76157913199eb1661cd0216591 SHA512 2e258913b17a5442d18928833ee7e9771b6dbd148dbf251a7661432a54d4b9f9f3a7c396134eb544c0e3ce0af48c99d2d632399ac6ebdcf148187a7a523f4974
diff --git a/dev-python/pytest-tornasync/metadata.xml b/dev-python/pytest-tornasync/metadata.xml
new file mode 100644
index 000000000000..2b85afa59328
--- /dev/null
+++ b/dev-python/pytest-tornasync/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">pytest-tornasync</remote-id>
+ <remote-id type="github">eukaryote/pytest-tornasync</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pytest-tornasync/pytest-tornasync-0.6.0_p2.ebuild b/dev-python/pytest-tornasync/pytest-tornasync-0.6.0_p2.ebuild
new file mode 100644
index 000000000000..7beeaea50ebf
--- /dev/null
+++ b/dev-python/pytest-tornasync/pytest-tornasync-0.6.0_p2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pytest plugin for testing Python 3.5+ Tornado code"
+HOMEPAGE="https://github.com/eukaryote/pytest-tornasync"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P//_p/.post}.tar.gz"
+S="${WORKDIR}/${P//_p/.post}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# TODO: fix this
+# E ImportError: cannot import name 'MESSAGE' from 'test'
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-python/pytest-3.0[${PYTHON_USEDEP}]
+ >=www-servers/tornado-5.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Do not install the license file
+ sed -i -e '/LICENSE/d' setup.py || die
+
+ distutils-r1_python_prepare_all
+}