summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-11-04 08:26:30 +0100
committerMichał Górny <mgorny@gentoo.org>2020-11-04 08:34:07 +0100
commit2ba57a24fe855d096ccb474c2df798ca8d314c1d (patch)
tree55b6765411ccc4a7e95997a49b4c9664c05c13a6 /dev-python/python-memcached
parentdev-python/pgspecial: Remove old (diff)
downloadgentoo-2ba57a24fe855d096ccb474c2df798ca8d314c1d.tar.gz
gentoo-2ba57a24fe855d096ccb474c2df798ca8d314c1d.tar.bz2
gentoo-2ba57a24fe855d096ccb474c2df798ca8d314c1d.zip
dev-python/python-memcached: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-memcached')
-rw-r--r--dev-python/python-memcached/Manifest1
-rw-r--r--dev-python/python-memcached/python-memcached-1.59.ebuild47
2 files changed, 0 insertions, 48 deletions
diff --git a/dev-python/python-memcached/Manifest b/dev-python/python-memcached/Manifest
index 00b745958fa7..ad992bd85f4b 100644
--- a/dev-python/python-memcached/Manifest
+++ b/dev-python/python-memcached/Manifest
@@ -1,2 +1 @@
DIST python-memcached-1.59-gh.tar.gz 32334 BLAKE2B de8d18ba887b03e4737b554cc4b0074a4f16745e26a8b3631a747c45019e1da83612677dc3e98f97d76e851320c61baafbd0a29231a826c14b7d3bf3e477f29e SHA512 d7ff45a329f2a9bf97fdc7c0268c2c67046c3501270fcf03578b955c2da35904d7bdecd4239924d390797ddff8f4cc69fc5743f4d4f663cdb9f2f8c7e8159512
-DIST python-memcached-1.59.tar.gz 22210 BLAKE2B 50387821d50cf974ada738346e016eb736043078721bf905782f41df1f27574244d03b6b94ac9e5ccab7aeecfa8ca4c5a78cec2c41d15fda8756c7cb3bce9aa1 SHA512 a25cbb9efb3babe85e1523bdabfe4644b93b3a6a7268787a3928f724f833ce0eea7d2ef676d1b7f894cdfe293129975b35cb46ec553c92810dbc18013bfabece
diff --git a/dev-python/python-memcached/python-memcached-1.59.ebuild b/dev-python/python-memcached/python-memcached-1.59.ebuild
deleted file mode 100644
index d394de416857..000000000000
--- a/dev-python/python-memcached/python-memcached-1.59.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit distutils-r1
-
-DESCRIPTION="Pure python memcached client"
-HOMEPAGE="
- https://www.tummy.com/Community/software/python-memcached/
- https://pypi.org/project/python-memcached/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="OSL-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 ppc x86 ~amd64-linux ~x86-linux ~x86-macos"
-IUSE="test"
-
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- net-misc/memcached
- dev-python/nose[${PYTHON_USEDEP}]
- )"
-RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
-
-# Tests try to connect to memcached via TCP/IP. Please do not re-enable
-# until you get them all to pass properly while using the UNIX socket
-# only and not even trying to connect to memcached over TCP/IP.
-RESTRICT=test
-
-python_test() {
- # Note: partial. Needs fixing. Stuff like that.
-
- cd "${TMPDIR}" || die
-
- local memcached_opts=( -d -P memcached.pid -s memcached.socket )
- [[ ${EUID} == 0 ]] && memcached_opts+=( -u portage )
-
- memcached "${memached_opts[@]}" || die
-
- "${PYTHON}" memcache.py --do-unix || die "Tests fail with ${EPYTHON}"
-
- kill "$(<memcached.pid)" || die
- rm memcached.pid || die
-}