summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-06 16:17:24 +0100
committerMichał Górny <mgorny@gentoo.org>2023-03-06 16:22:29 +0100
commit74d9309efb6a5046354a150d8dc9a167b341cafb (patch)
tree6dbef9dd69d266b3dd5b0814b5a0f4de6a5cfda4 /dev-python/python-memcached
parentdev-python/python-memcached: Use unittest instead of nose (diff)
downloadgentoo-74d9309efb6a5046354a150d8dc9a167b341cafb.tar.gz
gentoo-74d9309efb6a5046354a150d8dc9a167b341cafb.tar.bz2
gentoo-74d9309efb6a5046354a150d8dc9a167b341cafb.zip
dev-python/python-memcached: EAPI 8, PEP517
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-memcached')
-rw-r--r--dev-python/python-memcached/Manifest1
-rw-r--r--dev-python/python-memcached/python-memcached-1.59-r2.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/python-memcached/Manifest b/dev-python/python-memcached/Manifest
index ad992bd85f4b..0cf6825f7023 100644
--- a/dev-python/python-memcached/Manifest
+++ b/dev-python/python-memcached/Manifest
@@ -1 +1,2 @@
DIST python-memcached-1.59-gh.tar.gz 32334 BLAKE2B de8d18ba887b03e4737b554cc4b0074a4f16745e26a8b3631a747c45019e1da83612677dc3e98f97d76e851320c61baafbd0a29231a826c14b7d3bf3e477f29e SHA512 d7ff45a329f2a9bf97fdc7c0268c2c67046c3501270fcf03578b955c2da35904d7bdecd4239924d390797ddff8f4cc69fc5743f4d4f663cdb9f2f8c7e8159512
+DIST python-memcached-1.59.gh.tar.gz 32334 BLAKE2B de8d18ba887b03e4737b554cc4b0074a4f16745e26a8b3631a747c45019e1da83612677dc3e98f97d76e851320c61baafbd0a29231a826c14b7d3bf3e477f29e SHA512 d7ff45a329f2a9bf97fdc7c0268c2c67046c3501270fcf03578b955c2da35904d7bdecd4239924d390797ddff8f4cc69fc5743f4d4f663cdb9f2f8c7e8159512
diff --git a/dev-python/python-memcached/python-memcached-1.59-r2.ebuild b/dev-python/python-memcached/python-memcached-1.59-r2.ebuild
new file mode 100644
index 000000000000..7271e700ea66
--- /dev/null
+++ b/dev-python/python-memcached/python-memcached-1.59-r2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{9..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pure python memcached client"
+HOMEPAGE="
+ https://github.com/linsomniac/python-memcached/
+ https://pypi.org/project/python-memcached/
+"
+SRC_URI="
+ https://github.com/linsomniac/python-memcached/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="OSL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ net-misc/memcached
+ )
+"
+
+distutils_enable_tests unittest
+
+python_test() {
+ local pidfile="${TMPDIR}/memcached.pid"
+
+ memcached -d -P "${pidfile}" || die "failed to start memcached"
+
+ eunittest || die "Tests fail with ${EPYTHON}"
+
+ kill "$(<"${pidfile}")" || die "failed to kill memcached"
+ local elapsed=0
+ while [[ -f ${pidfile} ]]; do
+ if [[ $(( elapsed++ )) -ge 30 ]]; then
+ kill -KILL "$(<"${pidfile}")" ||
+ die "failed to kill -KILL memcached"
+ die "memcached failed to stop after 30 seconds"
+ fi
+ sleep 1
+ done
+}