summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-27 17:44:03 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-27 17:44:03 +0200
commit188c535828afb195195c096752a882a05c775620 (patch)
tree76dcbb2302e9b2075355f4e3f875e171cb9607f7 /dev-python/signature-dispatch
parentdev-python/Nuitka: Bump to 1.7.7 (diff)
downloadgentoo-188c535828afb195195c096752a882a05c775620.tar.gz
gentoo-188c535828afb195195c096752a882a05c775620.tar.bz2
gentoo-188c535828afb195195c096752a882a05c775620.zip
Rename dev-python/{signature_dispatch → signature-dispatch}
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/signature-dispatch')
-rw-r--r--dev-python/signature-dispatch/Manifest1
-rw-r--r--dev-python/signature-dispatch/metadata.xml12
-rw-r--r--dev-python/signature-dispatch/signature-dispatch-1.0.1.ebuild30
3 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/signature-dispatch/Manifest b/dev-python/signature-dispatch/Manifest
new file mode 100644
index 000000000000..8fff41ba4459
--- /dev/null
+++ b/dev-python/signature-dispatch/Manifest
@@ -0,0 +1 @@
+DIST signature_dispatch-1.0.1.tar.gz 15348 BLAKE2B 35356caae5f6f7ba28494c02142addb581a36520b8becd2e0e132f1e4a37002870c981475688b758a4733341d67cc4cb30b2a7b69b3d106570766eeed36104fc SHA512 656fb47c50d865d1afec53f389154e783792bcedd7443442a142d19bcbd352fe0eff41ae9ef74378bafc164bb386a8e9a6f57d762f34ad23557a44a5d0d0f5de
diff --git a/dev-python/signature-dispatch/metadata.xml b/dev-python/signature-dispatch/metadata.xml
new file mode 100644
index 000000000000..ef90611fa33d
--- /dev/null
+++ b/dev-python/signature-dispatch/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">kalekundert/signature_dispatch</remote-id>
+ <remote-id type="pypi">signature-dispatch</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/signature-dispatch/signature-dispatch-1.0.1.ebuild b/dev-python/signature-dispatch/signature-dispatch-1.0.1.ebuild
new file mode 100644
index 000000000000..19d13a97f45b
--- /dev/null
+++ b/dev-python/signature-dispatch/signature-dispatch-1.0.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Execute the first function that matches the given arguments"
+HOMEPAGE="
+ https://github.com/kalekundert/signature_dispatch/
+ https://pypi.org/project/signature-dispatch/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_tests pytest
+
+RDEPEND="
+ >=dev-python/typeguard-3.0.0[${PYTHON_USEDEP}]
+"
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -o addopts=
+}