summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-07-19 20:44:33 +0200
committerMichał Górny <mgorny@gentoo.org>2024-07-19 21:56:18 +0200
commit0d71bd5757e92f02d835aec012bc6d61688bed01 (patch)
treeee717baf062db472fdc952e555d1b7686b8535cd /dev-python/sympy
parentdev-python/oslo-log: Bump to 6.1.1 (diff)
downloadgentoo-0d71bd5757e92f02d835aec012bc6d61688bed01.tar.gz
gentoo-0d71bd5757e92f02d835aec012bc6d61688bed01.tar.bz2
gentoo-0d71bd5757e92f02d835aec012bc6d61688bed01.zip
dev-python/sympy: Bump to 1.13.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sympy')
-rw-r--r--dev-python/sympy/Manifest1
-rw-r--r--dev-python/sympy/sympy-1.13.1.ebuild106
2 files changed, 107 insertions, 0 deletions
diff --git a/dev-python/sympy/Manifest b/dev-python/sympy/Manifest
index 7eb97578eeab..97ca95a0cfad 100644
--- a/dev-python/sympy/Manifest
+++ b/dev-python/sympy/Manifest
@@ -1,2 +1,3 @@
DIST sympy-1.12.1.gh.tar.gz 8025309 BLAKE2B 01fe3e95716b0efcf682613fb8ba6f149f4f4dc4ad3f20eb816d85f30042af1cd5860d3d157d4c26458520cc2f8e994ae6671058a7a0d5237e7f15d0e61f9e53 SHA512 9b50d2b0e8e9628c38296f8d1e25c83b1b9fa1503166b48cc344709217393b00910ad3441a1da0e81e6faf56e5db7a33bc96926918da024cafc77fb4957f94a4
DIST sympy-1.13.0.gh.tar.gz 8124299 BLAKE2B 0aedeb4005aa7ee32470d6fd89494cfb68667b579bce33b189016347d136c6e961b0bc226bf638ba9ee5f14fa5c239af5e27de7da2a45dbf6fb16abf2d79cae9 SHA512 1a0d794d5a48d8b46cf87635753d316d807e14eb98c8c880e815168c5ac2c479608ec3c2b0ff786611736f9e68a2941a05fa31f187e83b84e1ce10d72099a6b6
+DIST sympy-1.13.1.gh.tar.gz 8130206 BLAKE2B 92ecaccddc5e48ac8e338488ff67cd0b6fdd9b40105334a82fc81c2ae4e6162a369ce142c6a61041698378d2c08eb5f95595702c35219a90d797485176f6fb23 SHA512 3e742ec74b6f774660a43b93c8b8a14ad97fbcf998c2ce15a6512ced5003804f4dec34f8beb3ad1f45f0f0a701110d1a81d6855075db03436cc77c101b33d7ea
diff --git a/dev-python/sympy/sympy-1.13.1.ebuild b/dev-python/sympy/sympy-1.13.1.ebuild
new file mode 100644
index 000000000000..92c208153ac7
--- /dev/null
+++ b/dev-python/sympy/sympy-1.13.1.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Computer Algebra System in pure Python"
+HOMEPAGE="
+ https://www.sympy.org/
+ https://github.com/sympy/sympy/
+ https://pypi.org/project/sympy/
+"
+# pypi sdist misses some files, notably top-level conftest.py, as of 1.12.1_rc1
+SRC_URI="
+ https://github.com/sympy/sympy/archive/${PV/_/}.tar.gz
+ -> ${P/_/}.gh.tar.gz
+"
+S=${WORKDIR}/${P/_/}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="examples imaging ipython latex mathml opengl pdf png pyglet symengine texmacs"
+
+RDEPEND="
+ >=dev-python/mpmath-1.1.0[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ imaging? ( dev-python/pillow[${PYTHON_USEDEP}] )
+ ipython? (
+ dev-python/ipython[${PYTHON_USEDEP}]
+ )
+ latex? (
+ virtual/latex-base
+ dev-texlive/texlive-fontsextra
+ png? ( app-text/dvipng )
+ pdf? ( app-text/ghostscript-gpl )
+ )
+ mathml? ( dev-python/lxml[${PYTHON_USEDEP}] )
+ opengl? ( dev-python/pyopengl[${PYTHON_USEDEP}] )
+ pyglet? ( dev-python/pyglet[${PYTHON_USEDEP}] )
+ symengine? ( dev-python/symengine[${PYTHON_USEDEP}] )
+ texmacs? ( app-office/texmacs )
+"
+BDEPEND="
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_test() {
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # require old version of antlr4
+ sympy/parsing/tests/test_autolev.py
+ sympy/parsing/tests/test_latex.py
+ # crash due to assertions in sys-devel/llvm[debug]
+ sympy/parsing/tests/test_c_parser.py
+
+ # TODO: pytest?
+ sympy/solvers/ode/tests/test_systems.py::test_linear_3eq_order1_type4_long_check
+ sympy/solvers/ode/tests/test_systems.py::test_linear_3eq_order1_type4_long_dsolve_dotprodsimp
+
+ # either very slow or hanging
+ sympy/solvers/ode/tests/test_systems.py::test_linear_new_order1_type2_de_lorentz_slow_check
+ sympy/integrals/tests/test_failing_integrals.py::test_issue_15227
+ sympy/matrices/tests/test_matrices.py::test_pinv_rank_deficient_when_diagonalization_fails
+ sympy/solvers/ode/tests/test_systems.py::test_nonlinear_3eq_order1_type1
+ sympy/solvers/ode/tests/test_systems.py::test_nonlinear_3eq_order1_type3
+
+ # known broken
+ # https://github.com/sympy/sympy/issues/26321
+ sympy/solvers/tests/test_simplex.py::test_lp
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ nonfatal epytest --veryquickcheck ||
+ die -n "Tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ local DOCS=( AUTHORS README.md )
+
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ distutils-r1_python_install_all
+
+ if use texmacs; then
+ exeinto /usr/libexec/TeXmacs/bin/
+ doexe data/TeXmacs/bin/tm_sympy
+ insinto /usr/share/TeXmacs/plugins/sympy/
+ doins -r data/TeXmacs/progs
+ fi
+}