summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/transmissionrpc
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/transmissionrpc')
-rw-r--r--dev-python/transmissionrpc/Manifest2
-rw-r--r--dev-python/transmissionrpc/metadata.xml12
-rw-r--r--dev-python/transmissionrpc/transmissionrpc-0.11.ebuild39
-rw-r--r--dev-python/transmissionrpc/transmissionrpc-9999.ebuild33
4 files changed, 86 insertions, 0 deletions
diff --git a/dev-python/transmissionrpc/Manifest b/dev-python/transmissionrpc/Manifest
new file mode 100644
index 000000000000..26ba5ce77c01
--- /dev/null
+++ b/dev-python/transmissionrpc/Manifest
@@ -0,0 +1,2 @@
+DIST transmissionrpc-0.11.tar.gz 96091 SHA256 ec43b460f9fde2faedbfa6d663ef495b3fd69df855a135eebe8f8a741c0dde60 SHA512 778c4099264d38deefbcf05c8f9e5d165ce113b4180e3797eb3cf11f0a9ba5393c0b2e6f1f0ae7c2dcfc679bfc1d0d69cb3715b3db6ac90a1a840fbd0775f82f WHIRLPOOL fabee8985ce38d6430aa80fdda1ea90d244a33cd50f1cb8200b10e81b607000e119cb70a9dd7ed5276ed8384e5dc32f1fb47ab50143b4cbec535ed759989ec64
+DIST ubuntu-12.04.2-alternate-amd64.iso.torrent 28541 SHA256 2fe13c38b0b9ab9b1d3d92c53af8f8c0be5e9d36dd270591deee922bdcceaf64 SHA512 a597d9c5258111cb9c42dfcbb0804e093b6c69d4cdf178c961de1d52ec64e75f76d078700b59535e631575e42d3a995844ac0d30c9f7e852ab1ece149ec1f6de WHIRLPOOL 36323cf11643be4fd51b2dc658c0bd96b2dafc5ceffeed71cfdc6603520e78cc52ba19ace46b642e03fb950aae7b6b9ca7e3c0ee2f2790341820cf06ff52f71d
diff --git a/dev-python/transmissionrpc/metadata.xml b/dev-python/transmissionrpc/metadata.xml
new file mode 100644
index 000000000000..ad30f06856c9
--- /dev/null
+++ b/dev-python/transmissionrpc/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>floppym@gentoo.org</email>
+ <name>Mike Gilbert</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">transmissionrpc</remote-id>
+ <remote-id type="bitbucket">blueluna/transmissionrpc</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/transmissionrpc/transmissionrpc-0.11.ebuild b/dev-python/transmissionrpc/transmissionrpc-0.11.ebuild
new file mode 100644
index 000000000000..cb0bbd3e195b
--- /dev/null
+++ b/dev-python/transmissionrpc/transmissionrpc-0.11.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+if [[ ${PV} != 9999 ]]; then
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz
+ https://bitbucket.org/blueluna/transmissionrpc/src/release-0.10/test/data/ubuntu-12.04.2-alternate-amd64.iso.torrent"
+ KEYWORDS="~amd64 ~x86"
+else
+ inherit mercurial
+ EHG_REPO_URI="https://bitbucket.org/blueluna/${PN}"
+ KEYWORDS=""
+fi
+
+DESCRIPTION="Python module that implements the Transmission bittorrent client RPC protocol"
+HOMEPAGE="https://bitbucket.org/blueluna/transmissionrpc"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+RDEPEND=">=dev-python/six-1.1.0[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cp "${DISTDIR}/ubuntu-12.04.2-alternate-amd64.iso.torrent" ${P}/test/data/ || die
+}
+
+python_test() {
+ esetup.py test
+}
diff --git a/dev-python/transmissionrpc/transmissionrpc-9999.ebuild b/dev-python/transmissionrpc/transmissionrpc-9999.ebuild
new file mode 100644
index 000000000000..80cf369aedf6
--- /dev/null
+++ b/dev-python/transmissionrpc/transmissionrpc-9999.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+if [[ ${PV} != 9999 ]]; then
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+else
+ inherit mercurial
+ EHG_REPO_URI="https://bitbucket.org/blueluna/${PN}"
+ KEYWORDS=""
+fi
+
+DESCRIPTION="Python module that implements the Transmission bittorrent client RPC protocol"
+HOMEPAGE="https://bitbucket.org/blueluna/transmissionrpc"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+RDEPEND=">=dev-python/six-1.1.0[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ esetup.py test
+}