summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/zfec
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/zfec')
-rw-r--r--dev-python/zfec/Manifest1
-rw-r--r--dev-python/zfec/metadata.xml16
-rw-r--r--dev-python/zfec/zfec-1.4.24.ebuild30
3 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/zfec/Manifest b/dev-python/zfec/Manifest
new file mode 100644
index 000000000000..56543f02247d
--- /dev/null
+++ b/dev-python/zfec/Manifest
@@ -0,0 +1 @@
+DIST zfec-1.4.24.tar.gz 175884 SHA256 e3e99e6e67ac9af72c0f918f03d2051e17d41f48ee0134d0d2c81e7fe92749cf SHA512 ec213912eea054c954ddda67a401b1538fb2f02c2b56cdfb610df5f4852b79305ef72e9919c578d46a268ea4c5912a60422117326f633c7e9b8a7977561fa1f5 WHIRLPOOL ffbfda6ea69ece90b33ed8d6e39372c373e32c287cbc1fd7fda25f07b851e17fb85386ed2514f4326f8a3e190577dc7280fc26ebe4eb3a50fa0487642a785247
diff --git a/dev-python/zfec/metadata.xml b/dev-python/zfec/metadata.xml
new file mode 100644
index 000000000000..0924b9d9b1c4
--- /dev/null
+++ b/dev-python/zfec/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <longdescription lang="en">
+ Generate redundant blocks of information such that if some of
+ the blocks are lost then the original data can be recovered from
+ the remaining blocks. This package includes command-line tools,
+ C API, Python API, and Haskell API.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">zfec</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/zfec/zfec-1.4.24.ebuild b/dev-python/zfec/zfec-1.4.24.ebuild
new file mode 100644
index 000000000000..2b51590f3a99
--- /dev/null
+++ b/dev-python/zfec/zfec-1.4.24.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+inherit distutils-r1
+
+DESCRIPTION="Fast erasure codec which can be used with the command-line, C, Python, or Haskell"
+HOMEPAGE="https://pypi.python.org/pypi/zfec"
+SRC_URI="mirror://pypi/z/zfec/zfec-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+COMMON_DEPEND=""
+RDEPEND="${COMMON_DEPEND}
+ dev-python/pyutil[${PYTHON_USEDEP}]
+ dev-python/zbase32[${PYTHON_USEDEP}]"
+DEPEND="${COMMON_DEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+src_install() {
+ distutils-r1_src_install
+
+ rm -rf "${ED%/}"/usr/share/doc/${PN}
+}