summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-08-17 18:30:03 +0200
committerMichał Górny <mgorny@gentoo.org>2024-08-17 18:55:16 +0200
commit73748318f8e7be95d163edfb8bae73e76ddb74c4 (patch)
tree776bcefd8df66b1d52667b7d04510b1220637bfd /dev-python
parentdev-python/griffe: Remove old (diff)
downloadgentoo-73748318f8e7be95d163edfb8bae73e76ddb74c4.tar.gz
gentoo-73748318f8e7be95d163edfb8bae73e76ddb74c4.tar.bz2
gentoo-73748318f8e7be95d163edfb8bae73e76ddb74c4.zip
dev-python/griffe: Bump to 1.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/griffe/Manifest1
-rw-r--r--dev-python/griffe/griffe-1.1.0.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/griffe/Manifest b/dev-python/griffe/Manifest
index 3149e9b33903..642968b24974 100644
--- a/dev-python/griffe/Manifest
+++ b/dev-python/griffe/Manifest
@@ -1 +1,2 @@
DIST griffe-1.0.0.gh.tar.gz 378841 BLAKE2B a71007a09585b1ef0b17c867177f01e0e38984075f1450a6957a65427c3b9fb2486bbf7fa0b41f3c8ce289003e514eeaaefe0b679181d843a8b57befca39a8b4 SHA512 5a286c293f39b0df185345c00954d61e130cf3942aa8dede56180330dff5150043d77bf48ef14bc01c8b1af0af19de8651344d3f3a8fbf850ece1c4c04d17513
+DIST griffe-1.1.0.gh.tar.gz 379874 BLAKE2B 452d98f1248866ee159229aec84bc99f7f83bc9c22505c809ea0de2b9bf6342ffddae42f694c30a2b696de081a34d886e42270a1c6a68aedc5a9f544112889da SHA512 a443c3094c4044b58537b5fa781610d99e26be195df216b74a097257596f52ecc7021ba5fb504c82f7960154b8d3a00fa05cc63526e538291486e915ef44cc51
diff --git a/dev-python/griffe/griffe-1.1.0.ebuild b/dev-python/griffe/griffe-1.1.0.ebuild
new file mode 100644
index 000000000000..b3ab8d048238
--- /dev/null
+++ b/dev-python/griffe/griffe-1.1.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=pdm-backend
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Signature generator for Python programs"
+HOMEPAGE="
+ https://mkdocstrings.github.io/griffe/
+ https://github.com/mkdocstrings/griffe/
+ https://pypi.org/project/griffe/
+"
+# Tests need files absent from the PyPI tarballs
+SRC_URI="
+ https://github.com/mkdocstrings/griffe/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv"
+
+RDEPEND="
+ >=dev-python/colorama-0.4[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/backports-strenum-1.3[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+BDEPEND="
+ test? (
+ >=dev-python/jsonschema-4.17[${PYTHON_USEDEP}]
+ dev-python/mkdocstrings[${PYTHON_USEDEP}]
+ >=dev-python/pytest-xdist-2.4[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export PDM_BUILD_SCM_VERSION=${PV}
+
+EPYTEST_DESELECT=(
+ # fragile to installed packages
+ # (failed on PySide2 for me)
+ tests/test_stdlib.py::test_fuzzing_on_stdlib
+)