summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2016-06-27 22:40:19 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2016-06-27 22:42:57 +0100
commita2bc2463c651af12b93f4d46d6d4d890ec94ee45 (patch)
tree47004e8e476f2b70300827c27c3f5b1ebb9a67ca /dev-util/ltrace
parentmedia-libs/libvorbis: fix building with Clang (diff)
downloadgentoo-a2bc2463c651af12b93f4d46d6d4d890ec94ee45.tar.gz
gentoo-a2bc2463c651af12b93f4d46d6d4d890ec94ee45.tar.bz2
gentoo-a2bc2463c651af12b93f4d46d6d4d890ec94ee45.zip
dev-util/ltrace: restore basic alpha support
Builds successfully on gcc-5.4.0 and can trace calls to calls like 'gcc -v'. Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-util/ltrace')
-rw-r--r--dev-util/ltrace/files/ltrace-0.7.3-alpha-protos.patch14
-rw-r--r--dev-util/ltrace/ltrace-0.7.3_p4.ebuild5
2 files changed, 17 insertions, 2 deletions
diff --git a/dev-util/ltrace/files/ltrace-0.7.3-alpha-protos.patch b/dev-util/ltrace/files/ltrace-0.7.3-alpha-protos.patch
new file mode 100644
index 000000000000..659952bdf148
--- /dev/null
+++ b/dev-util/ltrace/files/ltrace-0.7.3-alpha-protos.patch
@@ -0,0 +1,14 @@
+Fix build failure on alpha:
+ plt.c:32:12: error: dereferencing pointer to incomplete type ‘struct library_symbol’
+ return sym->enter_addr;
+ ^
+diff -U0 -raN ltrace-0.7.3/sysdeps/linux-gnu/alpha/plt.c ltrace-0.7.3/sysdeps/linux-gnu/alpha/plt.c
+--- ltrace-0.7.3_p4/work/ltrace-0.7.3/sysdeps/linux-gnu/alpha/plt.c 2012-11-10 13:43:55.000000000 +0100
++++ foo/work/ltrace-0.7.3/sysdeps/linux-gnu/alpha/plt.c 2016-06-27 23:21:28.000000000 +0200
+@@ -23,0 +24 @@
++#include "library.h"
+diff -U0 -raN ltrace-0.7.3/sysdeps/linux-gnu/alpha/trace.c ltrace-0.7.3/sysdeps/linux-gnu/alpha/trace.c
+--- ltrace-0.7.3_p4/work/ltrace-0.7.3/sysdeps/linux-gnu/alpha/trace.c 2016-06-27 23:30:08.000000000 +0200
++++ foo/work/ltrace-0.7.3/sysdeps/linux-gnu/alpha/trace.c 2016-06-27 23:25:20.000000000 +0200
+@@ -29,0 +30 @@
++#include "backend.h"
diff --git a/dev-util/ltrace/ltrace-0.7.3_p4.ebuild b/dev-util/ltrace/ltrace-0.7.3_p4.ebuild
index 5ee60c23cd3c..22394b2c64e4 100644
--- a/dev-util/ltrace/ltrace-0.7.3_p4.ebuild
+++ b/dev-util/ltrace/ltrace-0.7.3_p4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -17,7 +17,7 @@ SRC_URI="
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="-alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
IUSE="debug selinux test unwind"
RDEPEND="dev-libs/elfutils
@@ -32,6 +32,7 @@ S=${WORKDIR}/${PN}-${LTRACE_V}
src_prepare() {
epatch "${WORKDIR}"/debian/patches/[0-9]*
epatch "${FILESDIR}"/${PN}-0.7.3-test-protos.patch #bug 421649
+ epatch "${FILESDIR}"/${PN}-0.7.3-alpha-protos.patch
sed -i '/^dist_doc_DATA/d' Makefile.am || die
eautoreconf
}