summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-07-20 20:11:26 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-07-20 20:14:18 -0400
commit1116a3506008948831a89beee42095efc0a0bd61 (patch)
tree2e2fe4583c77d60dfd3fee5b5acd6bf6b4bc5f8a /dev-util/maturin
parentsys-block/gparted: Stabilize 1.4.0-r1 ppc, #853958 (diff)
downloadgentoo-1116a3506008948831a89beee42095efc0a0bd61.tar.gz
gentoo-1116a3506008948831a89beee42095efc0a0bd61.tar.bz2
gentoo-1116a3506008948831a89beee42095efc0a0bd61.zip
dev-util/maturin: disable rustls on arches where ring is broken
Upstream already disables for some but this doesn't carry over to tests. Bug: https://bugs.gentoo.org/859577 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-util/maturin')
-rw-r--r--dev-util/maturin/maturin-0.13.0.ebuild13
1 files changed, 13 insertions, 0 deletions
diff --git a/dev-util/maturin/maturin-0.13.0.ebuild b/dev-util/maturin/maturin-0.13.0.ebuild
index b02807a0ef99..64d1038971fb 100644
--- a/dev-util/maturin/maturin-0.13.0.ebuild
+++ b/dev-util/maturin/maturin-0.13.0.ebuild
@@ -381,6 +381,19 @@ src_prepare() {
use !debug || sed -i "s/^cargo_args = \[/&'--profile','dev',/" setup.py || die
filter-lto # undefined references with ring crate
+
+ # ensure rustls is disabled on arches where ring crate is problematic,
+ # keep in sync with src_configure below (bug #859577)
+ if use ppc64 || use s390; then
+ sed -i '/^if platform.machine/s/^if/if True or/' setup.py || die
+ fi
+}
+
+src_configure() {
+ if use ppc64 || use s390; then
+ local myfeatures=( upload log human-panic ) # sync with setup.py
+ cargo_src_configure --no-default-features
+ fi
}
python_compile_all() {