summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/qmtest
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/qmtest')
-rw-r--r--dev-util/qmtest/Manifest1
-rw-r--r--dev-util/qmtest/metadata.xml5
-rw-r--r--dev-util/qmtest/qmtest-2.4.1-r1.ebuild34
-rw-r--r--dev-util/qmtest/qmtest-2.4.1.ebuild36
4 files changed, 76 insertions, 0 deletions
diff --git a/dev-util/qmtest/Manifest b/dev-util/qmtest/Manifest
new file mode 100644
index 000000000000..3538da0cbd53
--- /dev/null
+++ b/dev-util/qmtest/Manifest
@@ -0,0 +1 @@
+DIST qmtest-2.4.1.tar.gz 2792290 SHA256 106b591ffae7c879afd147f21bfb37a2f5c3ea484988f54289d91063df567a04 SHA512 01a8b317fd5ae3d653b81d031005975d745829eda4b7d4d57c85cc13b71c142213dce053ba13999bf42a1b9b17118075e2c244c67e5c4c8a957d35d2850ae372 WHIRLPOOL 795d160ed71f2e5ab4453151a1d1d8bb9cc9d745a06823e9c4dd11a47e0c8c22cccce3688730016de9407dcab1d12b20abf0a44356d8f6bddbfba17139c115a8
diff --git a/dev-util/qmtest/metadata.xml b/dev-util/qmtest/metadata.xml
new file mode 100644
index 000000000000..effbbf33eac8
--- /dev/null
+++ b/dev-util/qmtest/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer><email>maintainer-needed@gentoo.org</email></maintainer>
+</pkgmetadata>
diff --git a/dev-util/qmtest/qmtest-2.4.1-r1.ebuild b/dev-util/qmtest/qmtest-2.4.1-r1.ebuild
new file mode 100644
index 000000000000..faeac0eb7c88
--- /dev/null
+++ b/dev-util/qmtest/qmtest-2.4.1-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+DISTUTILS_SINGLE_IMPL=1
+
+inherit distutils-r1
+
+DESCRIPTION="CodeSourcery's test harness system"
+HOMEPAGE="http://www.codesourcery.com/qmtest/"
+SRC_URI="http://www.codesourcery.com/public/${PN}/${P}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_install() {
+ distutils-r1_src_install
+ find "${D}" -name config.py -print0 | xargs -0 sed -i "s:${D}:/usr:"
+ rm -r "${D}"usr/share/doc/${PN}/{COPYING,LICENSE.OPL} || die
+ mv "${D}"usr/share/doc/${PN}/* "${D}"usr/share/doc/${PF} || die
+ rm -r "${D}"/usr/share/doc/${PN} || die
+}
diff --git a/dev-util/qmtest/qmtest-2.4.1.ebuild b/dev-util/qmtest/qmtest-2.4.1.ebuild
new file mode 100644
index 000000000000..fe18a236aab9
--- /dev/null
+++ b/dev-util/qmtest/qmtest-2.4.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+PYTHON_DEPEND="2"
+
+inherit distutils
+
+DESCRIPTION="CodeSourcery's test harness system"
+HOMEPAGE="http://www.codesourcery.com/qmtest/"
+SRC_URI="http://www.codesourcery.com/public/${PN}/${PF}/${PF}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~mips x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+PYTHON_MODNAME="qm"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_install() {
+ distutils_src_install
+ find "${D}" -name config.py -print0 | xargs -0 sed -i "s:${D}:/usr:"
+ dodir /usr/share/doc/${PF}
+ rm -r "${D}"/usr/share/doc/${PN}/{COPYING,LICENSE.OPL} || die
+ mv "${D}"/usr/share/doc/${PN}/* "${D}"/usr/share/doc/${PF} || die
+ rm -r "${D}"/usr/share/doc/${PN} || die
+}