summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /gnome-extra/gnome-dvb-daemon
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'gnome-extra/gnome-dvb-daemon')
-rw-r--r--gnome-extra/gnome-dvb-daemon/Manifest1
-rw-r--r--gnome-extra/gnome-dvb-daemon/gnome-dvb-daemon-0.2.10.ebuild74
-rw-r--r--gnome-extra/gnome-dvb-daemon/metadata.xml9
3 files changed, 84 insertions, 0 deletions
diff --git a/gnome-extra/gnome-dvb-daemon/Manifest b/gnome-extra/gnome-dvb-daemon/Manifest
new file mode 100644
index 000000000000..3d742554d249
--- /dev/null
+++ b/gnome-extra/gnome-dvb-daemon/Manifest
@@ -0,0 +1 @@
+DIST gnome-dvb-daemon-0.2.10.tar.xz 696372 SHA256 c23fcd4744c91bda065036a1a9b4a77b4665d7ca237f489e89a4c2f3133adcfb SHA512 9bf99f3b9d3c6a96a0fd193e41d98017f60ffa6255ae5fea52d2360fed0a3f292fc28c59060f54eb58e321e32e06693f5443bd3a4aba41cbd579a07a3c9691fb WHIRLPOOL 18eaa5739788ae3d9c44ce596105b64fcf608a875d4aba224abe18c8e1eac14d388c22126a61c92abe5efbf54c1cfc37400eb6b70fb457f597b4cdc1cb3573d6
diff --git a/gnome-extra/gnome-dvb-daemon/gnome-dvb-daemon-0.2.10.ebuild b/gnome-extra/gnome-dvb-daemon/gnome-dvb-daemon-0.2.10.ebuild
new file mode 100644
index 000000000000..1b2e4a9bf0b9
--- /dev/null
+++ b/gnome-extra/gnome-dvb-daemon/gnome-dvb-daemon-0.2.10.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+GCONF_DEBUG="no"
+PYTHON_DEPEND="2:2.5"
+VALA_MIN_API_VERSION="0.16"
+
+inherit eutils python gnome2 multilib vala
+
+DESCRIPTION="Setup your DVB devices, record and watch TV shows and browse EPG using GStreamer"
+HOMEPAGE="https://live.gnome.org/DVBDaemon"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64"
+IUSE="nls totem vala"
+
+RDEPEND=">=dev-libs/glib-2.32.0:2
+ >=media-libs/gstreamer-0.10.29:0.10
+ >=media-libs/gst-plugins-good-0.10.14:0.10
+ >=media-libs/gst-plugins-bad-0.10.13:0.10
+ >=dev-libs/libgee-0.5:0
+ >=dev-db/sqlite-3.4
+ >=media-libs/gst-rtsp-server-0.10.7:0.10
+ media-plugins/gst-plugins-dvb:0.10
+ dev-python/gst-python:0.10
+ >=dev-python/pygobject-3.2.1:3
+ >=dev-libs/gobject-introspection-0.10.8
+ x11-libs/gtk+:3[introspection]
+ virtual/libgudev
+ vala? ( $(vala_depend) )
+ totem? ( media-video/totem )"
+DEPEND="${RDEPEND}
+ >=dev-lang/perl-5.8.1
+ >=dev-util/intltool-0.40.0
+ virtual/pkgconfig
+ nls? ( >=sys-devel/gettext-0.18.1 )
+ >=sys-devel/libtool-2.2.6"
+
+pkg_setup() {
+ G2CONF="${G2CONF} \
+ $(use_enable nls)
+ $(use_enable totem totem-plugin)"
+ use totem && G2CONF="${G2CONF} \
+ --with-totem-plugin-dir=/usr/$(get_libdir)/totem/plugins"
+
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ python_clean_py-compile_files
+ python_convert_shebangs -r 2 .
+ gnome2_src_prepare
+ use vala && vala_src_prepare
+}
+
+pkg_postinst() {
+ python_mod_optimize gnomedvb
+ if use totem; then
+ python_mod_optimize "/usr/$(get_libdir)/totem/plugins"
+ fi
+ gnome2_pkg_postinst
+}
+
+pkg_postrm() {
+ python_mod_cleanup gnomedvb
+ if use totem; then
+ python_mod_cleanup "/usr/$(get_libdir)/totem/plugins"
+ fi
+ gnome2_pkg_postrm
+}
diff --git a/gnome-extra/gnome-dvb-daemon/metadata.xml b/gnome-extra/gnome-dvb-daemon/metadata.xml
new file mode 100644
index 000000000000..222c199b4a12
--- /dev/null
+++ b/gnome-extra/gnome-dvb-daemon/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnome</herd>
+<use>
+ <flag name="totem">Build a plugin for <pkg>media-video/totem</pkg></flag>
+ <flag name="vala">Add support for <pkg>dev-lang/vala</pkg></flag>
+</use>
+</pkgmetadata>