summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-07-23 10:01:46 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-07-23 11:13:41 -0400
commit86b56d2c66b0ad21cd449bfefa53c22c49ff4a76 (patch)
tree52c91ccf4c25230ce5d40006fdcd94493bfcbe0c /gui-libs
parentgui-libs/eglexternalplatform: move .pc file to /usr/share (diff)
downloadgentoo-86b56d2c66b0ad21cd449bfefa53c22c49ff4a76.tar.gz
gentoo-86b56d2c66b0ad21cd449bfefa53c22c49ff4a76.tar.bz2
gentoo-86b56d2c66b0ad21cd449bfefa53c22c49ff4a76.zip
gui-libs/egl-gbm: add multilib support
To match NVIDIA that started shipping egl-gbm/wayland 32bit variant in >=nvidia-drivers-560 to let 32bit applications work right on wayland. ...albeit this is rather uncommon given most 32bit applications would be using xwayland at best, but do not want an unexpected setup that may confuse some things like steam or wine's new wayland support. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'gui-libs')
-rw-r--r--gui-libs/egl-gbm/egl-gbm-1.1.1-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/gui-libs/egl-gbm/egl-gbm-1.1.1-r1.ebuild b/gui-libs/egl-gbm/egl-gbm-1.1.1-r1.ebuild
new file mode 100644
index 000000000000..4ec0bbc9775c
--- /dev/null
+++ b/gui-libs/egl-gbm/egl-gbm-1.1.1-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson-multilib
+
+DESCRIPTION="GBM EGL external platform library"
+HOMEPAGE="https://github.com/NVIDIA/egl-gbm/"
+SRC_URI="
+ https://github.com/NVIDIA/egl-gbm/archive/${PV}.tar.gz
+ -> ${P}.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+RDEPEND="
+ media-libs/mesa[gbm(+),${MULTILIB_USEDEP}]
+ x11-libs/libdrm[${MULTILIB_USEDEP}]
+"
+DEPEND="
+ ${RDEPEND}
+ >=gui-libs/eglexternalplatform-1.1-r1
+ media-libs/libglvnd
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.1.0-werror.patch
+)
+
+src_install() {
+ meson-multilib_src_install
+
+ insinto /usr/share/egl/egl_external_platform.d
+ doins "${FILESDIR}"/15_nvidia_gbm.json
+}