summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2023-04-27 16:56:09 +0200
committerPacho Ramos <pacho@gentoo.org>2023-04-27 16:56:09 +0200
commitda921b9a45dabcebc70594e997f20e1426704454 (patch)
tree06de38805d6b1bf4b83e90519c50ce679919a34c /mate-extra/mate-polkit/mate-polkit-1.26.0-r1.ebuild
parentnet-p2p/deluge: Fix ayatana indicators detection (diff)
downloadgentoo-da921b9a45dabcebc70594e997f20e1426704454.tar.gz
gentoo-da921b9a45dabcebc70594e997f20e1426704454.tar.bz2
gentoo-da921b9a45dabcebc70594e997f20e1426704454.zip
mate-extra/mate-polkit: Support ayatana indicators
Backported patch from future 1.28 release Closes: https://bugs.gentoo.org/898394 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'mate-extra/mate-polkit/mate-polkit-1.26.0-r1.ebuild')
-rw-r--r--mate-extra/mate-polkit/mate-polkit-1.26.0-r1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/mate-extra/mate-polkit/mate-polkit-1.26.0-r1.ebuild b/mate-extra/mate-polkit/mate-polkit-1.26.0-r1.ebuild
new file mode 100644
index 000000000000..720be36f5713
--- /dev/null
+++ b/mate-extra/mate-polkit/mate-polkit-1.26.0-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit mate
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
+fi
+
+DESCRIPTION="A MATE specific DBUS service that is used to bring up authentication dialogs"
+LICENSE="LGPL-2"
+SLOT="0"
+
+IUSE="accountsservice appindicator"
+
+COMMON_DEPEND="x11-libs/gdk-pixbuf:2
+ virtual/libintl:0
+ >=x11-libs/gtk+-3.22.0:3
+ appindicator? ( dev-libs/libayatana-appindicator )"
+
+RDEPEND="${COMMON_DEPEND}
+ >=dev-libs/glib-2.50:2
+ >=sys-auth/polkit-0.102
+ accountsservice? ( sys-apps/accountsservice )"
+
+BDEPEND="${COMMON_DEPEND}
+ dev-util/gtk-doc
+ dev-util/gtk-doc-am
+ >=dev-util/intltool-0.35
+ sys-devel/gettext
+ >=sys-devel/libtool-2.2.6
+ virtual/pkgconfig"
+
+PATCHES=(
+ # https://github.com/mate-desktop/mate-polkit/commit/65a6c367e28e338dc74931dece1af9e53338276f
+ "${FILESDIR}/${P}-ayatana.patch"
+)
+
+src_configure() {
+ mate_src_configure \
+ --disable-static \
+ $(use_enable accountsservice) \
+ $(use_enable appindicator)
+}