summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOz Tiram <oz.tiram@gmail.com>2022-11-30 09:29:56 +0100
committerSam James <sam@gentoo.org>2022-12-03 01:04:14 +0000
commit438797567262d42d336ffd2e433dc864b901e364 (patch)
tree4f60331f7c48cc13cb0ec3fc08d38f862135dade /mate-extra/mate-utils
parentmate-extra/mate-user-share: add 1.26.0 (diff)
downloadgentoo-438797567262d42d336ffd2e433dc864b901e364.tar.gz
gentoo-438797567262d42d336ffd2e433dc864b901e364.tar.bz2
gentoo-438797567262d42d336ffd2e433dc864b901e364.zip
mate-extra/mate-utils: add 1.26.0
Signed-off-by: Oz Tiram <oz.tiram@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'mate-extra/mate-utils')
-rw-r--r--mate-extra/mate-utils/Manifest1
-rw-r--r--mate-extra/mate-utils/mate-utils-1.26.0.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/mate-extra/mate-utils/Manifest b/mate-extra/mate-utils/Manifest
index 007d46c6012e..b65949aed4f1 100644
--- a/mate-extra/mate-utils/Manifest
+++ b/mate-extra/mate-utils/Manifest
@@ -1 +1,2 @@
DIST mate-utils-1.24.0.tar.xz 7930068 BLAKE2B 0e2c82afbc2d8a90b8c31d56d9bfbb3a477b1e9cd67108e52c96f4087d09336ed9e6980551e39b43797743b9ef86cc2beabfa84fd7a5820e38122e0d0a7c968d SHA512 d8945c85936a55d22f3ed94c9858ba84cadf552a63cdd2d9eec9120111ad71526ac88772f8e4b7a6a460b691574534e52706fba35a0395b1d894b27eece9e92c
+DIST mate-utils-1.26.0.tar.xz 7984892 BLAKE2B 9785ecc232f06241bfc389550226d0a099a543c91b9c131e1f2b8998dccd4152c4c056070b10dcd3b98f4d59be87304b999998a10192257aaa682834f6d544e5 SHA512 c8752f6b43a836adc647ec8a9eef4fcea782914994d27ee8491406188da584aa98244d0ba402005beecc293d1b6e50a9ed5339467011e05f301a6b98c2374b91
diff --git a/mate-extra/mate-utils/mate-utils-1.26.0.ebuild b/mate-extra/mate-utils/mate-utils-1.26.0.ebuild
new file mode 100644
index 000000000000..174cada33d81
--- /dev/null
+++ b/mate-extra/mate-utils/mate-utils-1.26.0.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MATE_LA_PUNT="yes"
+
+inherit mate
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
+fi
+
+DESCRIPTION="Utilities for the MATE desktop"
+LICENSE="FDL-1.1+ GPL-2+ GPL-3+ LGPL-2+"
+SLOT="0"
+
+IUSE="X applet debug ipv6 nls test udisks"
+RESTRICT="!test? ( test )"
+
+COMMON_DEPEND="
+ >=app-accessibility/at-spi2-core-2.46.0
+ >=dev-libs/glib-2.50:2
+ >=gnome-base/libgtop-2.12:2=
+ >=media-libs/libcanberra-0.4[gtk3]
+ sys-libs/zlib
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-3.22:3
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/pango
+ applet? ( >=mate-base/mate-panel-1.17.0 )
+ udisks? ( >=sys-fs/udisks-1.90.0:2 )
+"
+
+RDEPEND="${COMMON_DEPEND}
+ mate-base/mate-desktop
+ virtual/libintl
+"
+
+BDEPEND="${COMMON_DEPEND}
+ app-text/rarian
+ >=app-text/scrollkeeper-dtd-1:1.0
+ app-text/yelp-tools
+ dev-libs/libxml2
+ dev-util/glib-utils
+ dev-util/gtk-doc
+ dev-util/gtk-doc-am
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ x11-base/xorg-proto
+"
+
+src_prepare() {
+ # Make apps visible in all DEs.
+ LC_ALL=C find . -iname '*.desktop.in*' -exec \
+ sed -e '/OnlyShowIn/d' -i {} + || die
+
+ mate_src_prepare
+}
+
+src_configure() {
+ mate_src_configure \
+ --enable-zlib \
+ --enable-debug=$(usex debug yes minimum) \
+ $(use_with X x) \
+ $(use_enable applet gdict-applet) \
+ $(use_enable ipv6) \
+ $(use_enable nls) \
+ $(use_enable udisks disk_image_mounter)
+}