summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jordan <immoloism@gmail.com>2024-04-06 15:22:47 +0100
committerArthur Zamarin <arthurzam@gentoo.org>2024-04-09 20:19:15 +0300
commit3803f7929578d76669c58da2f10969d098a74585 (patch)
treeac7c9f1507368dce7100db9678dfae035d09ae8e /mate-extra
parentmate-extra/mate-netbook: drop 1.27.0 (diff)
downloadgentoo-3803f7929578d76669c58da2f10969d098a74585.tar.gz
gentoo-3803f7929578d76669c58da2f10969d098a74585.tar.bz2
gentoo-3803f7929578d76669c58da2f10969d098a74585.zip
mate-extra/mate-polkit: add 1.28.1
Signed-off-by: Ian Jordan <immoloism@gmail.com> Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'mate-extra')
-rw-r--r--mate-extra/mate-polkit/Manifest1
-rw-r--r--mate-extra/mate-polkit/mate-polkit-1.28.1.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/mate-extra/mate-polkit/Manifest b/mate-extra/mate-polkit/Manifest
index 09bc7e1d7027..0fbdd47692b2 100644
--- a/mate-extra/mate-polkit/Manifest
+++ b/mate-extra/mate-polkit/Manifest
@@ -1,3 +1,4 @@
DIST mate-polkit-1.26.0.tar.xz 335768 BLAKE2B 15b1fd38efcb157802ff96f09879a8790d6a8356d6fe75f833bcd4b9f088e30b019a7e0739d48000aed4a7d9b5634727c2176ce7b725d82431118c7da4e04f04 SHA512 393a8a0a9567ec75762dcd1e776a1544756f4b9b88b8bbb4f6d1ed87dcc25c30025e27d6f4e18c04c79f5f02152490f577fb89c758ce042dc466a387d9202e0f
DIST mate-polkit-1.26.1.tar.xz 344216 BLAKE2B 4ebb173bfc94f87199aa53cc9cede9a454969801b57a6702e85bf695ad23c7b2b29c62e1428d3b28afb32d96b98dfa6252142b0c23ad8f78fb0807f3cca866a4 SHA512 0c8e881991d90af3121212c2dbb931bcea9ab9b9d22e0664d866b8a2bc95f2427bba09635be35f1a01404efd83b567d8a3d947cca84562463591a7821fb85678
DIST mate-polkit-1.27.1.tar.xz 345096 BLAKE2B ffdf98fbfc8d840a441b33ef7db3e09ac9a651fa9af9d68df52b939abd5322f3fdba352114fbfc442ebbb794c50a305687f171ad38fe3b79182749cde7e6f0a9 SHA512 5dc91c02e8538c214b72ac799ac7724327e8c950837213a41f91ecdc25834b0ef059143f173f570b8ac1195a76b073c54a189e3067a91b3ca8382edaf98d740c
+DIST mate-polkit-1.28.1.tar.xz 347556 BLAKE2B 6ded6349b5e61c3b233365dd9d57377349416a813f7fc002fe15ee9d7f68ab1b006a5b19655222f8ca99a8e94bc2c55679f16ce080c5b489d2ba82f6384da7ce SHA512 fbe25e2f0beae8c681a38aef5bb213e719e45bf9f9d7685fc4f1a5d80d524340e706f9222f0acdd5f1b4a662de1d3a0c017ccabad0df35c8f4fe68526fad199c
diff --git a/mate-extra/mate-polkit/mate-polkit-1.28.1.ebuild b/mate-extra/mate-polkit/mate-polkit-1.28.1.ebuild
new file mode 100644
index 000000000000..0d4d07ef96d6
--- /dev/null
+++ b/mate-extra/mate-polkit/mate-polkit-1.28.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit mate
+
+MINOR=$(($(ver_cut 2) % 2))
+if [[ ${MINOR} -eq 0 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
+fi
+
+DESCRIPTION="A MATE specific DBUS service that is used to bring up authentication dialogs"
+LICENSE="LGPL-2"
+SLOT="0"
+
+IUSE="accountsservice appindicator"
+
+COMMON_DEPEND="x11-libs/gdk-pixbuf:2
+ virtual/libintl:0
+ >=x11-libs/gtk+-3.22.0:3
+ appindicator? ( dev-libs/libayatana-appindicator )"
+
+RDEPEND="${COMMON_DEPEND}
+ >=dev-libs/glib-2.50:2
+ >=sys-auth/polkit-0.102[daemon]
+ accountsservice? ( sys-apps/accountsservice )"
+
+BDEPEND="${COMMON_DEPEND}
+ dev-util/gtk-doc
+ dev-build/gtk-doc-am
+ >=dev-util/intltool-0.35
+ sys-devel/gettext
+ >=dev-build/libtool-2.2.6
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.27.1-configure.patch
+)
+
+src_configure() {
+ mate_src_configure \
+ --disable-static \
+ $(use_enable accountsservice) \
+ $(use_enable appindicator)
+}