summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-fonts/unifont/unifont-7.0.06.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-fonts/unifont/unifont-7.0.06.ebuild')
-rw-r--r--media-fonts/unifont/unifont-7.0.06.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/media-fonts/unifont/unifont-7.0.06.ebuild b/media-fonts/unifont/unifont-7.0.06.ebuild
new file mode 100644
index 000000000000..63d6ca099178
--- /dev/null
+++ b/media-fonts/unifont/unifont-7.0.06.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils font toolchain-funcs
+
+DESCRIPTION="GNU Unifont - a Pan-Unicode X11 bitmap iso10646 font"
+HOMEPAGE="http://unifoundry.com/"
+SRC_URI="mirror://gnu/${PN}/${P}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="fontforge utils"
+
+DEPEND="
+ fontforge? (
+ app-text/bdf2psf
+ dev-lang/perl
+ dev-perl/GD[png(-)]
+ media-gfx/fontforge
+ x11-apps/bdftopcf
+ )
+"
+RDEPEND="
+ utils? (
+ dev-lang/perl
+ dev-perl/GD[png(-)]
+ )
+"
+
+src_prepare() {
+ sed -i -e 's/install -s/install/' src/Makefile || die
+ epatch_user
+}
+
+src_compile() {
+ if use fontforge || use utils; then
+ tc-export CC
+ makeargs=(
+ CFLAGS="${CFLAGS}"
+ BUILDFONT=$(usex fontforge 1 '')
+ )
+ emake -j1 "${makeargs[@]}"
+ fi
+}
+
+src_install() {
+ makeargs+=(
+ DESTDIR="${ED%/}"
+ PCFDEST="${ED%/}${FONTDIR}"
+ TTFDEST="${ED%/}${FONTDIR}"
+ USRDIR=usr
+ )
+ use utils || makeargs+=( -C font )
+ emake -j1 "${makeargs[@]}" install
+ font_xfont_config
+ font_fontconfig
+}