summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Dummer <martin.dummer@gmx.net>2024-06-02 15:06:26 +0200
committerConrad Kostecki <conikost@gentoo.org>2024-06-22 21:09:49 +0200
commit9184ce871cb4a7bc7b1dd545f613ca3033018975 (patch)
tree5f72624f79496e3b840f246ae285249bf09f1d04 /media-plugins
parentmedia-plugins/vdr-calc: add 0.0.1_rc6 (diff)
downloadgentoo-9184ce871cb4a7bc7b1dd545f613ca3033018975.tar.gz
gentoo-9184ce871cb4a7bc7b1dd545f613ca3033018975.tar.bz2
gentoo-9184ce871cb4a7bc7b1dd545f613ca3033018975.zip
media-plugins/vdr-fritzbox: add 1.5.4
Signed-off-by: Martin Dummer <martin.dummer@gmx.net> Closes: https://github.com/gentoo/gentoo/pull/36975 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'media-plugins')
-rw-r--r--media-plugins/vdr-fritzbox/Manifest5
-rw-r--r--media-plugins/vdr-fritzbox/vdr-fritzbox-1.5.4.ebuild64
2 files changed, 69 insertions, 0 deletions
diff --git a/media-plugins/vdr-fritzbox/Manifest b/media-plugins/vdr-fritzbox/Manifest
index 14c79bf26080..ed3e634819f6 100644
--- a/media-plugins/vdr-fritzbox/Manifest
+++ b/media-plugins/vdr-fritzbox/Manifest
@@ -1 +1,6 @@
DIST vdr-fritzbox-1.5.3.tgz 132207 BLAKE2B c9a93e922eeb2126279409e3948c44cb1fc3348d44fbcc2c1116038d66fc77a707d3885a6d587c8996138fcaff134bb78db4dab2d122caf0293d2d8d8770e985 SHA512 d396bb1386ffc4b53867c735d4ffc710c4266067e011e17f2d4aa597ecceeb502d2c6e23a1df69f929503b2cd5d07f4d57869c890040b1ae9af1742c044541be
+DIST vdr-fritzbox-1.5.4.libconvpp.tar.gz 215666 BLAKE2B 58a49a3008be465e8a068692e7e39882e99d802380d2bcc9673aaac91e5474d3b8acbf130bc91b092a5d95387fcd11c264c46039134fc2305fe9cd58b0077952 SHA512 b7169d20e6034bc4b40c862175b8f57af474073e50175b1d99e3d0a6f096e1e9cb072d9932350d12a0470fd6e1a1386fc3cf0a19ffb94b9a1a2d683ed9725808
+DIST vdr-fritzbox-1.5.4.libfritzpp.tar.gz 370775 BLAKE2B f27c55e913fbdffa4dab57ae6ce666e06e132789b4ec7703f53d31d3acb18be00c997587e44191c8249f1faeb5c0da30e73eac11e3fb2b0ff8b77d04d2683be7 SHA512 72134fc6aaa5091e219ce70a8ec462203aa2af2fa8454c0541050ad487e727a92a1d6798dc54a30dbb0d60772ba69bae9a6f6ad7cef58e3066aeef1dffdcb2b0
+DIST vdr-fritzbox-1.5.4.liblogpp.tar.gz 9552 BLAKE2B 55ae5fb39918e3f2df8aa1cb9725fd9e8de8450fe041bff8b4077c6d61a66d4d94605dd43f09c34f5a80858c902fcb8e69480a553772f7bc340f587edf2b8260 SHA512 4ad36a6c5f3c8f0a7e2f151c565e8e099a204157d238987f2c44a906b4fde2b7781e599f890124295f6aecd43a5f1f8c00af6a2f29048b492e7c1094446c5950
+DIST vdr-fritzbox-1.5.4.libnetpp.tar.gz 216618 BLAKE2B 960a6b7b538608a71947f7bcaeee1f1cb6d17d578fc0f514f32b9f1bcb8b19fa1bfe7a31825201b6c68596d15e1f3adf3ed885b6a3e206a3087e5e15f73edfcb SHA512 98f38f5d97ffd4b45bcca29fd60c4de1c3224e9332872a8d317c8411840dacd892ca823de5bc5cd1ebc3df00367a7eeb18f8cdb0ca5c1528e0c5621ed4528b98
+DIST vdr-fritzbox-1.5.4.tar.gz 267844 BLAKE2B 416b8476848b535137741f42aabee96c1c933f58176c270656422ccf1298b26a5912f864e2735b45e326634fcb9f5ea53cef5cb4e1788c64c07f8487caad567d SHA512 c3c893a26863bb2a6c96313cafd7b8373de2b179f1c97cb6d9f58e3baa71373beceada8948553dad268ce9823f9ca95b5cb18b876e43f03d88f2f38a3c67a4d5
diff --git a/media-plugins/vdr-fritzbox/vdr-fritzbox-1.5.4.ebuild b/media-plugins/vdr-fritzbox/vdr-fritzbox-1.5.4.ebuild
new file mode 100644
index 000000000000..71c513cf8ddb
--- /dev/null
+++ b/media-plugins/vdr-fritzbox/vdr-fritzbox-1.5.4.ebuild
@@ -0,0 +1,64 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs vdr-plugin-2
+
+DESCRIPTION="VDR Plugin: Inform about incoming phone-calls and use the fritz!box phonebook"
+HOMEPAGE="https://github.com/jowi24/vdr-fritz"
+SRC_URI="https://github.com/jowi24/vdr-fritz/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/jowi24/libconvpp/archive/286a289e30417ac534c861529ae245ccb44286e5.tar.gz -> ${P}.libconvpp.tar.gz
+ https://github.com/jowi24/libfritzpp/archive/c74fd462285ade1054784b97b6dce22d55196c01.tar.gz -> ${P}.libfritzpp.tar.gz
+ https://github.com/jowi24/liblogpp/archive/d61e25f4548f40261e6db62a967776cfa16e599a.tar.gz -> ${P}.liblogpp.tar.gz
+ https://github.com/jowi24/libnetpp/archive/b32ecc8e64508f3b1158a2adcbd82034c71d7a38.tar.gz -> ${P}.libnetpp.tar.gz"
+S="${WORKDIR}/vdr-fritz-${PV}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-libs/libgcrypt:=
+ dev-libs/boost:=
+ media-video/vdr"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.5.3_clang.patch"
+)
+
+src_unpack() {
+ default
+
+ # source git repo has submodules, which are not included in main repo download.
+ # so each submodule is loaded separately und must be moved to the right place after unpack
+ mv libconvpp-*/* "${S}/libconv++/" || die
+ mv libfritzpp-*/* "${S}/libfritz++/" || die
+ mv liblogpp-*/* "${S}/liblog++/" || die
+ mv libnetpp-*/* "${S}/libnet++/" || die
+}
+
+src_prepare() {
+ vdr-plugin-2_src_prepare
+
+ # do not call ar directly
+ export _VDRAR="$(tc-getAR)"
+ sed -e "s:\@ar :\@\$(_VDRAR) :" \
+ -i libconv++/Makefile \
+ -i libfritz++/Makefile \
+ -i liblog++/Makefile \
+ -i libnet++/Makefile || die
+
+ # upstream author forgot to update version information
+ sed -e "s:1.5.3:1.5.4:" -i fritzbox.cpp || die
+}
+
+pkg_postinst() {
+ elog "It is recommend to update your firmware release to the latest."
+ elog
+ elog "The integrated call monitor (available in Fritz!Box official"
+ elog "firmware releases >= *.04.29) has to be enabled in order to"
+ elog "have the vdr-fritzbox plugin display anything on your tv. To"
+ elog "enable it call #96*5* from your telephone. If that doesn't"
+ elog "work for you, read the documentation for further instructions."
+}