summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/entagged-tageditor
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/entagged-tageditor')
-rw-r--r--media-sound/entagged-tageditor/Manifest1
-rw-r--r--media-sound/entagged-tageditor/entagged-tageditor-0.35.ebuild45
-rw-r--r--media-sound/entagged-tageditor/files/entagged-tageditor-0.35-buildfixes.patch31
-rw-r--r--media-sound/entagged-tageditor/metadata.xml8
4 files changed, 85 insertions, 0 deletions
diff --git a/media-sound/entagged-tageditor/Manifest b/media-sound/entagged-tageditor/Manifest
new file mode 100644
index 000000000000..96d09b22221f
--- /dev/null
+++ b/media-sound/entagged-tageditor/Manifest
@@ -0,0 +1 @@
+DIST entagged-tageditor-0.35.tar.gz 4606721 RMD160 24dbf8631a128a3ffd1eccaecdc6fe5d148bd281 SHA1 0ed0437bc938f2060d0793723f3ec22b7ee4d0df SHA256 c9e9b69a49bdf6646cc21dc3cc0734e6c54ac91e99774b1d87a6765b365611ac
diff --git a/media-sound/entagged-tageditor/entagged-tageditor-0.35.ebuild b/media-sound/entagged-tageditor/entagged-tageditor-0.35.ebuild
new file mode 100644
index 000000000000..6fcc228b543f
--- /dev/null
+++ b/media-sound/entagged-tageditor/entagged-tageditor-0.35.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils java-pkg-2 java-ant-2
+
+DESCRIPTION="Open-source audiofile tagger"
+HOMEPAGE="http://entagged.sourceforge.net/"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="|| ( GPL-2 LGPL-2.1 )"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+S="${WORKDIR}"
+
+RDEPEND=">=virtual/jre-1.5
+ dev-java/squareness-jlf
+ dev-db/hsqldb"
+
+DEPEND=">=virtual/jdk-1.5
+ dev-db/hsqldb"
+
+EANT_BUILD_XML="entagged/build.xml"
+EANT_BUILD_TARGET="build"
+
+src_unpack() {
+ unpack ${A}
+ mkdir -p test/entagged/junit || die
+ mv entagged/entagged/junit test/entagged || die
+ rm entagged/*.jar || die
+ java-pkg_jarfrom hsqldb hsqldb.jar entagged/hsqldb.jar
+ cd entagged || die
+ epatch "${FILESDIR}"/${P}-buildfixes.patch
+}
+
+src_install() {
+ cd entagged || die
+ java-pkg_newjar ${P}.jar ${PN}.jar
+ java-pkg_register-dependency squareness-jlf
+ java-pkg_dolauncher ${PN} --main entagged.tageditor.TagEditorFrameSplash
+ newicon entagged/tageditor/resources/icons/entagged-icon.png ${PN}.png
+ make_desktop_entry ${PN} "Entagged Tag Editor" ${PN}
+}
diff --git a/media-sound/entagged-tageditor/files/entagged-tageditor-0.35-buildfixes.patch b/media-sound/entagged-tageditor/files/entagged-tageditor-0.35-buildfixes.patch
new file mode 100644
index 000000000000..7b470e2dbeb5
--- /dev/null
+++ b/media-sound/entagged-tageditor/files/entagged-tageditor-0.35-buildfixes.patch
@@ -0,0 +1,31 @@
+--- build.xml 2007-03-23 16:25:25.000000000 +0200
++++ build.xml.fixed 2007-09-01 09:20:44.000000000 +0300
+@@ -30,7 +30,7 @@
+ <property name="entagged_dir" location="."/>
+ <property name="entagged_base_dir" location=".."/>
+ <property name="tageditor_dir" location="tageditor"/>
+- <property name="tageditor_version" value="0.21"/>
++ <property name="tageditor_version" value="0.35"/>
+ <property name="tageditor_jar" value="entagged-tageditor-${tageditor_version}.jar"/>
+ <property name="tageditor_zip" value="entagged-tageditor-${tageditor_version}.zip"/>
+ <property name="tageditor_tar" value="entagged-tageditor-${tageditor_version}.tar"/>
+@@ -52,7 +52,7 @@
+
+ <!-- Compile the sources -->
+ <target name="compile" depends="clean">
+- <javac srcdir="${entagged_dir}" classpath="${entagged_base_dir}" excludes="entagged/junit/*" source="1.4"/>
++ <javac srcdir="${entagged_dir}" classpath="hsqldb.jar" excludes="entagged/junit/*"/>
+ <echo>
+ Entagged Tag editor is now fully compiled.
+ You can use either:
+@@ -71,9 +71,8 @@
+ <!-- Prepares the classes to be packaged -->
+ <target name="build" depends="compile">
+ <!-- Jar the classes files -->
+- <jar destfile="${tageditor_jar}" basedir="${entagged_base_dir}" includes="entagged/**/*.class entagged/**/*.xsl entagged/**/*.dtd entagged/**/*.properties entagged/**/*.html entagged/tageditor/resources/**/*" excludes="**/*.java" >
++ <jar destfile="${tageditor_jar}" basedir="${entagged_base_dir}/entagged" includes="entagged/**/*.class entagged/**/*.xsl entagged/**/*.dtd entagged/**/*.properties entagged/**/*.html entagged/tageditor/resources/**/* miage/**/*.class" excludes="**/*.java" >
+ <manifest>
+- <attribute name="Class-Path" value="${tageditor_jar_classpath}"/>
+ <attribute name="Main-Class" value="${tageditor_jar_mainclass}"/>
+ </manifest>
+ </jar>
diff --git a/media-sound/entagged-tageditor/metadata.xml b/media-sound/entagged-tageditor/metadata.xml
new file mode 100644
index 000000000000..a2ac2e03bfbd
--- /dev/null
+++ b/media-sound/entagged-tageditor/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>java</herd>
+<maintainer>
+ <email>java@gentoo.org</email>
+</maintainer>
+</pkgmetadata>