summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/ezstream
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/ezstream')
-rw-r--r--media-sound/ezstream/Manifest2
-rw-r--r--media-sound/ezstream/ezstream-0.5.6.ebuild41
-rw-r--r--media-sound/ezstream/ezstream-0.6.0.ebuild41
-rw-r--r--media-sound/ezstream/files/ezstream.confd5
-rw-r--r--media-sound/ezstream/files/ezstream.initd33
-rw-r--r--media-sound/ezstream/metadata.xml5
6 files changed, 127 insertions, 0 deletions
diff --git a/media-sound/ezstream/Manifest b/media-sound/ezstream/Manifest
new file mode 100644
index 000000000000..765f2c2982e6
--- /dev/null
+++ b/media-sound/ezstream/Manifest
@@ -0,0 +1,2 @@
+DIST ezstream-0.5.6.tar.gz 263150 SHA256 818b7ab2a498ffe6e59155279cb79ed0291c4979210e99af6dda950fe54a30c0
+DIST ezstream-0.6.0.tar.gz 250448 SHA256 f86eb8163b470c3acbc182b42406f08313f85187bd9017afb8b79b02f03635c9 SHA512 d6b621db85a0d56dcc54a8b7a0136c25342ec507f04ab397a53f46a74e85e94806e17d0a0a59e66096b5c0d97b7f98eaba95a50c1ca6c8d82aed11b854d0d33d WHIRLPOOL 7f9960add62ec83c72fef7db8a7d7836a689879127ba7ad72f0584c152e74d76cef9def4f9251d3101b3e21b344ac8a64e47145969880c5f1fedead8ab80d398
diff --git a/media-sound/ezstream/ezstream-0.5.6.ebuild b/media-sound/ezstream/ezstream-0.5.6.ebuild
new file mode 100644
index 000000000000..8b245757c799
--- /dev/null
+++ b/media-sound/ezstream/ezstream-0.5.6.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+DESCRIPTION="A command line source client for Icecast media streaming servers"
+HOMEPAGE="http://www.icecast.org/ezstream.php"
+SRC_URI="http://downloads.xiph.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="taglib"
+
+COMMON_DEPEND="dev-libs/libxml2
+ >=media-libs/libshout-2.2
+ media-libs/libvorbis
+ taglib? ( media-libs/taglib )"
+RDEPEND="${COMMON_DEPEND}
+ net-misc/icecast"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ local docdir=/usr/share/doc/${PF}
+
+ econf \
+ --docdir=${docdir} \
+ --enable-examplesdir=${docdir}/examples \
+ $(use_with taglib)
+}
+
+src_install() {
+ default
+
+ newinitd "${FILESDIR}"/${PN}.initd ${PN} || die
+ newconfd "${FILESDIR}"/${PN}.confd ${PN} || die
+
+ rm -f "${D}"/usr/share/doc/${PF}/COPYING
+}
diff --git a/media-sound/ezstream/ezstream-0.6.0.ebuild b/media-sound/ezstream/ezstream-0.6.0.ebuild
new file mode 100644
index 000000000000..6e0a54642775
--- /dev/null
+++ b/media-sound/ezstream/ezstream-0.6.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="A command line source client for Icecast media streaming servers"
+HOMEPAGE="http://www.icecast.org/ezstream.php"
+SRC_URI="http://downloads.xiph.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="taglib"
+
+COMMON_DEPEND="dev-libs/libxml2
+ >=media-libs/libshout-2.2
+ media-libs/libvorbis
+ taglib? ( media-libs/taglib )"
+RDEPEND="${COMMON_DEPEND}
+ net-misc/icecast"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ local docdir=/usr/share/doc/${PF}
+
+ econf \
+ --docdir=${docdir} \
+ --enable-examplesdir=${docdir}/examples \
+ $(use_with taglib)
+}
+
+src_install() {
+ default
+
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+
+ rm -f "${D}"/usr/share/doc/${PF}/COPYING
+}
diff --git a/media-sound/ezstream/files/ezstream.confd b/media-sound/ezstream/files/ezstream.confd
new file mode 100644
index 000000000000..6480e0c7a71f
--- /dev/null
+++ b/media-sound/ezstream/files/ezstream.confd
@@ -0,0 +1,5 @@
+# Config location
+CONFIGFILE=""
+
+# Options
+EZSTREAM_OPTS=""
diff --git a/media-sound/ezstream/files/ezstream.initd b/media-sound/ezstream/files/ezstream.initd
new file mode 100644
index 000000000000..a5c0d56514c5
--- /dev/null
+++ b/media-sound/ezstream/files/ezstream.initd
@@ -0,0 +1,33 @@
+#!/sbin/runscript
+
+depend() {
+ need icecast
+}
+
+checkconfig() {
+ if [ ! -e ${CONFIGFILE} ]; then
+ eerror "You need to make a config file"
+ return 1
+ fi
+}
+
+start() {
+ checkconfig || return 1
+ ebegin "Starting ezstream"
+ start-stop-daemon --background --start --pidfile /var/run/ezstream.pid \
+ --make-pidfile --user icecast --group nogroup \
+ --exec /usr/bin/ezstream -- ${EZSTREAM_OPTS} -c "${CONFIGFILE}"
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping ezstream"
+ start-stop-daemon --stop --pidfile /var/run/ezstream.pid --name ezstream
+ eend $?
+}
+
+reload() {
+ ebegin "Reloading ezstream"
+ kill -1 `cat /var/run/ezstream.pid`
+ eend $?
+}
diff --git a/media-sound/ezstream/metadata.xml b/media-sound/ezstream/metadata.xml
new file mode 100644
index 000000000000..e1774e3d9ad7
--- /dev/null
+++ b/media-sound/ezstream/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sound</herd>
+</pkgmetadata>